Exclude checkbox does not work (v3.0.15.277 x32) [FIXED]

Similar bugs were reported on previous versions:
EXCLUDE function not working as expected? BUGREPORT 3.0.13.268
Exclude checkbox does not work (v3.0.14.276 X32)

We were told by russian-speaking user Mor0 that bug is on v3.0.15.277 too.

I checked it on my machine and can confirm it. Also details listed here are of my system.

  1. AMD Athlon™ XP 2500+ X86

  2. Windows XP Pro SP2

  3. Actively-running security and utility applications: CFP v3, CMF v2.0.2.12.

  4. Specific symptoms of the bug, and steps you can take to reproduce it.

After creating global rule for eMule P2P client, firewall blocks and logs connections on port 35641 (which is specified under settings of eMule as port for incoming connections), despite of option “exclude…” is checked. Of course, if this rule is changed/removed, port is not blocked.
I guess the bug can be reproduced in any similar case.

  1. Specific steps you have taken to try to resolve it:
    None.

  2. D+ in paranoid mode, firewall in custom policy mode.
    Settings are default in advanced sections (except alert level set to “very high”).

[attachment deleted by admin]

Thanks, goodbrazer. :■■■■

Both Source Port and Destination Port are affected by this bug.
The bug happens with “A single port” and “a port range” but not with “a set of ports”.
The bug is reflected in the rule description: It does not say “Not” if the exclusion does not work.

OK, thanks for additional information :-TU

EDIT:
That bug with global rule described in first post is fixed in 3.0.18