Excel 2007 will not save with AV program running

Excel 2007 and XP will not save with AV program running.
Gives some sort of sharing violation.

Unload the AV program and you can save the file.
Load the AV program back and can’t save.

Any ideas how to get around this other than loading and unloading, I use Excel a lot.


What AV software are you using?


Comodo Build

Perhaps you can try excluding Excel from CAVS on access scan? Just a guess but it might work.


Thanks for the suggestion Dave.
I tried excluding Excel from CAVS access scan, same problem.
As long as CAVS is running you cannot save a file with Excel.
Unload CAVS and file save works fine.

I’ll check around some more. Heck, I’ll download CAVS myself and see what happens with Excel. Were there any of these problems when using other Office 2007 products?

Ok, I downloaded CAVS myself and tried it on Excel 2007 and Word 2007 and I could not replicate the saving error you’re getting. I’ll dig into it some more and see what I can’t turn up,

Same here - latest build and updates on CAVS and Office 2007 fully patched - no problems.

What O/S and what, if any, other security software are you running?

Ewen :slight_smile:

XP Home v 2002 SP2
Comodo Firewall
BOClean 4.25

Do you have DEP enabled? look at http://support.microsoft.com/kb/875352
If you have dep OptOut then add the offending program mentioned in the error message (excel) to the exclusion list.

Ok I did that, re-booted, same thing.
Error attached…

[attachment deleted by admin]

I see. Please remove Excel from that list :stuck_out_tongue:
This is a File sharing violation. This means that CAVS or another apps don’t release that file.

Then download WhoLockMe Explorer Extension v2.0 beta (NT-Win2K-XP) download page and post a screenshot when this happens before you close the error dialog.

after that please add *.xls to cavs exclusion list

I should mention it will let you save the file one time.
After that sharing violation.

Can’t add *.xls to exclusion, must be folder or filename.


[attachment deleted by admin]

You need to use wholockme on the xls file not on the folder

you can disable on access scanning until this issue is resolved.

Guess I am not sure just how to use wholockme.
Right Clicking the file either open or closed with Explorer, running wholockme, produces no results.

Then try with OpenedFilesView - View opened/locked files in your system (sharing violation issues) It’s important to find the other app that locked that file and cause that error.OpenedFilesView will list all opened files so I guess you should see at least two instances of that xls file

OpenedFilesView reports 211 files open but the spreadsheet is not one of them.
Excel type files open (the type with the Excel icon):


The spreadsheet is open and giving sharing violation, see attached.

[attachment deleted by admin]

Well that’s not much we can do. Maybe the official support could come with something.
The only thing to do ATM is to disable the on access scanner. If you submit a support ticket add a link to this topic as well.

BTW what’s that compatibility mode?

Thank you for your time and effort.

The Compatible Mode saves the worksheet so it can be used with the older Excel 97-2003 program.
See attached.

Thanks again,


[attachment deleted by admin]

I was unable to help though :-[
Post here any results of your support ticket.

…a bump to the case…

I’ve been having the same problem here.
Also, I like to add another info; that the Compatibility mode does not cure the problem.
As it will get denied too, when you tried to save the document, again.
The only thing that can fix this malfunction “save”, is to save the document to another name; EACH TIME YOU WANT TO SAVE!! …or, disable CAVS, when you’re working with Ms.Office 2007.

…I really hope there’s a fix to this matter, considering that there’s no news to CAVS 3 “coming soon” status…