Everything works great, but can't browse Internet

Hello! :slight_smile:

Firstly, i want to thank everyone for making this great program and for making it free and for being so kind to let everyone be safe online!

I have a little problem and i will try to explain it the best way i can. I have two Internet connections. One of them works absolutely fine and without trouble and the satellite connection works great too, except that i can not browse Internet and can not reach any web site. I think that it is using some kind of web acceleration or a proxy because it says so in the router’s internal page (Web acceleration upstream address). I can see that the DNS server can be reached and the address is resolved, but it does not go any further. :-[

Internet Explorer and Firefox are both allowed with pre-defined settings as the browser, Local Area Network is set to “any” / “any”. Maybe there is something i can try?

Thank you so much for your time and the answer.


I have tried setting the Firewall from Safe Mode to Disabled and then the web pages would load fine, so it might be something blocked.

The router that i have is Hughes HN7740S and it is operated via NOC (network operations centre). It has a turbo page and from what i could find out, it uses acceleration that works like proxy. I have tried using the web acceleration address as a proxy in browser settings, but it gave me the error. I’ll try some other things now. It might be that turbo page because all other programs work fine, the update works fine too.


Can you show me a screenshot of your Global Rules and of the Firewall logs (for the situation with the satelite connection).

The Global Rules can be found under Firewall → Advanced → Network Security Policy → Global Rules. The firewall logs can be found under Firewall → Common Tasks → View firewall events.

Thanks for writing back! :slight_smile:

I have made a screenshot of Global Rules. The only entry that i have added there was when i have allowed browser as trusted application. I used IE as the example, but Firefox and Opera act the same too. Other than adding the browser, i did not change Global Rules because everything worked ok with other Internet connection (usb G3 modem stick).

And i did Firewall log too. I found out how to make firewall log all browser activity and it looks strange that the source address is and pointing to local loop address. Then as you will see, i have tried to type in https://forums.comodo.com in the browser and it worked fine. We can see that it connected through SSL port and i could browse. One of the reason is that turbo acceleration (that is enabled in router) does not support SSL.

I hope it helps and thank you so much again for your help and time! :slight_smile:


[attachment deleted by admin]

I am not quite sure about the allow rule you made in the Global Rules. Please move it to the bottom of the Global Rules. You will be back to the default settings. Now see what happens when you surf.

Dear Eric!

I did as you told me and moved the rule to the bottom, but it is still the same. I even tried to remove it and ran IE again, but still the same result and still the same entry in the firewall log. :frowning:

I searched online and here is what i found about this acceleration system. “Hughes Web Accelerator (turbo page) actually downloads and stores the page for you, then zips it up like a zip file and downloads it to your modem. Then the modem “unzips” it back into a normal web page and sends it to your computer.”

Another web site mentions using the proxy in a browser as “” and the port number to be the local listening port. I will try “80, 10080, 68 and 67” as ports and will see what happens. I will let you know! Thanks again for all your help! :slight_smile: It means so much!


You are very likely on the right track.:-TU Investigating the proxy would have been my next step.

Can you post the url’s where you found the mentioned information?

Keep us posted.

Thanks, mister! :slight_smile:

The web links where i found the information are:


(see one of the messages there)


(something similar to Hughes accelerator, i think)

I have also found out the listening port of the web acceleration server located at NOC which is port 87 and i am wondering if i should add it to ports in HTTP list. Then i am wondering why firewall logs port 10080 as connecting to address. Another thing i’ve done is running “netstat” command. It shows that it has local connection “localhost” listening to port 10080 on the address

I’ll try to do some more researching and will keep you informed. And since i installed Comodo Firewall, laptop works 3-4 times faster and better with all the programs and even Internet speed got better. Thank you so much! It is really the best program!


it’s called COMODO Internet Security if you can’t access your internet everything is not great lol :D.

it should secure your PC from your internet activity without having you to pull your internet cable or turn off your modem.

Anyway it could be that you messed with the firewall rules. Don’t fiddle with it unless you know what you’re doing. The default proactive security setting works like charm.

Also see when you try to connect to the internet, is there anything blocked?
My CIS blocks the IP addresses of And I have to allow these addresses sometimes in order for me to get online.

Hi. I can’t say I’m very familiar with the Hughes Web Accelerator, but one thing that struck me immediately, after looking at your screen shots and reading the bits and bats on those links you provided is this:

Secure sites cannot go through this proxy because of the encryption involved. Therefore secure sites load really slowly. So withough "turbo page", browsing would be worse than dialup.....much much much worse...

In your screen shot all outbound connections are for SSL, Destination port 443, or if you will, secure connections.

The items you are seeing look like some sort of loopback request, so you could add a rule for that, I believe it’s safe as it’s only connecting internally.

Thanks for all your replies! :slight_smile:

Michael, when i said that everything works great, i spoke of firewall’s doing what it is supposed to do - to get computer secured and protected from various online threats and attacks. All of the systems, apart from HTTP browsing work without any problems. The reason why HTTP browsing is becoming a trouble is related to the specific satellite connection i am using and not knowing enough about how it works. Comodo does it works and it does it in a great way! :wink: If something is not allowed, it is MY fault, but not the fault of the program since i have to know what to allow and what to leave in blocked zone.

I did not mess with the rules that much and i have tried browsing from the clean installation with the default rules. What i have to do is to find out how my system works and what web acceleration port i need to allow. So far i can not see anything being blocked, but will see the router’s logs too, maybe something is there. Thanks for your reply!

Quill, thank you too for the advice and commenting! :slight_smile: I have to explain the secure bit to you, mister. You see, it says that the secure sites can not go through this proxy. It is exactly the reason why SSL port is not affected by firewall and why i have used it for screenshot. I am sorry i did not explain properly. :-[ I have made the screen shot intentionally to show that SSL connection works. Now when i am trying normal HTTP connection, then the special connection to the proxy server at NOC is made. Then firewall must be blocking something or something is not allowed. What happens when i try normal connection is source going for port with 10080 listening port. I will try to add the rules for that too and will see what happens. But probably tomorrow since it’s long over midnight over here. Thanks again for your reply!

I will try to ask adults and see if i can find out more about Hughes and how it works. I will post the results here, maybe it will be helpful for others too. :slight_smile: Have a good night everyone!


Finally solved! :slight_smile: :-TU

My problem is finally solved and thanks everyone for your replies. I hope that my solution will be helpful to everyone using Hughes Satellite router, be it enterprise router as in my case or the small office router. Here is the solution:

As one can see from my screenshots, the secure connection (SSL) goes fine through firewall while the usual port 80 non-secure connections can not be established. The Hughes system uses turbo page for the web acceleration due to the high satellite latency. This is where turbo page comes up - it works like a smart proxy and it downloads the web page, compresses the images and sends it back to router. So when i am typing in non-secure web address, my router tries to connect to the NOC server and use turbo page. I went to the extended settings in the router and saw that the listening port for the remote server is 87. Then i looked at my screenshot from the firewall log and saw that the local connection is being made, but it goes to from which is a loop. Yes, as Quill wrote, it is the loopback request. Hence i decided to point my browser to the internal proxy since Comodo Firewall is not blocking any requests.

I typed in with port 87 for HTTP only connections (since it is the only place where turbo page works and is intended for!). And IT WORKED! ;D

I am writing from fully functioning Hughes Satellite connection with Comodo Firewall being enabled! Thanks again!


Congratulations on solving it. :-TU

You know more than I do ;D