Event Warnings lead to uphclean identifing cpf.exe locking registry hive

I’m using Comodo. I was getting event warnings that a registry profile was locked during shutdown so I installed UPHClean. UPHClean identifies the problem is caused by cpf.exe. Here is the results…

Event Type: Information
Event Source: UPHClean
Event Category: None
Event ID: 1401
Date: 4/15/2007
Time: 9:30:22 PM
User: AAA\User
Computer: AAA
The following handles in user profile hive AAA\User (long number) have been remapped because they were preventing the profile from unloading successfully:

cpf.exe (1508)
HKCU\Software\Classes (0x7c)
HKCU\Software\Classes\CLSID (0x80)
HKCU (0xb8)
HKCU\Software\Microsoft\Windows NT\CurrentVersion\Windows (0x110)

I have found other posts for earlier versions of Comodo but nothing conclusive for an answer. Do we know how to prevent Comodo from locking the registry yet? (:AGY)


I have the User Profile Hive Cleanup service too.

I’m not experincing this issue. What is your UPHClean version number?

Try to use the registry editor to change
HKLM\System\CurrentControlSet\Services\UPHClean\Parameters\CALLSTACK_LOG to 0.

Hello MrRAlan. Actually, if you received the above, UPHCLEAN did its job. There is a MS bug which causes the problem of the locked hives and the relocation of the data just corrects things.
I have had the same problem here and long before using CFP.

Lee (B)

Hi. This is not an issue for me without Comodo. I was only getting the warnings when I installed Comodo. After that, I turned on UPHClean to see what application is at fault. It shows it to be Comodo. Of course, UPHClean shuts down the hives but the issue is Comodo is locking them and it shouldn’t be. Comodo should have a fix for this or at least be working on one.

Ooh… this one. I had this annoying problem for 2-3 years with UPHClean and could never figure out why it was lsass.exe. I solved it by upgrading to XP SP2


Anyway, this is something to try out: Security > Adv > Misc > Config > Disable the Protect own registry and file option. See if that works. If it doesn’t then try a clean re-install of CFP with other software disabled.

Here’s another thread on this, but unfortunately no effective suggestions from me:

However, upon review of seadog’s posts thereafter, it seems his problem was solved by properly uninstalling the other software in addition to CFP:

Well I tried disabling the “protect own registry” option but that didn’t help. I wouldn’t want to uninstall everything and then have to re-configure everything again. It seems that Comodo should try to solve this issue in a future release. Do they read these forums? Thanks.

Sure they do. From time to time ;D, but apparently they’re still locked on V3. Rather than having to uninstall your other software, just re-install CFP, but this time remember to disable your other software during the installation process. If you would rather wish to wait for an official response then file a support ticket: http://support.comodo.com and link this thread.

You can backup your settings

But I would disable internet and unistalll antivirus and other similiar programs prior and after installation to know if there is something interfering…

After testing two or three shutdown if there ane no problems I would install one app at time testing the shutdown reghiveproblem.

After finding the culprit I would choose which software I have to uninstall and then enable internet.

Thanks all for the suggestions. I did disable my avast antivirus when I installed Comodo the first time. I will raise a support ticket. Thanks again!

I just checked, and I too see the same entry logged to EventViewer
(UPHClean entry reporting that cpf.exe needed a diaper change)

Frazzled, what Antivirus are you using?

antivirus? None

Ok…so I know it is not a conflict with that.

I also am experiencing the same System Event errors that a registry profile was locked during shutdown or reboot. I tried different things and did not come up with any solution. I also tried using the latest UPHClean and it also verified that Comodo (cpf.exe) was causing the conflict. I hope the next version of Comodo will address this issue. When I uninstalled Comodo I get no System Event errors.