etec usb 56k modem and comodo

I’ve just bought an etec AL-56UH usb modem in order to update a website which I need to access with dial up. I have installed the driver and entered all the details for the isp (orange) but the modem won’t connect to the server, I keep getting the ‘try again’ window in vista. Could comodo be preventing the modem from connecting? I have broadband as well and it connects no problem…

Any advice on how I can check if comodo is blocking the usb dial up modem would be appreciated…

To tinman,

Actually there is a fairly simple way. Simple prevent CPF3 from booting up when the computer is started. My preferred method is to use startcop which is an old PC mag utility that still works with win XP, or you can go starts–run–type msconfig–and go to the start up tab and uncheck comodo3. Prevent comodo from starting, and then reboot. A little harder to undo, but it arrives in the same place.

Either reboot method should tell you if CPF3 is the villain or not, but in the event that CPF3 is the villain, come back to these forums to find out how to have your cake and eat it too because permission to allow the dial up modem may be
something needing help.

But first establish if the problem is comodo related or not because barking up the wrong tree is a waste of time.

An excellent program for monitoring start-up programs is Winpatrol. You can disable and enable start-up programs with one click and find which is causing problems. I’ve been using it for years and don’t know what I’d do without it.

http://www.winpatrol.com/download.html

That’s the free version; you can update to ‘Plus’ which you pay for.

Mike.

Yes, Good suggestion.

Josh

ok I used ccleaner start up tool to disable comodo at startup. However i checked running processes and comodo was not listed, but when I checked my firwall settings in vista security it said comodo was on…How can this be after disabling it? I also tried uninstalling comodo and and it was still listed as on in vista security…

As far as the dial up modem goes it still wouldn’t connect even after supposedly preventing comodo from running…

More help appreciated…

Here are 2 good free start-up monitors:

  1. AutoRuns 9.21
    Autoruns for Windows - Sysinternals | Microsoft Learn

  2. What’s Running? 2.2
    http://www.whatsrunning.net/whatsrunning/main.aspx

All you did was stop the GUI tray icon from starting up. If you went into the services you could have set the services to manual. Go to run and type “services.msc”. Find both Comodo services which are cpf.exe and cmdagent.exe. Set them to manual.

Unfortunately, this does not work either… it still leaves CFPs drivers (the bits with teeth) loaded & running. The best way to disable CFP is to use CFP itself (Security Levels to Disabled). CFP.EXE isn’t a service, but as Vettetech said, stopping this process doesn’t stop CFP anyway as it’s just CFPs User Interface (it only stops CFP communicating with the user).

There are a couple of reasons why CFP might impact a new DUN (Dial Up Networking) connection… On detection/connection the DUN adapter is using an IP range that already has existing rules within CFP (Firewall issue, would not stop the actual DUN connection) or if the COM interface, associated with DUN, had been blocked within CFP (Defense+ issue, probably could block DUN connection).

In general, CFP doesn’t interferer with adapters. Of course, Windows DUN can still break/crash without any help from CFP.

so how can I stop comodo from running completely? in order to eliminate it from enqiries?

Go to Miscellaneous/Settings and untick start up with Windows. Then go to the Windows services like I said and set the services to disable. Try that. When you boot up look in your taskmanager for cpf and cmdagent. They shouldn’t be there.

This ignores CFPs drivers, bad idea. Use CFP to disable CFP. Right click CFPs systray icon & set the Firewall Security Level & Defense+ Security Level to “Disabled”, reboot & test DUN. If DUN works… something in CFP is stopping it. If DUN still doesn’t work, then you need to rule-out a low level conflict (unlikely). Create an XP Restore Point. Uninstall CFP. Test DUN (don’t stay connected if it works, no firewall!). If DUN still doesn’t work, it’s not CFP but something else. Use Restore Point to get back before CFP was uninstalled. Post again.

I take it by xp restore point you meant vista? As I am running vista home premium… it won’t make any difference?

No, I don’t believe so. However, I personally will not be able to help you with any DUN related problems in Vista as I’m not familiar with it.

Success! I tried disabling comodo and it didn’t work… However I then changed the telephone cable from the modem to the socket and it connected, so looks the cable was dodgy.

Thanks to everyone for their input, much appreciated. :BNC

That’s great news tinman. I’ll mark this topic as [RESOLVED] & lock it. Just send a PM (Personal Message) to any on-line Mod if you need it unlocked again.