Errors when trying to run the Update process manually [NBZ]

The bug/issue

  1. What you did: Attempted to manually run the update procedure
  2. What actually happened or you actually saw: Two things - wasn’t able to save the configuration file, and wasn’t able to successfully complete the update process (received an error 0x80072efd)
  3. What you expected to happen or see: Firewall updated
  4. How you tried to fix it & what happened: Nothing much I can do. There were no errors logged in my local Application, Security or System logs. There were also no entries in Comodo’s logs.
  5. If it’s an application compatibility problem have you tried the application fixes here?: N/A
  6. Details & exact version of any application (except CIS) involved with download link: Win7 Pro x32
  7. Whether you can make the problem happen again, and if so precise steps to make it happen: Yes. Try to save the configuration to a file on any media. Try to run the update manually.
  8. Any other information (eg your guess regarding the cause, with reasons): Not certain. Since no events are being logged anywhere it’s a bit difficult to make a determination. Also, I’m unable to find the error code “0x80072efd” on the forum anyplace.

Files appended

  1. Screenshots illustrating the bug: Appended

  2. Screenshots of related CIS event logs or the Defense+ Active Processes List: No events being posted.

  3. A CIS config. report or file: Unable to save one.

  4. Crash or freeze dump file: Not applicable

  5. CIS version, AV database version & configuration used: Firewall only, version 5.3.176757.1236

  6. a) Have you updated (without uninstall) from CIS 3 or 4: No. The current version was a clean install.

  7. a) Have you imported a config from a previous version of CIS: No.

  8. Have you made any other major changes to the default config? (eg ticked ‘block all unknown requests’, other egs here.): No changes.

  9. Defense+, Sandbox, Firewall & AV security levels: D+=Safe Mode, Sandbox=N/A, Firewall=Safe Mode, AV=N/A

  10. OS version, service pack, number of bits, UAC setting, & account type: Win7 Pro,none,x32,Disabled,Administrator

  11. Other security and utility software installed: Avira Antivir version

  12. Virtual machine used (Please do NOT use Virtual box): Physical laptop, not a VM


I’m running the firewall only, version 5.3.176757.1236, with Win7 Pro x32. Except for February’s patches I’m fully up to date.

A week or two back I tried checking for updates – which I have configured for manual – and the first thing I always do is export my configuration. This has always worked in the past when I was using XP, but now my laptop is running Win7 and this is the first time I’ve tried it with the new OS (which was a clean install, not an upgrade). Attempting to save the file to either my C: or D:, which are logical partitions of the same physical drive, gave me the error “Unable to export the configuration. Please make sure you have enough rights for the path” (see Comodo Error 1.png).

I also got the same error when I tried to save the file to a thumb drive and external hard drive. I’m running as administrator with UAE turned off. All of the aforementioned drives read/write files just fine with every other program, so it’s only Comodo which has the problem.

Since I was not able to save the configuration file I opted to just see if any updates were available, assuming that if there were none I would just deal with the problem later. However, when I did a message popped up that merely said “0x80072efd” (see Comodo Error 2.png).

I tried searching the forum for that string, but came up with no hits. Neither of these errors posted anything in the local Application, Security or System logs, so I wasn’t able to get any ideas that way either. Has anyone else had these problems?

[attachment deleted by admin]

We would very much appreciate it if you would edit your first post to create an issue report in line with the bug forum guidelines and format here. You can copy and paste the format from this topic.

To understand the reasons why we ask you to follow these guidelines please see below.

Bugs/issues can be impossible or very time consuming to fix if developers don’t have enough information to reproduce them. Since CIS is free, development time is limited. So if you want your issue fixed, please use the format below to describe it.

To avoid clutter, issues not described in the format below your post will not be moved to the ‘moderator verified’ issues topic. This means that the developers may not look at it.

Best wishes and many thanks in anticipation


Wow, I had no idea there was such an elaborate process for a bug report. I’ll modify the post and see if it aligns itself with the procedure any better. I’ll also leave my original posting, just in case additional information is required.

We really would very much appreciate it if you would edit your first post to create an issue report in line with the bug forum guidelines and format. You can copy and paste the format from this topic.

Thank you


OK, let’s see if that works…

Thank you for your bug report in the required format.

Moved to verified.

Thank you


Bump… anyone?

I’m sure glad I put in all that time and effort to get this bug report to comply with the format perfectly, otherwise it might not have gotten any replies. :-\

Sorry for the lack of feedback from staff.

Though this does not mean they have not read it, and taken note.

The feedback usually comes by PM, if they require further info.

Thanks for making the effort to post a bug report in the correct format :slight_smile:


Dennis; I’m beginning to wonder if you and I are the only ones left on the forum… ;D