Error when closing program

Hi, when I close CAV or CFW I get the error -

The instruction at “0x7c80d189” referenced memory at “0x78221592”. The memory could not be “read”. Click OK to terminate the program.

Everything seems to work ok but I get this when I close the Comodo launch pad or when I do an update. I also got the same (or similar) message when I installed both CAV and CFW but they both seem to be working.


At the top of the error windows which appear is either -

cpfupdat.exe application error
CLPUpdater.exe application error
CLPConfig.exe application error

This happens when the computer starts up aswell.

this is my 1st ever reply post so scuse me if not quite rite. I have just solved a similar problem - turned out to be a (new) variation of the merkur trojan that got past NOD32 and Ewido. Look for file avupdate.exe and it’s run under explorer policies (in reg). I found it using sysinternal’s Autoruns.

Hi, I have checked and can’t find any viruses. I am still getting the error message but it doesn’t seem to affect the programs working. I am also having to allow Firefox internet access everytime I start it. Thanks, Peter

hello peter71,
I have just started using the Comodo firewall and have experienced a similar problem. When closing the Launch Pad I get an error message that states that I have encountered a CPF.exe Application Error. Then – “The instruction at 0x7c80d189 referenced memory at 0x78148e2a. The memory could not be ‘read’. Click ok to terminate the program.” Everything also seems to work after closing the error message window. I downloaded the firewall last night and noticed today that version was released. I uninstalled the older version, cleaned my registry and then installed the newer version however the problem persists. I am not certain that Comodo updated the launch pad. Just wanted to add this reply to your post to let you know that you are not alone! Sorry I don’t have a solution.

Comodo users:

I saw and report similar errors with aigle involving spyware software. I just launch firewall
with its launch pad to avoid errors messages.

Support has been notified to address this issue.



we’ll fix this asap.

First we need your help in identifying your systems, the apps you run, the version of the Comodo products you run pls and if you can repeat the problem, pls tell us how. The more information u can provide the better please.



Hello Melih,

Help would be appreciated. I have a pentium4, 2.4gh Gateway computer. I am running windows xp home, sp2. I am using the free Comodo firewall, version The Launch Pad version is If it makes a difference, I have 512mb ram installed (soon to upgrade to 1024). I am using Nod32 antivirus, and SpyCatcher Express 4.0.4 (I allow this program to actively monitor my computer and Comodo continually asks for my permission to allow it to access the internet and act as a server even though I always check the “remember my answer” box). I also check my computer periodically with Spybot, Ad-Aware, Ewido (no active monitoring enabled), and use SpywareBlaster. Yes, I am a bit paranoid. There have been some concerns about SpyCatcher posted on the net as Blacklight beta root kit eliminator (F Secure) does show a couple of it’s executables as hidden. From what I have gathered from reading online posts, this is actually because of SpyCatcher trying to protect itself from malware disabling it. In this same vein, Sysinternals Rootkit Revealer comes up with three SpyCatcher files hidden from the Windows API.

As stated previously, the error message I get (CPF.exe Application Error – “The instruction at 0x7c80d189 referenced memory at 0x78148e2a. The memory could not be ‘read’. Click ok to terminate the program,” always occurs when I close the Comodo Launch Pad. It does not occur when I open and close the main Comodo Firewall program window. I have also had a couple of the same error messages pop up randomly, but have not seen this happen enough to establish any pattern yet.

One last note that may or may not be pertinent – I previously have run the ZoneAlarm firewall. When I updated to the latest version of ZoneAlarm, I encountered a problem running Check disk. After Checkdisk runs and completes, the blue screen comes up and windows is shut down. I googled this problem and it is definitely tied to the current version of ZoneAlarm. I thus uninstalled the program and tried to clean up all instances of it by running RegSupreme Pro (registry cleaner), Easy Cleaner and CCleaner.

I hope this helps you to help me! If you need additional information from me, please let me know and I will do my best to supply you with it.

Thanks Melih – it’s really nice to have a program that has it’s own “hero” and I do appreciate your response. From what I have read, the Comodo firewall is first rate!


Hi Melih, pls see my post here with error details.,674.0.html

In my case it is clearly a conflict with SpyCatcehr and i can reproduce the problem all the times I installed it with Comodo.
I am using Toshiba satellite M70, 1.7, 512, 40 GB sata with XP SP2.
I have following softwares,
RollbackRx, Comodo firewall( latest version but same problem with latest beta as well), Antivir classic, Windows defender, SnoopFree, GesWall, Spyware blaster, and that,s it.

I recently started getting the same type of error. CPF.exe - Application Error in Header
The instruction at “0x77697493” referenced memory at “0x00000010”. The memory could not be “read”.

Any thoughts, solutions, etc.?


[attachment deleted by admin]

Hi Paul,

What other security software are you using? And can you paste us the details about the crash(Just click on the details button on crash report)?


Event Type: Information
Event Source: Application Popup
Event Category: None
Event ID: 26
Date: 6/28/2006
Time: 6:16:13 PM
User: N/A
Application popup: CPF.exe - Application Error : The instruction at “0x77697493” referenced memory at “0x00000010”. The memory could not be “read”.

Click on OK to terminate the program
Click on CANCEL to debug the program

For more information, see Help and Support Center at

This is from the error log trace.

I am running the following in memory when these errors occur.

See attached jpg

[attachment deleted by admin]

I’ve only been running CPF for a couple of days and was getting the same errors as above.
I read on one of the posts that SpyCatcher seemed to be a problem, so I uninstalled it and haven’t had any problems since.
Bye the way, I have tried several free and not so free Firewalls and think this one is by far the best.

Hey Peter,

Firstly welcome to the forums.

There does appear to be a conflict with Comodo Personal Firewall (CPF) and SpyCatcher. It has been reported by several users and is solved by removing SpyCatcher. Not much of an answer, but it works. :wink:

Have you had a look at Comodo Anti Virus (CAV)? It is going beyond normal anti virus insofar as Comodo are building in some syware definitions and behaviour blocking capabilities. It is still a beta, but it is definitely worth watching.

Feel free to ask away. There’s a very active user community witha broad range of experience and the Comodo tech support guys are really good. If you have a highly technical query, you can email it to as well as posting it here on the forums.

Remember, the only truly dumb queston is the one that doesn’t get asked. :wink:

Again, welcome to the circus.

Ewen :slight_smile: