error using alteriwnet 0xc0000018

Hello, i am having problems with the alteriwnet game modern warfare 2 multiplayer, i have done this “solution” but it doesnt work:

"[i]If you are using Comodo and game crashes, then follow these steps…

  1. Add both iw4mp.exe and iw4mp.dat to the firewall and defense+ lists as trusted apps.

  2. Then select Defense+ Settings → Execution Control Settings → Exceptions
    and add the entire MW2 folder there…[/i]"

but it doesnt work, what can i do?

i have opened iw4mp.dat with dependency walker and the log is:

Operating System: Microsoft Windows NT/2000/XP/2003/Vista based Home Premium (64-bit), version 6.01.7601 Service Pack 1
Program Executable: c:\program files (x86)\call of duty modern warfare 2 spanish\IW4MP.DAT
Program Arguments:
Starting Directory: C:\Program Files (x86)\Call Of Duty Modern Warfare 2 Spanish
Search Path: C:\Program Files (x86)\NVIDIA Corporation\PhysX\Common;C:\Program Files\Common Files\Microsoft Shared\Windows Live;C:\Program Files (x86)\Common Files\Microsoft Shared\Windows Live;C:\windows\system32;C:\windows;C:\windows\System32\Wbem;C:\windows\System32\WindowsPowerShell\v1.0;C:\Program Files\Broadcom\Broadcom 802.11 Network Adapter\Driver;C:\Program Files\WIDCOMM\Bluetooth Software;C:\Program Files\WIDCOMM\Bluetooth Software\syswow64;C:\Program Files (x86)\Windows Live\Shared

Options Selected:

Started “IW4MP.DAT” (process 0x1260) at address 0x00400000.
Loaded “NTDLL.DLL” at address 0x76F30000.
Loaded “KERNEL32.DLL” at address 0x74D20000.
Loaded “KERNELBASE.DLL” at address 0x74680000.
Loaded “WINMM.DLL” at address 0x720B0000.
Loaded “MSVCRT.DLL” at address 0x75280000.
Loaded “USER32.DLL” at address 0x76570000.
Loaded “GDI32.DLL” at address 0x74F20000.
Loaded “LPK.DLL” at address 0x74CC0000.
Loaded “USP10.DLL” at address 0x75620000.
Loaded “ADVAPI32.DLL” at address 0x764D0000.
Loaded “SECHOST.DLL” at address 0x74CA0000.
Loaded “RPCRT4.DLL” at address 0x74700000.
Loaded “SSPICLI.DLL” at address 0x74620000.
Loaded “CRYPTBASE.DLL” at address 0x74610000.
Loaded “WSOCK32.DLL” at address 0x72CD0000.
Loaded “WS2_32.DLL” at address 0x751B0000.
Loaded “NSI.DLL” at address 0x76F00000.
Loaded “IW4M1.DLL” at address 0x20000000.
Loaded “MSCOREE.DLL” at address 0x6FE80000.
Loaded “IMM32.DLL” at address 0x74FB0000.
Loaded “MSCTF.DLL” at address 0x74AD0000.
Loaded “GUARD32.DLL” at address 0x10000000.
Loaded “VERSION.DLL” at address 0x72E80000.
Loaded “FLTLIB.DLL” at address 0x72E70000.
Loaded “STEAM_API.DLL” at address 0x08D00000.
Unloaded “STEAM_API.DLL” at address 0x08D00000.
Exited “IW4MP.DAT” (process 0x1260) with code -1073741800 (0xC0000018).

EDIT: To sum up, my question why comodo when we add these files to the exception list of execution control, comodo doesnt make this exception?

*guard32.dlll this dll is the file of comodo responsible of this problem

and here is this .dat file blocked:

and the .exe that executes .dat file:

I have a serious problem with modern warfare 2 online, the game will not run perfectly simplesmemte closes the process alone, tried to implement what was recommended in this link: but could not because the language is in English, if poderm help me I will be very grateful. Ever tried or remote asistencia, and perch on conttinuar problem. If you can help me, preferably someone who speaks my language en the Portuguese, now thanks.

Makarboy. Please consider filing a bug report in the Bug Reports - CIS board following the format as described in FORMAT & GUIDE - just COPY/PASTE it!, That will greatly help Comodo to fix your problem.

UNINSTAL the Comodo and will be run the gam with no problem, I tested…

Can you see if adding the game executable (or its complete installation folder) to the Exclusions of buffer overflow protection (shellcode injections) helps to make the program work for you?

Hey Guys. i solve this problem…

Just chkdsk c: /f /r and enjoy your game!

100% working… :wink:

Thank you for your insight. Next time please look at the date. You’re making a major kick. :wink: This topic is