Error upgrading/uninstalling old version

I have an older laptop (Dell inspirion 1545) which is running Comodo Internet Security Premium Version 6.3.32439.2937 and windows 10. I tried to upgrade to the latest version of Comodo however it fails telling me it cannot uninstall the current version.

I tried the standard uninstall process which also fails with a COMODO Endpoint Security Setup Wizard ended prematurely.
Detail of the message is “COMODO Endpoint Security Endpoint Wizard ended prematurely because of an error. Your system has not been modified. To install the program at a later time, run setup wizard again. Click the Finish button to exit the setup wizard.” (keep in mind this msg is after I started the UNINSTALL process).

Any ideas on how to get rid of the old version???

Hi maxwelwp,
Do you still have the installer for 6.3?
If yes, try reinstalling 6.3 then after reboot try uninstalling it through Windows programs and features.
Edit note: When running the installer, you might be fortunate enough to see a remove option.
If the remove option is not greyed out, this might be more desirable to select rather than reinstalling.

If you do not have the 6.3 installer, you can get separate 32/64-bit installers from the external links below.
Comodo Internet Security 6.3.32439 (32-bit)-FileHorse
Comodo Internet Security 6.3.32439 (64-bit)-FileHorse

Kind regards.

Thank you for the suggestion. One small problem. It seems the only version that does not have a download button is the exact version I need to download :frowning:

Hi maxwelwp,
That is because the link I gave already had it selected, you can see the version number and the green download button on the top of the page.

If you use this page, you will note it can be selected.

Also please note, I added an edit note in my previous post.

Kind regards.

OK - Downloaded. However when I run the installer it tells me this version of comodo does not work on this version of windows and aborts the install.

Hi maxwelwp,
Sorry that failed, I just tried running the installer in every compatibility mode available and it will not run.

Have you tried manually running the current versions installer in hope for an upgrade option?

I will ask the other Mods to take a look in hope of a solution.

Kind regards.

The step from v6 to v8 is a big one. There are two ways to go here. One way is to upgrade to v7 first and from v7 to 8 but you may encounter the same problem.

The other way is a clean installation. When choosing a clean install try following Most Effective Way to Reinstall/Update CIS to Avoid/Fix Problems. It will allow you to uninstall CIS. When needed run the clean up tools in Windows Safe Mode. That should help to get CIS uninstalled.

Because you’re taking two big steps one from updating to Windows 10 and from CIS v6 to CIS v8 I strongly suggest to choose the path of clean installation.

Another path is choosing to export the active configuration of v6 and import it in v8 but I am not familiar at all with this road. You may end up with not activating new features. Dennis2 is more familiar with upgrade paths as he uses elaborate rule systems that he wants to preserve over long stretches of time.

Yes you can upgrade to v7 from v6 worked fine for me, no missing parts all functions were working.

Sorry you then cannot upgrade to v8 you lose the file list totally, including any new entries without the list it just does not function.


PS That’s why a certain person at my home using Windows 7 is still running version CIS 7 waiting for CIS 10 to go final before I uninstall/install on her computer.

Try this one:

It’s helpful in some situations.

I cannot run Most Effective Way to Reinstall/Update CIS to Avoid/Fix Problems. as this is a 64-bit machine and that only runs on 32-bit machines apparently.
I tried the Microsoft fix suggested by qmarius. It did remove comodo from the programs list in control panel. Unfortunately when I restart the machine, I get a CIS.EXE error stating it cannot start because cmdhtml.dll is missing. It suggests reinstalling the program.
Well reinstall again fails as comodo install still find and old version out there and says it cannot continue. Please uninstall the previous versions. Now I have nothing in my program list for comodo so cannot uninstall that way. Running the Microsoft fix does not find any entry for comodo any longer so cannot remove that way.
Seems stuck up a river without a paddle…

Found ESET AV Remover so thought would give that a try. It doesn’t find any applications to remove???

Do not panic. Try running removal tool* in Safe Mode**.

** Start your PC in safe mode in Windows - Microsoft Support

  • removal tool that you should be running with administrator rights:
    Comodo Forum

Thanks for all the feedback on support. However it seems everything I tried just dug a deeper hole. The last post with the removal tool like actually disabled my network adapters. A restore brought them back but still had the comodo issues.

So I just did a reset to the PC and reinstalled windows. The Comodo issue is finally gone, along with all my apps, but now I have a system that is running without issues. Defender has started now too so that is reassuring me it no longer thinks there is another AV or firewall running anymore. I can easily reinstall apps and this is a secondary laptop so have the time to deal with it.

Again, thanks for the support.