Error updating signature database

Have been using the product for several years without issue but the last couple days, it will not update the signature database. The program fails with an error on install signatures. Any ideas what is going on here?
Using the free version of internet security Premium Version 7.0.317799.4142 Database version 20183

just to let you know you are not alone int this, and seeing as I very much doubt our systems are identical im guessing the problem is thier end. I have even done an uninstall> regclean (using comodo tool)> re-install
same issue

Please, proceed as follows:

  • rename bxxxx.cav —> bxxxx.old.cav
    (C:\Program Files\COMODO\COMODO Internet Security\scanners)
  • Inmideately comes the warning “Needs Attention” on the Comodo Main Screen
  • Push the “fix it” button. Now the whole signature Database should be
    loaded and installed.
  • After the next restart you can delete the bxxxx.old.cav file.

I hope this should help!

This doesn’t help anything. Whenever I click on “Fix it”, it says that it couldn’t connect to the Servers…

From your last post I assume, that you cannot connect to the Comodo Database-Server.
I suggest:

  • have a look an your hosts-file.
  • install and execute an on demand scanner (for instance Malwarebytes)
    This should clean a virus infection (DNS changer o similar)

I don’t have any virus… I neither was on any side possibly infected with a virus, nor I downloaded anything. The only thing that is new is my Router.

download thew new definitions from : Comodo Anti Malware Database Latest Version & Additions 2022

then open comodo> click on the ? symbol > about and manually import via the button.

this worked for me and was done by a GeekBuddy after I had the same issue

This might work. But is this my exercise to manually update the database because Comodo still has those problems with its update service?

Please check your computer for malware. It’s important to be able to exclude that when troubleshooting.

Scan with :
TDSS Killer
Hitman Pro
Malwarebytes Antimalware
Super Antispyware

I would not expect your router to be a problem unless you have problems connecting to the web with more applications. You might check if your router uses some kind of blacklist and if so disable it.


I just checked for malware with Malwarebytes two days ago. No problems. Comodo still doesn’t want to work

Please also try the other scanners. This is just to make sure there isn’t an underlying malware problem.

Last night I recognized that my laptop also can’t update Comodo. Maybe it’s nevertheless a “problem” with my new router? Because it’s very unlikely both systems have the same problem since I didn’t use my laptop for more than a week. It was the first time I started it connecting it to the new network at home and now it even can’t update.

Within a pool of 50 PCs, I have experienced the same thing with only a minimum number of PCs (2 or 3 PCs).

I checked them with many scanners, including the ones proposed EricJH and others, but malware was found. Checked the host file and nothing was in there either. While this PCs couldn’t connect to the COMODO download server for the update, other computers within the same local network could connect and update.

So I reported this as a bug and so far haven’t get any response from COMODOs dev team. After a few days of waiting, and without changing any configurations, those PCs started to connect again without getting the message error “The server name or address cannot be resolved”.

For 9 days already my pcs in the network can’t connect to Comodo. Have activated Windows Firewall now. I’m still waiting a few days and when nothing is happening I’m going to delete Comodo

i have a similar problem: when i update my database it will usually update to the newest version. but since this morning it just updates to the next version and if i immidiately do another update it will update again and so on until the latest version, one by one…

just been to geek buddy again, with the update issue still, the copied a registry key from one place to another (Internet settings> connections) and it connected again, from what I could see the replaced key was fragmented. hopefully this helps

I have 2 laptops both with CIS v7.0.317799.4142 installed. The second one is only 2 weeks old and has not been run since installing Office and Windows updates a week ago. The only other software it has on it are Zoner Photo Studio and Filezilla FTP Client. As of today, neither laptop will update continually getting a server error after 18kb has been downloaded.

I don’t know if this is relevant but they both display this in their About section:
Database version: 20295
Websites database: 132

Please note 20295 was the current database this morning.

I afraid the Website database has been 132 for quite some time.

Screenshot showing todays latest update.


Please read your PM thank you.

[attachment deleted by admin]

Thanks Dennis. I think there was a problem with the server though because now both machines are updating normally with no warning messages.

Having sort of the same problem, I’m hoping someone here will be able to help me. My Laptop is new and I am trying to set up the programs I need/want, Comodo Internet Security being one. I just finished the install process and of course the program says “virus data base is outdated”. So I tried to update, but this is the error message I get:

Any ideas please?