Error STOAC017, trying to enable on access scanner [RESOLVED]


Newcomer here to the COMODO suite of products. I am very amazed at how many products are offered for free. Obviously you make your money in other ways; and I certainly appreciate you saving mine (L).

I installed the CPF last night and decided to deactivate the aVast antivirus i was using (terminated all services, but thought I’d keep it around as an on-demand scanner) and install the CAV.

Installation went fine, and upon reboot I didn’t get any “slowness” that people would be refering to in the forum when CAV would be colliding with another AV; a good thing. I feed it the e-mailed key and opened the CAV gui and noticed that the “On Access Scanner” has a staus of OFF. So i manually tried to enable it and received:

| X Error

Comodo AntiVirus encountered an error

|Number | STOAC017

| Description | Unable to perform requested operation

(attached screen capture of the error below)

Is CAV not liking the fact that aVast is still installed? Could CAV be conflicting with Windows Defender (beta spyware tool)? How about SpywareGuard?

Other things that I have checked:

  • Admin account
  • service is started
  • setting the CPF to “allow all” (temporarily)

I would like to give CAV a good trial, but until I can get the “On Access” part to function I can only try out the “e-mail scanner” that is enabled. So, in the mean time, I have re-enabled the aVast “Network Sheild”, “Standard Sheild” & “Web Sheild” so that I still feel protected in some way.

I do run WinXP SP2 if that helps.

Thanx in advance.

[attachment deleted by admin]

I think you need to fully uninstall Avast as from what I can tell having both Avast and CAV running at the same time even without On Access scanning enabled it tends to cause conflicts. Try completely uninstalling Avast, use something like CCleaner to remove temp files and clean the registry. Also get rid of any uninstalled Avast files.

I’m not overly familiar with Avast but it does seem to cause lots of problems who use CAV or CPF along with it.


Hi and welcome,

I’m afraid Eric’s right. Even when you disable on access scanning of an AV it still may not be completely disabled and thus causes conflicts between the two AV’s.

Have you tried going to start>>run>>type ‘msconfig’ (without quotes)>>click ok>>click services tab>>untick any services relating to avast! and make sure the ones for CAV are ticked.

For an on demand scanner you can try an AV that doesn’t have any resident protection like BitDefender if you want to use CAV.


To add to my above post:

avast! doesn’t like being installed with other AV’s so often disables itself or the other AV to stop conflicts.

Does the procedure (msconfig, disabling services) in my above post work at all?


Thank you for your replies. I will try the aVast “crippling” through MSCONFIG before uninstalling it completely… but I think I have read recently that a new version of CAV will be coming soon, so I may wait for that before I try reinstalling CAV again.

Ok. Let us know how you get on when you do.


I decided to try CAV beta 1.1 again. This time I unistalled aVast, rebooted, installed CAV, rebooted, applied CAV updates… and still had the same problem.

What was odd however was that CAV said it was “activated”, when at no time did i add my activation code. So it seems some things were remembered after the past uninstall. So I unistalled it again, deleted the CAV folder, and checked all registry entries pertaining to Comodo and Comodo Group… and found no references to CAV or preserved settings. Odd…

I’d like to think that this attempt failed because of old residue, but I can’t find it.

I’m hoping CAV 2.0 is happier! (R)

My issue is solved! Read more @ [url],986.msg6724.html#msg6724[/url]