Error(s) during update process [Merged Threads]

You may be having UAC problems.

Try exiting the firewall (right click the tray icon and select exit) then run the firewall again by right clicking on the start menu icon for the firewall and selecting “run as administrator”.

same thing happened to me and now it wont even boot up. says cfp.exe1 cant find what program created it

Hello, when attempting to apply the latest update manually (the update notification bubble disappeared before I had a chance to click on it), I get the following error:

       Error 119: Downloaded file is not signed by COMODO. This is only possible if update process has been hijacked by some malicious application or updates have been re-directed to wrong sources. Please contact support.

Does anyone have any idea what is going on here? I wouldn’t mind deleting the update it just downloaded and see if a re-download will work. Does anyone know where this file resides?

I am running Windows Vista btw with 2GB of memory. Antivirus program is CA. Other updates in the past have updated without any problem, and I have not changed any hardware/software recently.

Thanks!!

I’ve been having this same problem for the last week or 10 days. I have a broadband connection which is not totally reliable (it’s not unusual to need 3 downloads to get one that is not corrupted, but it is unusual to need more than 3!). I’ve now had the same error message maybe 20 times - this is NOT normal. And I’ve had no problems with, for example, Windows updates.

I thought I had some sort of a clue when I noticed that the download was regularly stopping at 18% complete. Left it a few days, hoping that Comodo would realise there was a problem and do a fix. But today it failed at 6% download. I was too frustrated to try it more than twice…

I’m on version 3.0.15.277

i confirm, having the same problem.

Me too!

Tried again and it worked!
:SMLR

Comodo firewall 3.0 said there is a new version of updates available, so I deiced to update it through the Comodo internal updater. But Comodo updated about 50% and said it lost the connection half-way and so I had to re-update and again it said the same thing 5 times. Finally it downloaded the update and it came up with an error saying it couldn’t copy ctp.exe and I tried to update it again and it said the same thing. So I went to diagnostics and it said nothing wrong with my firewall.

What version does it say you have in Miscellaneous > About?

Latest is 3.0.18.309

Mine auto updated fine. Do you suggest leaving it be? Or uninstall it and reinstall again? I done that method with the last update.

My comodo version is: 3.0.17.304 and I am using Xp pro service pack 2.

If there is a Comodo uninstall tool, could you provide me the link because the standard uninstall(add/remove) seems ineffective.

See:

https://forums.comodo.com/help_for_v3/comprehensive_instructions_for_completely_removing_comodo_firewall_pro_3_info-t17220.0.html

Regards,
Mike

You don’t need to use that link to uninstall unless your having problems. I use Revo Uninstaller in advanced mode and it works just fine.

a few moments ago i also had a problem with the updater. during the update, i’ve got the following error:

Error 112: Unable to copy file: cfpsbmit.exe. Please contact support.

actually i am using v3.0.16.295. btw, the diagnostics utility can’t find any problems.

//edit:

strange … after i re-updated cfp, the updater just copied 3 files and now its done. seemed to be a temporarely file access rights problem with my winxp o.O

COMODO, are you listening, please? …

So, how come Comodo does not ask to ‘run as administrator’ all by itself??? Surely it shouldn’t run as a normal user. And in any case, shouldn’t the updater run under admin priveleges? (I have Vista32, UAC enabled, and I expect to be prompted by programs that need Admin access). I’ve been getting error 112 for file cfpconfg.exe. I restarted firewall sometime in the session before the update ran, which I now assume, ran without admin privileges.

I got error 112 when going from v 3.0.16 to 17 AND from 17 to 18. I had to manually uninstall v16 and install v17, and it looks like I’m going to have to do the same for v17 to v18. I lost all my settings the first time, because I had never exported them and there was nothing to indicate that I should, that re-installing would lose them. Other software I have ‘re-installed’ or ‘repaired’ over the years has preserved settings.

I need Comodo over Windows firewall because WF won’t let me use separate levels of protection for LAN and dial-up networks. I hope you can fix Comodo to run with correct UAC/privileges on Vista; and to notify the user clearly of the value of ‘exporting’ settings before an uninstall.

:slight_smile: Update 113 and 109 Errors - This worked for me… here in the deepest South of France (only dial-up available) My set-up = Vista Home Premium and networked Windows XP (SP2). COMODO update via Vista from v 3.0.17.304 to 3.0.18.309 with dial-up (USB) modem - no probs whatso. But, no go with W-XP either across the lan or direct via 56K external - always nearly there but not quite there (errors 113 & 109). So (after 6 hours figuring this) uninstalled local machine modem drivers and let W-XP find the modem again and re-installed drivers with COMODO running with pro-active defense temporarily disabled. Job done! Exactly why quite this worked for me - I’m not techy enough to understand, but it did in my circs, but it may not work for everyone I guess. Well done COMODO for offering a FREE first-class product! A Question: I’m wondering if you might change the way COMODO update connects to your update servers? Give us a port, any port? Maybe a special stealthed and dedicated port exclusive to COMODO? :slight_smile:

If your on dial up you really don’t need a firewall in all honestly.

Please explain.

Regards,
Mike

I am a relative newbie and recently upgraded to version 3.0.17.304 and am now also getting Error 102 Temporary File/disc space warnings when I try to update manually after autoupdate failures. (I have enabled autoupdate and when CFP sends messages that updates are available and I respond to perform the update, the window just closes, apparently without downloading anything. I tried the manual updates after the autoupdate failures)

I did not have this problem with earlier versions of CFP.

A couple of possibly related items:

  1. I ran the CFP diagnostic tool and it found something to correct (without identifying what it was). When I ran it again it found no remaining problems. This didn’t help the Error 102 problem.

  2. I recently installed SpyBot S&D and let it run in resident mode. I took it out of resident mode after getting the CFP error message, but that didn’t solve the problem.

  3. I get occasional inadequate Temporary folder space error messages when trying to send email in Thunderbird but there is plenty of unused hard disc space on my laptop.

Any thoughts?

Mike

Download the current version off the main page.