Error message: Missing module!

I am running WinXP and I update manually. Today I encountered an error message (while attempting to manually update) that said:

[b]"Missing module!

Can’t find BOC4UPD.EXE to perform autoupdate.

On VISTA, this error means that you need to permit the ‘Updater’ through the Windows firewall settings because the ‘updater’ is being BLOCKED!"[/b]

I was then able to successfully update via the start program menu updater (not the internal updater), but any subsequent attempt to manually update via the internal program updater results in this error dialog being displayed.

I see that Kevin replied to another user’s post about this error message here →;msg153601#msg153601 , but I’d like to bring this to the forum’s attention again, and ask what I should do to fix it.

** Edit: My firewall is ZAP 7.0.462.000

[attachment deleted by admin]

Good one … “official answer” is I honestly don’t know … the error that you’re receiving (if XP) is that some sort of UAC action is happening there, denying the start of the updater. In simpler words, there’s some sort of “permission problem” which is preventing BOClean from “calling” the external updater from within BOClean. Means “execution is blocked” in purely “geek terms.” :slight_smile:

In Vista, under BOC 4.25, we executed the update inside BOClean itself under Vista and XP rather than doing what we’d done before in 4.23 and earlier - calling that external BOCUPD4.exe thingy at all times … that’s the updater, and we always kept it SEPARATE in BOClean. I mean … if a security program is gonna go and create a connection to the “intarwebs” and just SIT there after it’s done an update, I always saw that as a “security risk” … close the ports, shut down the “web-aware” application and NEVER call internet inside a security program. When 4.26 was released, we removed that “internal” for XP and earlier and left it SOLELY for Vista as there was no way around UAC. The XP version in 4.26 calls external where it was internal in 4.25.

And before anyone suspects that the weird problems we’ve seen here and there have anything to do with that change, only happens when the update is called, does its thing and done. I’m still looking at any possibilities of that in its relationship with other oddities, and since I am the SOLE “keeper of the code,” and having written all of it, still can’t find the connection there.

This all said, definitely not a bug in BOClean there … (I have found a few with some help from others using BOClean) … I’d have a look in what’s required in that copy of ZA and see if there’s something in there which wants to block “child processes” (which is what BOC4UPD is) and see if there isn’t a setting or more which will PERMIT BOClean to spank its child and make it go to bed for an update. Heh.

Dunno from ZA, hasn’t done it for me since the 90’s. I eat OUR dogfood here. :slight_smile:

I switched on autoupdate for awhile (sorry, don’t know if an update occured or not) and then went back to manual updating and the error message has not returned since. Everything is back to normal. I didn’t change anything with my firewall. So changing BOClean settings fixed the problem.

Sounds like you doubt that I have WinXP. I said I did.

Sounds like you’re knocking ZoneAlarmPro? I’ve run BOClean for 5 years and ZoneAlarm for at least 8 years. So ZAP has “done it” for me longer than BOClean. I think what I experienced is a bug in BOClean, oh keeper of the code. :slight_smile:

Sorry for any apparent misunderstandings … when I referred to ZA at all, was doing so simply on a basis of that I haven’t used it for a very long time and I lack any knowledge of its settings. That’s all I meant by that is “I don’t know how to work it.” :slight_smile:

And as far as mentioning XP, one of the problems with any forum anywhere is that if I say “give this a try, should work” or try to explain how things work “under the hood” I need to be very specific and mentioned “If XP” solely on a basis that what I posted up above is not applicable to any other Windows version than XP … in hopes that someone won’t lift those words above and recommend doing something that isn’t going to work on another version of Windows and only results in more misunderstandings down the road. I’ve often seen advice I’ve offered for a specific situation suddenly becoming a FAQ of “always do this.” Nothing more than that.

Reason why I went into the explanation is that the error message you were getting is an OLD one, rarely seen, and is intended actually for OLDER versions of Windows (that error possibility goes back to Win98) and was always the result of the BOC4UPD.exe file actually being MISSING since that would be the only thing that would prevent it from running - namely that the program was actually missing!

After the explanation, was trying to tell you that if that message appears, what it’s actually saying is that BOClean could not run the updater (usually because it was missing) and when a program calls another program, it does so by passing a command to the OS telling it to run a program. Vista changed how this works, but was never a problem in XP itself. Therefore, something ELSE is actually blocking that call. Only things that usually block execution would be a firewall, which is why I suggested it could be ZA blocking it as that would be expected if ZA is unaware of BOClean.

Back in the “old days” I could email a friend named Marcus who worked there, and he’d have ZA updated to recognize any new builds of BOClean as soon as possible. He’d also be a great wealth of information on any necessary workarounds. He and I worked together for years this way. However, he’s not with them anymore and I don’t know who to contact there. As a result, I suggested seeing if you could check the settings and see if somehow BOC4UPD is being blocked. That’s what I suspect the problem is. Autoupdate is pretty handy though.

Once again, sorry for any misunderstandings there …

Hi fracTure - may I ask exactly what you mean by “I switched on autoupdate for awhile”? In my configuration, the box is ticked for ‘Check for update every xx hours…’ which presumably means my autoupdate has been switched on for a helluva long while but I still get the error message. How can I get shot of it like you seem to have? I run Vista and have changed the firewall to allow the updater inbound and outbound access - still no difference. I have also UNchecked the box saying ‘Do NOT show automatic update screen’ but I have yet to see an update screen. Accordingly, I’m not sure if I’m updating or not…

Now for the daft newbie question - what is it we’re talking about here? Updates of ‘definitions’ or updates to BOClean itself?

Hello pooksahib

If I understand you correctly, you want to know how I configured BOClean for manual update? By unticking the autoupdate box. I have always done manual updating. I explained to Kevin that I turned autoupdate back on (by checking the box again) and upon returning to manual updating (unchecking the box) the error message no longer appeared.

To get a shot of it like I did, do what is called a screen capture. There are various softwares available to do this for you, or you can use mspaint, like I did (click on start/run/type in mspaint/click enter). To capture the error message, simultaneously press down on the alt+print screen keys. You can capture the entire desktop by pressing just print screen. Then save the file to your hard drive and upload it in the forum.

Sounds like you run Vista, and so you may have a different set of circumstances than I do with WinXP. Check out the link in my first post wherein Kevin replies to a user with Vista, perhaps that will help. I have not paid attention to the Vista responses because I don’t run it.

And yes, we’re referring to definition or signature updates, not program updates.

Hope this helps a little bit.

FYI, WinXP is the only operating system I have ever had on this box.

Thanks for that fracTure. I’ve done as much tinkering as I can and suspect I’ll have to await a proper ‘fix’ for this Missing Module error. Apologies for the use of vernacular - when I say ‘get shot of it’ I meant ‘get rid of it’! But thanks for taking the time to provide the info on screenshots anyway.

Ummm … guys? Hate to be curt, but I suppose I need to put this in a plainer explanation. When this error is appearing, the culprit is some OTHER “security program” which is STOPPING BOClean from running its updater automatically. There is no specific error returned from the autoupdate on XP other than “failed.” Why? We’ll never know. That’s how WINDOWS works. :frowning:

Over ten years’ time, we’ve always seen a handful of people who will get this error, and over that ten years the problem was caused by the file actually BEING missing, corrupted, or otherwise hosed. In THIS case, an uninstall and reinstall solved it.

Recently though, OTHER “security programs” have stopped this as a matter of their design (no child processes permitted unless excluded in THEIR program) or the security programs weren’t setup properly OR … last possibility … PERMISSIONS have been set on limited accounts to prevent that (though usually only a corporate admin will be THIS paranoid, but will also allow BOC4UPD to run knowing what it is) …

bottom line, it is NOT a problem in BOClean, never was … BOC4UPD wants to get an internet connection and download from COMODO’s website your update. Paranoid settings in other security programs will cause this to not happen, and unfortunately since the problem is NOT in BOClean … one needs to find which settings in something else are blocking that update, and windows telling BOClean “FAIL” … that’s what pops up that message. :frowning:

Yez puleez mak us unnerstan

No offence was intended Kevin, it’s just that the error message is so specific - “On Vista, this means you have to permit the updater through windows firewall”. I’ve given the updater carte blanche to come and go as it likes but to no avail. And I don’t know what else could be blocking it - I’ve only got Windows Defender, AVG and Vista Firewall Control none of which are blocking BOC to the best of my knowledge.

Have you tried stopping shutdown AVG and Vista Firewall Control offline to see if it works you will get a 108 error from the manual update but it should ask for admin password first if you use a limited account.

THANK YOU! There’s something actually useful … a 108 error means that the site was contacted. “Your” end then tried to download, got a STATUS OK back from the website here, and then the data coming down to you was completely blocked. Never got there. DEFINITELY a “data blocker” such as a firewall or other “security program” that allowed the connection, hooked it up and all, and then stopped the data from coming in.

I wish I had a better answer … all I can explain is how the code I wrote works, and when something goes sideways somewhere else, I’m stuck in the unfortunate position of “if I wrote it, I can definitely FIX it once I know what went wrong, where to look, and what to change.” That’s EASY! Alas, can’t fix OTHER people’s code and this error is the direct result of something else which is blocking the download.

Other than turn off the “security software” one at a time and ONLY go for the autoupdate and don’t go anywhere not already KNOWN as safe for the test and see WHICH one is doing that. From there, we can figure out how to allow it. The OLD BOCleans prior to 4.26 were FTP based whereas 4.26 now does an HTTP download. Perhaps it’s old firewall rules from an earlier version on a firewall which isn’t slick enough to notice that the file’s changed. It’s also possible that your IE browser is set to “offline” although THAT should present an “Error 106” instead. I’d really like this to work for you guys, but the problem ABSOLUTELY is not in BOClean. And I’d get arrested if I were to fix Windows or some other product. :slight_smile:

It was just a suggestion for the others auto and manual update works fine for me on Vista when connected ethernet cable to router
The only odd thing I get is the auto update has worked you can see the new update date if I then do a manual update from link on page which comes up after right on click icon it uploads the file again instead of saying I have the latest update and reloads the update with the same date. If I do a further manual update it then says I have the latest update.
I have the box unticked but the autoupdate screen never comes up.
Also I was unpluged from the internet no connecton when I had the error 108.

It sounds like an interesting conundrum but I’m not really bothered any longer. Whenever I right click the tray icon, the small BOClean page has a very recent UTC date for the last update (usually today or yesterday). So it must be updating. Point of interest: when I click ‘check for update’ and get the Missing Module message (and close it) the Last Update date changes to ‘authenticating’ for a few seconds. Which kind of reassures me… So I’m not about to go closing down my AVG etc one by one for no real reason. Not that you can close down AVG anyway, it doesn’t seem to have that option.


You could try doing the reverse of what I did to see if it makes the error message go away.

I was running with autoupdating OFF when the message appeared, so I turned autoupdating ON for a short period of time, then switched back to autoupdating OFF. That made the error message disappear.

You are running with autoupdating ON when the message appears, so try turning autoupdating OFF for a short period of time, then switch back to autoupdating ON.

Might work and it’s worth a try.

Good luck :slight_smile:

Already fixed for the next release … only question at the moment is WHEN. :slight_smile: