Error exporting CIS Configuration (v3.5.54375.427 x64)


In the CIS GUI, if I go to Miscellaneous → Manage My Configurations → Export → Comodo - Proactive Security, it will prompt me to save the export file (which is good), I select a directory and give it a filename and press “OK”, but it give the error:

“Unable to obtain necessary rights.
Please run this utility as Administrator and try again.”

Running the Comodo GUI as an Administrator also gives the same results. I did a clean install of CIS (ie. uninstalled CFP 3.0.25 and installed CIS without Antivirus as I have Nod32 Antivirus installed).


* CPU: 64 bit
* Windows Vista Ultimate sp1
* CIS 3.5.54375.427, Eset Nod32 Antivirus 3.0.642.
* Specific symptoms of the bug: see above.
* Specific steps you have taken to try to resolve it: run GUI as Administrator.  Didn't work.
* Brief description of your Defense+ mode: Clean PC mode
   Firewall+ mode: Safe mode
   No modified Advanced settings.
* Reboot/BSOD: N/A.
* UAC Enabled.  Occurs with both Administrator and Standard accounts.

How can this be resolved?

Thanks for any help!

I use Vista64 premium SP1,
same CIS 427 version, UAC on too., also FW and F+ only, avast av installed.

Export as admin works OK for me.

Try again to export settings to location
you are sure have write access.

Note that I have imported settings manually from CFPW 3 version.

Hi Poutnik,

Thanks for your feedback. I tried again to export to my user’s “Documents” folder with the same error message.
I did not import my settings at all.
As it works for you, I guess it is a bad install for some reason.
I guess I’ll try uninstalling CIS and reinstalling again from scratch.


Even if running as admin, close the gui , wait a while to let it close on backgroung, and run again, explicitly like admin.
The it should work

I need to disable UAC to do export and import.

I get the exact same error message (Vista Ultimate SP1, Core 2 Duo 32-bit, NOD32 without CIS Antivirus), using CIS under admin account.

FWIW, I got the same error with CFP v3 when I tried to export my settings (before uninstalling) so that I could import them into CIS. Since that failed, I uninstalled CFP and then did a clean install of CIS.

Run CFP(or CIS) as Administrator (close CFP, right click on CFP icon and choose run as administrator), or disable UAC during configuration export

I receive the same error. CIS was installed as “Run as Administrator”. I have then started CIS “Run as Administrator”, but still cannot export the settings.
The basic problem for me is in the save as “file name” does not present any format options. The only option offered is ‘All files (“.”)’, so the save process doesn’t know how to save the configuration settings. ???
I am using Vista Ultimate 64-bit, on a Core2Duo E6600. Everything else I have tried in the new CIS seems to work fine.
The import function appears to be similar – the only format option offered is ‘All files (“.”)’.

There is no extension for CIS exported configuration files for now. You can save it even without any extension and still will be able to import it again. But note that CIS does configuration format check, so you will not be allowed to export file that is not CIS(CFP) exported configuration.