Error : Engine Initialization Failed [Resolved]

First off would just like to say hi to all as this is my first post.

I have Comodo Firewall [works great] and Antivirus installed but Antivirus does not seem to be working properly because when i try a full system scan it just gets stuck on starting scanning engine and then comes up with this error:

[b]Error : Engine Initialization Failed

** Unhandled Exception! ExpCode: 0xC0000005 ExpFlags: 0 ExpAddress: 0x00410E6C

thanks for any help :wink:

I’ve seen a couple references like this in the forum lately.

here is another related post…,1250.0.html

I have decided to give it a try myself and also have the issue. I used to be able to run these scans, and suspect that an auto-update is at the root of the issue.

I have e-mailed; hopefully you have done the same.

I uninstalled and then reinstalled that seemed to do the trick.

Ok, I’ll give that a try as well and post back my results.

Like I said it worked for me, so if it doesn’t work for you, well then I guess it doesn’t like you ;D (kidding).

Hmm, Ryan’s Hal.dll issue has me spooked (makes a Hal.dll backup)… but if it worked for you, I’ll help prove/debunk both theories in one blow. :smiley:

I can confirm the “reinstall” as a fix… not ideal, but certainly a fix. ;D

It’s good to be liked by Comodo software :wink:


Well it works :slight_smile:

The error “engine initialization failed” may come if user has not selected to reboot the system when updater asks to reboot the system. So, simply restarting the system will fix this problem.

Interesting… I don’t remember seeing a prompt asking me to do that… If it updated while I was a work, I would have never known.

I wonder how often it it retries sending that message?

hello the re-install fix only works until cavs downloads updates it then reports " Error : Engine Initialization Failed " will have to hope the techies come up wth a fix

It seems that your response matches the response I got from Comodo Support…

This problem may come if you may not have restarted the system after last updates. Please restart the system after updates and try again to run the on-demand scanner. If still facing the problem please let us know, we can provide immediate solution.
I’m fine with the reboot solution, but will be looking for CAVS 2.0 Beta to resolve this.

Well… I just got a “CAV has updated, please reboot to take effect” message!! I checked the verison information and it was the updater that got updated! Sweet!

Unpackers got added also :slight_smile:

Doh! off by a letter… it was the “Program Updates Version” that incrimented, not the version of the Updater :wink: (CavAUD.exe I think).

Sorry to revive this ancient thread but I received ***Unhandled Exception! Exp:0C0000005 ExpFlags:0
ExpAddress:0x00410E6C Please Report!

I am using Vista Ultimate (32 bit), reinstalled this and it worked until it updated again. I was trying to do a right-click file scan when it occurred.

Thank you,


I don’t think Comodo products are Vista-compatible yet. I know the next version of the firewall will be; it’s due for beta testing in April (current timetable…subject to change).

Even tho you’ve got a 32bit system, it may not work right. I would suggest filing a ticket with Support to verify that.


I can confirm that.