error: cant initialise session manager?

I get an error with latest stable release “cant initialise session manager, fast user switching is not supported”. I dont even use fast user switching and its service is disabled. Also the CPF icon takes about 5 mins after boot before you can open CPF saying “initialising or something”.

Seems to run fine after this, but didn’t happen with beta version.

Just saw in another thread that Terminal Services is required to stop this. I disabled it and its staying that way as its a security risk, so I’ll use the beta until this is fixed.

This is just a message saying that fast user switching is disabled. There is no problem with CPF and it’s still protecting you.
I believe you can enable terminal services without fast user switching enabled.


thanks, Ill keep the latest stable then.

Thing is, that loads of people will have disabled “Terminal Services” as part of recomendations to disable unnecessary services for speed and security. This message and the slow down in initialising, should be looked at, as some new users may be turned away by it.

Yes. It adds maximum 2 minutes of delay. But this should be fixed if user does not want to enable FUS. Lets see if we can fix this next week.


Hi Egemen,

I really hope Comodo can fix this without requiring us to turn on the Fast User Switching and Terminal Services. Turning on more services in order to run CPF means more memory are utilised to run CPF optimally. All the previous versions doesn’t require us to turn on these two Windows services and I’m sure Comodo can find a workaround for it.

We have fixed the issue. You wont have to enable it for faster booting anymore. We will try to issue a fix next week.



Great! This is why I like using Comodo Products, excellent support! Thanks for the fix.