Error Authenticating to Tor

I am running the current CFP Version 3.0.22.349 on XPsp3. Tor starts up just fine. When I turn of the proxy setting off in Firefox or any other browser for that matter it works fine but when Vidalia after a browser using Tor has been used is turned off and turn it back on I get in Vidalia which is a control center for Tor the message in this pop up window:

Error Authenticating to Tor
Vidalia was unable to authenticate to Tor. (control socket is not connected)
Please check your port authentication settings

The computer has to be rebooted to start up tor. Shutting of Comodo and turning on doesn’t help. Uninstalling Comodo and the problem of tor authentication goes away. From any of the tor info I can find the same question pops up from others that have experienced the same, " Is the firewall blocking the connection?" Is there a solution to the problem I’m experiencing?

Any help is appreciated.

Thanks

There are serious bugs in SP3 thats why Microsoft pulled it back. Have you tried making Firefox a web browser in the firewall rules under network security policy.

I’ll try that but the problem isn’t Firefox it is with Tor. Any browser that connectes through Tor will do this. I don’t know anything about writting rules or permissions so I can’t approach it from that angle. Making Tor (really the package of three programs: Tor, Vidalia and Privoxy) as trusted hasn’t helped.

Generally when you get this error:

Error Authenticating to Tor
Vidalia was unable to authenticate to Tor. (control socket is not connected)
Please check your port authentication settings

It is a matter of going into Vidaliia’s settings and in the advanced tab and setting the authentication to “none”. In the past it was a problem with the “password” setting. It doesn’t happen in the latest release. I was using Look N Stop where this problem doesn’t exist. Under XPsp2 I got the same problem with Agnitum Outpost beside the ocassional bsod, there was also some problem with Tor years ago when the control center was called Torcp ZoneAlarm 5.0 didn’t allow Tor to connect to 127.0.0.1. In the post boot startup Tor loads up before Comodo is fully working and this might be why there is no problem initially. I’d like to switch to Comodo but this is the thing stopping me.

I’ve been trying the version of Opera that is bundled with Tor and Privoxy and that is OK with CFP3.