Error 5: Access is denied. Rolling back installation.

Hello all,

I just upgraded my Vista to Ultimate 64 bit.
When I attempt to install Comodo Firewall I get:

Error 5: Access is denied.
Rolling back installation.

Anyone have any ideas? I tried searching but it won’t let me input “Error 5.”

Did you download the 64 bit version or the 32 bit version? Also where did you download Comodo from?

Hello I downloaded from the Comodo main site. Yes, it is the 64 bit version.


I dont use Vista but here is a link to a thread. Try deleting that download and starting over with a fresh one and be sure to clean out your cookies and temp files first with CCleaner. Turn off UAC in Vista also.

Already tried redownloading. Even tried using IE. No go.


Can you try turning UAC off like V suggested?

Also post your security apps.


UAC has been off already. Sorry for not mentioning it.

Security apps. I disabled all the Windows stuff. Only thing I have runnning is AVG 7.5; which I disabled to install Comodo. But still no go. This is also an administrator account.

Try to launch setup file “run as admin”.
If it won’t install, try to install not to default location (c:\program files…). Once i had infamous “rolling back” issue, and installing to drive’s root (c:) helped me to resolve it.

Running as an Administrator and installing straight to C:\ root doesn’t work either.

Try the 32 bit. Doesn’t let me run it… as this is 64 bit. (worth a try)

Edit: Well… I went to Safe Mode and installed it. It seems to be running fine at the moment. Will update on any issues.