Error 193 / "not a valid Win32 application" [resolved]

About two days ago CPF agent stopped working. Since then I’ve been trying a number of suggestions/links from the Current 2.4 solutions thread but, still get the following.

This error when I try to start the service in mgmt console:
Could not start the Comodo Application Agent service on Local Computer. Error 193: 0xc1

And on load I get the message that none of the following are active:
-network monitor
-application monitor
-application agent

The engines are visible in Device Manager. Windows Firewall is off/disabled by default.
My only thought is that there is a conflict in the registry that has occurred. All help is appreciated.

Here is what I’ve tried so far:

  1. Checked advanced startup setting in Spybot. Reset

  2. Uninstalled AdAware2006 & Spybot.

  3. Uninstalled/Reinstalled CPF.

  4. Initiated standard system boot in msconfig. (By default I use a nogui/fast boot modification)

  5. Tried Safe mode install. Error you are trying to install a different version. Please uninstall CPF from the add/remove programs menu. It isn’t in the add/remove program menu.

  6. Uninstalled Avast

  7. sfc /scannow. fine

  8. chkdsk. fine

  9. registry check. fine

  10. System Restore back to before problem started. Stated no changes had occured since then.

  11. Clean all registry Entries related to Comodo Firewall. Big mistake, port problems. Restored Registry.

Hey, SirSmiley!

We haven’t seen you in a while, so I guess that means all has been well. :smiley:

Is there some event you are aware of that may have precipitated the problem with CFP not loading, and monitors being dead?

Typically, I have only seen this on a non-compatible system, but you’ve had it working for a while, correct? No system changes?

When you say you cleaned Comodo entries from the registry and this caused problems, what method did you use to clean it? Did you do it manually thru Regedit, or did you use a software to clean it for you? Also, when you say you had port problems, can you clarify what you mean by that?



Yeah, it’s been awhile but, CPF has been working great. I used regseeker & searched on every Comodo entry then removed them all.

Since the error doesn’t appear to be in the Event Logs. Basically, I couldn’t get dialup to work and Avast either.

I installed/removed two apps since this problem started. Shedko Shutdown (Which didn’t work) and ShutX. Both use hooks to override Xp’s standard shutdown dialog.

Ok. This is strange…um I should’ve read the Event Logs better. According to them there is an error in the file system structure but, chkdsk was ran after these errors and on boot. Maybe I’ll try a chkdsk scan from the recovery console. Or maybe the boot file is corrupted?

Here’s some of the errors that appear at my last boot, as I’ve only Hibernated since then:

The Comodo Application Agent service failed to start due to the following error:
Comodo Application Agent is not a valid Win32 application.

The file system structure on the disk is corrupt and unusable. Please run the chkdsk utility on the volume C:.

The following boot-start or system-start driver(s) failed to load:

The IPSEC Services service terminated with the following error:
An invalid argument was supplied.

The Intel NCS NetService service failed to start due to the following error:
Intel NCS NetService is not a valid Win32 application.

Sorry for the double post. Also installed Safari’s first beta when it first came out…not impressed.

I had a problem with sptd last year before CPF. This was related to Daemon Tools? It was fixed.

Rather than “manually” searching for Comodo entries with RegSeeker, what if you use it on Automatic? You’d select “Clean the Registry” then click the buttom for “Auto Clean.” Select the number of passes and so on, and let it do it without interaction. Wait for it to delete the files it tags, and reboot.

It’s easy enough to still delete something that should not have been, when doing it “manually.” Auto can still cause problems, too… after all, we’re dealing with the Regfiles… but it’s a little more gentle, perhaps, than a user. :wink:

I’ve seen something about that type of error; let me see if I can turn anything up.


Usually I clean the registry that way. Primarily I use Eusing Free Registry Cleaner for most of my registry maintenance.

Early last year I had to do MBR fix and have had some service issues related to Automatic Update. MS solution was to disable the automatic update. Either way I’m booting off into recovery mode and will let you know if that works.

Oy, please do keep us posted.

I generally clean the registry between installs, and have not had such issues. It may be related to what caused the failure in the first place.

BTW, I found what I was looking for on the error report; it related to a separate application, not CFP (the not a valid Win32 application error).


Sadly I’ve been lacking in my disk mgm’t tasks. Which hopefully this is the issue.


Let us know how that turns out.


Okay. I fixed the disk also did a defrag (long over due). Uninstalled CPF in safemode. Rebooted into safe mode then cleaned the registry. Rebooted back into safe mode then reinstalled CPF but, the problem persists with this error from the event log. Is there a way to uninstall/reinstall the agent from the command line?

Event Type: Error
Event Source: Service Control Manager
Event Category: None
Event ID: 7000
Date: 6/28/2007
Time: 9:23:21 PM
User: N/A
The Comodo Application Agent service failed to start due to the following error:
Comodo Application Agent is not a valid Win32 application.

Alright, this is one of those strange Windows things. Did a search on “Event ID 7000” which led me to this tip

Briefly just following the three lines below helped me start the agent. Then I quit CPF and restarted CPF and ta da! :BNC No reboot necessary. Going to check my environment variable to see if this is maybe where it ■■■■■■■ up in the first place. Thanks for the help!

If the problem is a space in the folder name, find the executable at

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\services<name of service>\ImagePath

and put quotes around the string. Example: “C:\Program Files\Humpy_Dumpty.exe”

two stupid " " quote signs…

now it works perfectly!:slight_smile:

thank you guys!

Great work, SirSmiley! We’ll close this one out, then. If you need it reopened, just PM a Moderator and we’ll be glad to do so.


PS: I’ve changed the Subject line on the first post, to give better search results to others with the same issue.