Epic fail with two DialUps no traffic monitored on one of the connections[NBZ]

The bug/issue

  1. What you did:
    Dial 2 dialups simultaneously ( mobile phone modems ) and leave default gateway to connection , that was dialed first
  2. What actually happened or you actually saw:
    There is no filterin through first dialup ! Neiter in Safe mode nor with Custom policy . No connections through first gateway are shown in monitor , no requests for applications ( except application is trying to reach ). Traffic goes out of control
    If then reassign default gateway to second dialup , CIS comes to work
    3.What you expected to happen or see:
    Total filtering
    4.How you tried to fix it & what happened:
    No idea
  3. If it’s an application compatibility problem have you tried the application fixes here?:
  4. Details & exact version of any application (except CIS) involved with download link:
  5. Whether you can make the problem happen again, and if so precise steps to make it happen:
    Yes . Dial one dialup connection with checked “Use default gateway” , then dial another with “Use default gateway” is not checked
  6. Any other information (eg your guess regarding the cause, with reasons):

Files appended

  1. Screenshots illustrating the bug: Not applicable
  2. Screenshots of related CIS event logs or the Defense+ Active Processes List: Not applicable
  3. A CIS config. report or file: Doesn’t matters
  4. Crash or freeze dump file: Not applicable

Your set-up

  1. CIS version, AV database version & configuration used:
    CIS 5.3.176757 , but the bug is since CFP3 and maybe much more earlier…
  2. a) Have you updated (without uninstall) from CIS 3 or 4: No
    b) if so, have you tried reinstalling (if not please do)?:
  3. a) Have you imported a config from a previous version of CIS: Doesn’t matters
    b) if so, have U tried a preset config (if not please do)?: Yes
  4. Have you made any other major changes to the default config (eg ticked ‘block all unknown requests’, other egs here.): No
  5. Defense+, Sandbox, Firewall & AV security level: D+=Disabled, Sandbox=Disabled, Firewall=Custom, AV=Stateful… But it doesn’t matters
  6. OS version, service pack, number of bits, UAC setting, & account type: Windows XP, SP3, 32 bit, None in XP, Admin account.
  7. Other security and utility software installed:
  8. Virtual machine used:

Thank you for your bug report in the required format.

Moved to verified.

Thank you