Enhanced Protection mode makes Toontown game crash though not sandboxed [M1369]

A. THE BUG/ISSUE (Varies from issue to issue)
Can U reproduce the problem & if so how reliably?:
Yes, 100% of the time.
If U can, exact steps to reproduce. If not, exactly what U did & what happened:
1:Run the “Toontown Rewritten” file on the desktop
2:Try to login to the game after downloading game files
3:The game will crash and continue to do so if you try to login again.
One or two sentences explaining what actually happened:
CIS on Enchanced Protection mode crashes the game even though it is trusted by CIS.
One or two sentences explaining what you expected to happen:
Game to run fine as it normally does.
If a software compatibility problem have you tried the advice to make programs work with CIS?:
It works by default with CIS on the default settings, as it is trusted by Comodo.
Any software except CIS/OS involved? If so - name, & exact version:
Toontown Rewritten |Download: Play | Toontown Rewritten (An account is needed to run the game and reproduce the issue.
Any other information, eg your guess at the cause, how U tried to fix it etc:
The game may be trying to access components that CIS maynot allow in EP mode.

Exact CIS version & configuration:
CIS Premium, Proactive Security Config
Modules enabled & level. D+/HIPS, Autosandbox/BBlocker, Firewall, & AV:
Hips Enabled (Clean PC Mode), Autosandbox Enabled, Firewall Enabled (Safe Mode), Antivirus Enabled (On-Access), Viruscope Enabled for all processes.
Have U made any other changes to the default config? (egs here.):
Yes, Av is On-Access, and HIPS is on Clean PC Mode.
Have U updated (without uninstall) from CIS 5 or CIS6?:
if so, have U tried a a a clean reinstall - if not please do?:
Have U imported a config from a previous version of CIS:
if so, have U tried a standard config - if not please do:
OS version, SP, 32/64 bit, UAC setting, account type, V.Machine used:
Windows 8.1, Fully Updated, 64 bit, UAC Enabled, Administrator, Not a Virtual Machine.
Other security/s’box software a) currently installed b) installed since OS, including initial trial security software included with system:
a=None b=None

[attachment deleted by admin]

I’m sorry that you are experiencing this problem.
Thank you for your report, I will try to reproduce this problem on our local machine.

Thanks Netguy.

Would you mind making a dump file - then I can get this put on the tracker and track it’s resolution.

To do this, please

  • replicate the situation in your Killswitch screenshot, with the Windows error dialog on the screen.
  • right click on the program executable in Killswitch and choose full dump,
  • zip and upload to cloud and paste link

Many thanks in anticipation


Here is the link to my dump file:


Thanks very much, forwarding.

Fixed in CIS version

Strike that, it appears the the issue is still present in this version and is NOT FIXED.

Not fixed in CIS v

Download for new full dump file: http://www.mediafire.com/download/3fnnfc25otrwhaz/TTREngine.zip

Thank you. I’ve updated tracker data.

Not fixed in

Thanks, Netguy101. I’ve updated tracker data : marked as ‘not fixed’ in mentioned version.

Thanks again.

Here is a new Full Dump file: http://www.mediafire.com/download/t037o1ven1by9cc/TTREngine.zip

and I have attached an error message related to the issue.

Also, can my first post be edited? The bug also occurs when CIS is HIPS is set to “Safe Mode”, AV is set to “Stateful” and ofcourse when “Enhanced Protection Mode” is enabled.

[attachment deleted by admin]

Thank you for the additional information.

I’m not sure if it’s valid since ‘enhanced protection mode’ implies ‘HIPS’ regardless of mode (except ‘Disabled’). Unless, you specify that ‘enhanced protection mode’ interferes with mentioned application if ‘HIPS’ is set to a particular mode (eg ‘Disabled’).

The issue occurs on both Clean PC and Safe Mode, so I guess HIPS setting doesn’t matter.

Should be fixed in moving to Resolved. If you feel that this is not fixed please say so here or PM a moderator. Thanks