Enhanced Protection Mode (HIPS) breaks HWMonitor [M1543]

A. THE BUG/ISSUE (Varies from issue to issue)
Can you reproduce the problem & if so how reliably?:
This is a reappearance of the bug that was fixed in my earlier report https://forums.comodo.com/resolvedoutdated-issues-cis/enhanced-protection-mode-causes-hwmonitor-speccy-to-malfunction-m1370-t108241.0.html;msg789263#msg789263. It is reproducible every single time.
If you can, exact steps to reproduce. If not, exactly what you did & what happened:
1: Turn on Enhanced Protection Mode in HIPS and reboot.
2: Start HWMonitor (or Speccy).
One or two sentences explaining what actually happened:
HWMonitor only shows a single CPU core on my 4-core i7 CPU. Speccy also only shows 1 core, although it also shows 8 logical processors. The Windows task manager shows (correctly) 4 cores and 8 logical processors.
One or two sentences explaining what you expected to happen:
HUWMoinitor should show temps for all four cores. Speccy should report there being 4 cores.
If a software compatibility problem have you tried the advice to make programs work with CIS?:
Any software except CIS/OS involved? If so - name, & exact version:
HWMonitor 1.28.0 (cpuid.com) and Speccy 1.28.709 64-bit (piriform.com)
Any other information, eg your guess at the cause, how you tried to fix it etc:
No idea on cause. Turning off Enhanced Protection Mode restores HWMonitor and Speccy to normal behaviour.

Exact CIS version & configuration: Proactive Security
Modules enabled & level. D+/HIPS, Autosandbox/BBlocker, Firewall, & AV:
AV (stateful), Firewall (safe mode), D+/HIPS(clean PC mode), Autosandbox (enabled), Viruscope (on), Cloud lookup (on)
Have you made any other changes to the default config? (egs here.):
Firewall entries added, HIPS entries added
Have you updated (without uninstall) from CIS 5, 6 or 7?:
No. Clean install of CIS 8 on a clean install of Windows 10
if so, have you tried a a a clean reinstall - if not please do?:
Have you imported a config from a previous version of CIS:
if so, have you tried a standard config - if not please do:
OS version, SP, 32/64 bit, UAC setting, account type, V.Machine used:
Windows 10 Pro 64-bit with all updates (build 10240) UAC on, admin account, laptop - Clevo W350ET chassis, i7 CPU, 12GB RAM, 120GB SSD, 750GB 7200rpm HDD
Other security/s’box software a) currently installed b) installed since OS, including initial trial security software included with system:
a=None b=None

[attachment deleted by admin]

Thank you very much for your report in standard format, with all information supplied. The care you have taken is much appreciated by Comodo, and will increase the likelihood that this bug can be fixed.

Developers may or may not communicate with you in the forum or by PM/IM, depending on time, availability, and need. Because you have supplied complete information they may be able to replicate and fix the bug without doing so.

Thanks again

Just to let you know that this is still broken.

I’ve updated tracker data.
Thank you.

Just toi let you know, I have the same setup as you (desktop though). I was getting this also. The latest update from Microsoft (fast ring, this week) removed both HWMonitor and Speccy, saying they were not completely compatible with Windows 10. I went to their website and DL’d the most recent and installed both again. This time, the CPU information read correctly, showing 4 cores and 8 threads.
This is not an issue with CIS, but rather an issue between Windows 10 and these two software programs.

I have stated this before: Please do not blame CIS for every issue when it is not the problem of CIS. (BTW, I never once thought CIS was responsible for this error in reading my CPU).
Fix your problem by installing the latest version of Speccy and HWMonitor, and stop whining needlessly.

This? From the global moderator? Do you really think this is an acceptable way to talk to someone who is, after all, only trying to help make CIS better? Do you really think a comment like this is going to make it more likely that I will report issues with CIS in the future? And please, just so that I can improve my posting skills, where was the whining in anything I posted here?

Thank you for the comment regarding updates. The version of HWmonitor I am running (1.28.0) is (still) the latest version available from CPUID. There is an update to Speccy which I have downloaded and installed and it still doesn’t show all 4 cores. My Windows 10 system is up to date (I have upgraded now to version 1511 and the problem is still there).

I have reported this problems before on a Windows 8.1 system (see https://forums.comodo.com/resolvedoutdated-issues-cis/enhanced-protection-mode-causes-hwmonitor-speccy-to-malfunction-m1370-t108241.0.html;msg789263#msg789263) and it was acknowledged as a CIS bug and was fixed. That is the reason I reported the problem when it cropped up again.

I don’t expect to be accused of whining on a bug reporting forum, nor do I expect to be treated like the dirt under your fingernails.
Have a good day.

I repeat. This is an issue between Microsoft and these programs.
Upon updating everything, the information is now displayed correctly (as can be seen in these pics).
CIS has nothing to do with the issue.

[attachment deleted by admin]

Thank you for that. This most certainly WAS a CIS issue with Windows 8.1 because they fixed it, that’s the reason I reported it again. I’ll await the Windows 10 update you speak of on the regular schedule (I’m not on the fast-ring) and see how it goes.

I’m still waiting for your apology for accusing me of whining and for the unnecessary rudeness of your previous post. Again, if you think that is the right way to speak to people then you should consider whether you are the right person to be a moderator at all.

It’s nice to be important, but it’s important to be nice.

I apologize for any rudeness you felt in my previous posting.
You are indeed a valued member of this community.

Thank you.

And many thanks for the very useful advice and information.

Same thing as ubuysa. I’ve opened a new thread because I didn’t find this one: https://forums.comodo.com/bug-reports-cis/proactive-security-on-windows-10-let-me-see-only-1-core-of-my-cpu-t114948.0.html

I hope CIS resolve soon with an update…

This is an issue with HWMonitor and Windows 10. Update both to the latest and your issues will resolve.

Thanks for that but I went back to Windows 8.1 some time ago. HWMonitor is broken in the same way on Windows 8.1 in CIS It’s nothing to do with Windows 10. It’s CIS.

Odds are that it’s fixed with next (major) version.

Hope it helps.

I’ve already the latest version of both softwares, as ubuysa said before…and the issue is not resolved…

Strange, since the issue resolved for me when I installed updated versions of these programs. Verified, with pics posted in the thread.

I don’t know why…it’s a fresh installation of windows 10, I installed all the updatem I installed CIS and all update, and I installed hwmonitor and speccy, latest version but the issue is not solved, as ubuysa said the same…

Should be fixed with CIS so moving to resolved. If you feel this is not fixed please PM a moderator. Thanks.

No, not resolved yest, at least on windows 10 installed in dual boot on a vhd, soon I will install it in normally way and I can tell you if it is resolved.

Working on mine