Enhanced protection mode causes HWMonitor & Speccy to malfunction [M1370]

A. THE BUG/ISSUE (Varies from issue to issue)
Can U reproduce the problem & if so how reliably?:
Yes, everytime
If U can, exact steps to reproduce. If not, exactly what U did & what happened:
1:Turn on hardware virtualization in CIS v8 HIPS (and reboot)
2:Start HWMonitor (or Speccy)
One or two sentences explaining what actually happened:
HWMonitor only shows a single CPU core on my 4-core i7 CPU. Speccy also only shows 1 core, although it also shows 8 logical processors. The Windows task manager shows (correctly) 4 cores and 8 logical processors.
One or two sentences explaining what you expected to happen:
HUWMoinitor should show temps for all four cores. Speccy should report there being 4 cores.
If a software compatibility problem have you tried the advice to make programs work with CIS?:
No
Any software except CIS/OS involved? If so - name, & exact version:
HWMonitor 1.25.0 (cpuid.com) and Speccy 1.26.698 (piriform.com)
Any other information, eg your guess at the cause, how U tried to fix it etc:
No idea on cause.

B. YOUR SETUP
Exact CIS version & configuration:
CIS 8.0.0.4337 - proactive security
Modules enabled & level. D+/HIPS, Autosandbox/BBlocker, Firewall, & AV:
AV (stateful), Firewall (safe mode), D+/HIPS(clean PC mode), Autosandbox (enabled), Viruscope (on), Cloud lookup (on)
Have U made any other changes to the default config? (egs here.):
Firewall entires added, Sandbox entries added
Have U updated (without uninstall) from CIS 5 or CIS6?:
No. This was a new clean install of WIndows 8.1, drivers, my usual apps and (new to me) CIS v8
if so, have U tried a a a clean reinstall - if not please do?:
Done
Have U imported a config from a previous version of CIS:
No
if so, have U tried a standard config - if not please do:
Yes, problem exists with vanilla CIS v8 (i.e. no changes made after install except HIPS hardware virtualization on)
OS version, SP, 32/64 bit, UAC setting, account type, V.Machine used:
Windows 8.1 64-bit with all updates. UAC on, admin account, laptop - Clevo W350ET chassis, i7 CPU, 12GB RAM, 120GB SSD, 750GB 7200rpm HDD
Other security/s’box software a) currently installed b) installed since OS, including initial trial security software included with system:
a=Malwarebytes Antimalware (free - scanner only) b=None included

[attachment deleted by admin]

No only these two programs are broken by the Enhanced Protection mode, also CPU-Z, RealTemp, HWInfo, and I’d say there are more.

Thank you for your report, we will try to reproduce it on our local machine.

Hi Ubuysa

Thanks very much for your report. Just to clarify

  1. HW monitor is running trusted and unsandboxed when this happens?
  2. By ‘hardware virtualisation on’ you mean ‘Enhanced protection mode on’?

Many thanks in anticipation

Mike

Yes. HWMonitor is in the trusted files list and it is not sandboxed

2) By 'hardware virtualisation on' you mean 'Enhanced protection mode on'?

Yes, the problem occurs with enhanced protection mode on.

OK many thanks ubuysa, forwarding

Hi, comodo internet security R80DFR_8.0.0.4344 is released! Please try this issue on the new build , thank you.

Thanks! I’ll try it out over the weekend and report back here. :slight_smile:

I didn’t realise it was available as an update, I was expecting to have to do a clean install. I’ve just updated to 8.0.0.4344 and the problem is fixed. HWMonitor and Speccy behave normally.

Thanks guys! This why we love Comodo. :slight_smile:

In that case, I will move this report to “Resolved/Outdated Issues” section.

Thank you.