endless loop scanning

Hi guys,
I’m not really sure, but it looks like an endless loop.
I have just installed the latest V4 CIS (free version) and I started a full scan.
The status field (of Scanning: My Computer window) is now displaying the same file, a codui.dll inside a nokia symbian SDK (it disappears for a very short time and then come back again - the same name).
The number of total objects scanned is 34286 and does not change at all. The running time at this moment is 1:00:35 and I will wait now a bit before shutting it down.
I don’t know how can I give you a better description or help on this issue…

firefox is running and some background processes (see attached images)

[attachment deleted by admin]

I have Windows XP Pro 32 bit SP3, almost all the latest patches are installed.
I have CIS V4, just downloaded, installed and updated itself (yesterday). Sorry at this moment I can’t tell the exact version information.

Can you please try trouble shooting steps as i described here:



I have just uploaded a file as Malware/False-Positive. It causes CIS AV scan to freeze. Maybe it is a quicker way to locate the problem.
The name of the file is: codviewer.exe, located originally in C:\S60\devices\S60_5th_Edition_SDK_v1.0\epoc32\release\winscw\udeb

Thanks, we will check it out.

is there any progress with this issue (at least is this helpful for you)?

Possible to tell us as how long this endless scan last?
Some time in minutes.



it was endless, I was not able to wait until it finished. As far as I remember I was waiting 70-80 minutes long before I killed the process.
If you wish I can try a longer run…

If it is useful I have the same problem and I let AV going for an entire night.

It seems to loop on the same group of files.

I have two differences to tell: first the number of scanned objects increases, but objects are the same, second, I’ve had somewhat the same problem with previous versions and I solved it just scanning manually single directories, vith version 4 the loop starts also with single directories. I noticed that the problem occurs with bigger directories such as 4 or 5 gigas and bigger.



Please help, I find impossible to perform any kind of system scanning

you could check the attached picture, it was at about an hour.

Right now it takes 13 minutes (scanning 1 file, codviewer.exe what I sent you already) - so it is not an endless loop.
During the scan the process cavscan.exe eats up more than 1 GB memory - usage grows up in the first 30 seconds)
When I press “stop scan” during this time the scan window will lost its comodo style settings (red frame) and will be frozen (= not refreshed).
Later on this frozen window will eat up more and more memory (see picture).
The window can be closed by clickeind on the X (upper right corner).

[attachment deleted by admin]

I think now I found 2 different bugs:
the first what I reported earlier today and the second is the original - cannot perform a full scan, because it looks like an endless loop.
The scanner stays at codui.dll (see the first posted image) and total objects scanned 34605, but eats up more and more memory.
I think it does not scan this file because the status line is flashing, maybe just the displayed information is not correct on the dialog.
I will now let it run longer. At this moment Duration is 30 minutes, 1.5 GB VM is used

altogether more than 9 hours and 1.85 GB VM used. Still the same file scanned…

Some news about this problem?

No news?

With the new update of CIS this problem was solved for me.

Thanks a lot for the good work!


Thanks for keeping us informed!