Enabling only SSH port for putty.exe

I have Comodo Firewall Pro v3.0.17.304 installed on a WinXP SP2 pc. I use putty to login via SSH to Linux servers.

I would like to allow putty access to only port 22 and block it from all other ports.

I’ve done this successfully with two application rules for putty.exe:
1. Allow TCP out port 22
2. Block all

I’ve tried unsuccessfully to reduce this to one rule:

  1. Block TCP out port 22 (exclude check box ticked)

I like to know whether or not the “Exclude” option only works when the Action is “Allow” or whether I’ve setup the rule incorrectly.

Thanks,
k6law

Hi k6law

Welcome to the Comodo Forums

Is the rule you have made working for you? Exclude has not been working in some cases. Let us know.

John

Hi John,

Thanks for your response.

Looks like the exclude option can’t be used with the “Block” action - at least for me.

I’ll have to stick with my two rules work-around.

k6law

If you are going to set up an EXCLUDE rule, the action is supposed to be BLOCK, and the nominated port is EXCLUDED from that action.

In this case, the action is BLOCK, the modifier is EXCLUDE and the port is 22.

This, in effect, only allows access outbound via port 22, to the exclusion of all other ports.

It’s a bit to get your head around, but once the penny drops, it’s quite logical. Just a different logic. :wink:

Cheers,
Ewen :slight_smile:

Hi Ewen,

What you described is exactly what I wanted to do - allow TCP outbound only to port 22 using a single rule with a BLOCK action and the EXCLUDE option checked.

But it didn’t work for me. I had to use the two rule approach instead - an “allow port 22 out” rule followed by a block all rule.

John indicated that the EXCLUDE option is not working in some cases which kind of supports my observation.

k6law