Enabling extensions in incognito mode.

Specific symptoms of the bug and steps you can take to reproduce it (step by step).
: Open new incognito window, click enable extension link (Screenshot1) takes you to enable/disable extensions outside of incognito mode (screenshot2).

Specific steps you have taken to try to resolve it.
: Workaround by typing dragon://extensions/ into the address bar takes you to the correct screen (Screenshot3).

Comodo Dragon Version
: Version 15.0.3.0 (Stable)

Plugins/Themes installed in Comodo Dragon
: Adblock Plus (Beta)

Windows version
: Windows 7 Home Premium (32-bit)

UAC status (disabled/enabled) if it applies to you
: Enabled

System Drive where Windows is installed
: “C” Drive

Place (installation path) where Comodo Dragon is installed
: Default location

User privileges
: Admin

If you have Google Chrome installed then please mention it’s version and whether the same issue reproduces with it.
: Not installed
Edit: Spelling correction.

[attachment deleted by admin]