Enabling Enhanced Protection Mode Sometimes causes BSOD on boot [V6][M602]

A. THE BUG/ISSUE Enhanced Protection Mode causing BSOD on boot
[ol]- Summary - Give a clear summary in the topic subject, NOT here.

  • Can U reproduce the problem & if so how reliably?:
    Yes, it happens at least every 2 boots, sometimes on every boot.
    As soon as I deactivate Enhanced Protection Mode, the machine boots perfectly fine.
  • If U can, exact steps to reproduce. If not, exactly what U did & what happened:
    a. I enabled Enhanced Protection Mode
    b. restarted the PC as told by Comodo Firewall
    c. Sometimes I get a BSOD and sometimes I don’t
  • If not obvious, what U expected to happen:
  • If a software compatibility problem have U tried the conflict FAQ?:
  • Any software except CIS/OS involved? If so - name, & exact version:
  • Any other information, eg your guess at the cause, how U tried to fix it etc:
    I had the exact same problem under version 5 of CIS. I reported that bug back then and it was fixed.
  • Always attach - Diagnostics file, Watch Activity process list, dump if freeze/crash. (If complex - CIS logs & config, screenshots, video, zipped program - not m’ware)

B. YOUR SETUP (Likely the same for each issue, so you can copy forward)
[ol]- Exact CIS version & configuration:
Comodo Firewall 6.2.285401.2860 / Proactive Security

  • Modules enabled & level. D+/HIPS, Autosandbox/BBlocker, Firewall, & AV:
    HIPS=safe, BBlocker=Untrusted, Firewall=Custom Ruleset, AV=not installed
  • Have U made any other changes to the default config? (egs here.):
  • Have U updated (without uninstall) from a CIS 5?:
    No. I uninstalled version 5 prior.
    [li] - :
    [/li]- Have U imported a config from a previous version of CIS:
    [li] - :
    [/li]- OS version, SP, 32/64 bit, UAC setting, account type, V.Machine used:
    Windows 7 x64 Pro SP1, UAC enabled (Standard level), Admin & User.
  • Other security/s’box software a) currently installed b) installed since OS:
    a= Avast Antivirus 8.0.1489 b= -

I attached a processes list, a windows dump file and a CIS report

Edit - Full dump file added:

[attachment deleted by admin]

I hope you don’t mind, but I modified your A2. The issue is that the bug reporting format now requires the steps to reproduce to be lettered. This is to help the devs to be more efficient in their handling of bugs.

Also, would it be possible for you to switch Windows into creating full dumps for BSOD? Then upload the dump file to a file sharing site, such as this one, and paste the download link into your first post. The reason I ask for this is that the devs have let me know that often it requires a full dump in order for them to locate and solve the issue. Thus, I now insist on full dumps whenever possible, to better help them and the end-users.

Thank you.

Fine by me, I didn’t realize it was that important.

As far as I remember, when I reported that very same bug in version 5, the devs were able to fix it with just a minidump.
Anyway, I can provide a full dump file, but tomorrow at the earliest.
So please don’t move this thread until then.

Thank you.

On the backend they’re working to improve efficiency. This is one of the requests they made, which should help them to be able to process bugs more quickly.

Often a MiniDump contains enough information, but sometimes it does not. Thus, in the interest of efficiency, and also to prevent the possibility that they will have to contact you later for more information, it actually saves everyone time if a full dump can be supplied.

No problem. Thank you very much.

I attached a link to a full dump file now.
I hope the file sharing site is ok, because I couldn’t get http://www.myupload.dk/ to work.

Thank you very much for your report in standard format, with all information supplied. The care you have taken is much appreciated by Comodo, and will increase the likelihood that this bug can be fixed.

Developers may or may not communicate with you in the forum or by PM/IM, depending on time availability and need. Because you have supplied complete information they may be able to replicate and fix the bug without doing so.

Many thanks again.

Not fixed with Update 6.3.294583.2937.

Thank you for checking.

I have updated the tracker.

What resolved the bug for me:

I updated Avast Free Antivirus a few days ago to version 2014.
Which brought some problems with it (Single file scanning triggering a full scan everytime and so forth).
Several reinstalls made it even worse, Avast simply refused to start at all on boot.

I then removed Avast entirely and, because I was without any Antivirus, installed the AV part of Comodo,
which I never did before.
Let’s say, I was positively surprised in several ways by it. :wink:

But now the important part:
I tried out activating the Enhanced Protection Mode and, you probably guessed it already, no BSOD on boot.
After about 10 boots without problems I’m pretty sure Avast was the problem in combination with Comodo.

I knew beforehand that installing several Security programs can cause trouble, but Comodo FW & Avast AV seem to be very popular as a firewall/antivirus bundle.

Anyway, I guess that puts this bug to rest.
I would suggest to include that little incompatibility in the FAQs
or somewhere else people can find it when encountering it.



Thank you for letting me know about this. I’ve now added this information to the tracker.

Although this is fixed for you I think I’ll leave it in the tracker for now. The reason is that you have provided enough information that the devs may be able to fix this conflict for other users.


No problem.

You’re right, thats probably the better way.

Too bad I can’t tell if the bug is still there once you get Avast 2014 to work correctly.
Because I’m actually not planning on going back from Comodo AV. :wink:

Thanks again for your help. :-TU

You’re welcome.

The devs have informed me that they believe that this is fixed for CIS version 7.0.313494.4115. I will therefore move this to Resolved.

If this is still not fixed for you please both respond to this topic and send me a PM (including a link to this bug report).

Thank you.