emule?

can somebody please show me a safe way to configure CIS4 so i can actually use emule? i used the old 6 rule guide for v3, & it seemed to work, but it pretty much blocks every connection. what am i doing wrong? this is what i have:

Rule 1

Action = Allow
Protocol = TCP
Direction = In
Description = Rule for incoming TCP connections
Source Address = Any
Destination Address = Any
Source port = A port range = (start port = 1025 / end port = 65535)
Destination port = your TCP port of emule (40000)

Rule 2

Action = Allow
Protocol = UDP
Direction = In
Description = Rule for incoming UDP connections
Source Address = Any
Destination Address = Any
Source port = A port range = (start port = 1025 / end port = 65535)
Destination port = your UDP port of emule b[/b]

Rule 3

Action = Allow
Protocol = TCP or UDP
Direction = Out
Description = Rule for outgoing TCP and UDP connections
Source Address = Any
Destination Address = Any
Source port = A port range = (start port = 1025 / end port = 65535)
Destination port = A port range = (start port = 1025 / end port = 65535)

Rule 4

Action = Allow
Protocol = ICMP
Direction = Out
Description = Ping the server (edk network)
Source Address = Any
Destination Address = Any
ICMP Details = ICMP Echo Request

Rule 5

Action = Ask (enable Log as a firewall event if this rule is fired)
Protocol = TCP
Direction = Out
Description = Rule for HTTP requests
Source Address = Any
Destination Address = Any
Source port = A port range = (start port = 1025 / end port = 65535)
Destination port = 80

Rule 6

Action = Block (enable Log as a firewall event if this rule is fired)
Protocol = IP
Direction = In/OUT
Description = Block and Log All Unmatching Requests
Source Address = Any
Destination Address = Any
IP Details = Any

  1. Start Emule. When Comodo asks you with a popup, choose Treat this application as select Emule and enable Remember my answer.

i will say after setting up this way, emule asked several times for permission to connect & when i tried to select “treat as emule” emule rule was NOT in the list, so i denied permission. really confusing… thanks for any help.

Rule 5 adds a rule with Ask. When you get a question you need to either allow or block it (don’t forget to let it remember your answer).

Did you open a port for incoming traffic for e Mule under Global Rules?

My advice? Don’t use eMule. From what I’ve heard all around the internet it spreads viruses.

Thanks Eric, not sure I understand exactly how I should open port under global rules. ??? I found this post:
https://forums.comodo.com/empty-t53677.0.html
but, am not sure how to implement. My global rules are quite different:

x block icmp out from ip any to ip where icmp message is protocol unreachable
x block icmp in from ip any to any where icmp message is 17.0
x block icmp in from ip any to any where icmp message is 15.0
x block icmp in from ip any to any where icmp message is 13.0
x block icmp in from ip any to any where icmp message is echo request

I’m not sure what to allow & what not to allow… sorry for the newbie questions.

sorry, i just dont get it. i am one of the domain of users that are not i.t. experts. i found this:
https://forums.comodo.com/empty-t53677.0.html
& tried to utilize it, but still no luck. maybe a little specific clarification of:

In most cases all they need would be to place new rules to allow inbound connection to emule TCP and UDP client ports before the "Block and Log IP In From IP Any to IP Any Where Protocol is Any" one
Disable Emule Randomize Ports option
dont see this option.
If you have connectivity problems: Go at Firewall -> Common Tasks -> Stealth ports wizard and select Alert me to incoming connections- stealth my ports on a per-case basis
i keep checking this box, but when i come back it has changed back to the first option. & it does block windows operating system as well as stated, not readily solvable for us non-i.t. folks again. if i could right-click & unblock, it might help, though, again, i'm not clear at all what is or is not safe to allow. thanks all.

I think there may be a problem when you use the E Mule application rule in conjunction with the “Alert me to incoming connections- stealth my ports on a per-case basis” approach.

Delete the current e Mule rule and start the program. When you get an alert don’t choose to use the e Mule policy you made but allow each action and let it remember the answers. Does that do the trick?