Emule port opening issue

Hi guyz, to put it simple, I’m trying to open ports so that my emule could work properly (I have that !%@? black mask on my mule icon)…I already opened my ports for UDP and TCP adding these 3 rules:

  • Allow TCP/UDP out: any/any/port range (1025-65535)/port range (1025-65535)
  • Allow UDP in: any/any/port range (1025-65535)/single port (32236)
  • Allow TCP in: any/any/port range (1025-65535)/single port (39022)

Emule still doesn’t work properly, the black mask is still there.
Is what I did sufficient to open all the ports I need? Do I need to do anything else? ???

Thanks for the help :-TU

You need to open the ports in Global Rules. Incoming traffic first goes through Global Rules (where you set generic rules to allow traffic in on UPD 32236 and TCP 39022) then it goes through Application Rules where it will find the rule you made for eMule.

In Global Rules you need to add two rules:
Allow UDP in from address Any to address (Any or more precisely defined to choice) from Port Any to Port 32236
Allow TCP in from address Any to address (Any or more precisely defined to choice) from Port Any to Port 39022

That should do the trick. Make sure the rules are somewhere above the basic block rule (at the bottom) as rules are read top-down.

Ok, I followed step by step the hints u gave me, but no result ??? the black mask is still there…
Is there any other cause which could bring to this?

Can you show me screenshots of your Global Rules and Application Rules?

Can you also check that eMule is opening the ports on your router (assuming it is set to automatically open and close them)?

Here’s my global rules section snapshot, hope it’s clear to read (sorry, my Comodo is in Italian by default).
How do I check if emule automatically opens/closes ports?

ps: “consenti” means “allow”, “in entrata” means “IN”, “in uscita” means “OUT”, the rest should be quite easy to understand. :wink:

[attachment deleted by admin]

If I recall correctly with default settings e Mule will automatically open ports using Universal Plug and Play (uPnP). It will report that in the log (Registro Eventi) as follows: “L’UPnP ha impostato con successo l’apertura delle porte 40000 (TCP) e 40000 (UDP)”

Please check the eMule options to see that uPnp is enabled. See image.

Other than that you need to check the manual of your router to see how to check.

ps: "consenti" means "allow", "in entrata" means "IN", "in uscita" means "OUT", the rest should be quite easy to understand. ;)
Your Global Rules seem fine but could do with a bit of cleaning up (but that is not important now).

If eMule says uPnp has opened the ports and you still get the masked mule symbol please change the application rule for eMule to Trusted. That way I know for sure we have a working rule.