emule low id (yes, again) [Resolved]

Before you start screeming bloody murder, yes, I read all the posts about configuring network monitor for emule.
I installed comodo 2.2.0.11 yesterday, all went well, looks great so far.
Just that small nag about the low id with emule :frowning:
I tried the settings for network monitoring as explained on this board. I even shut down the firewall and no effect.
Just for the test I completly removed it again and all was well again :wink:
I installed again, off course.

There is some setting I’m missing I guess, any help is welcome.

I assume you followed this guide.

Did you do the little MOST IMPORTANT thing at the end of the tutorial:

“You must move the rules up, over the default rule “Block IP in”. ( CPF “reads/applicates” the rules from the top to the bottom)”?

Hope it helps!

Indeed I did :wink:
But why is it when I shut down the firewall, I still get a low id?
An uninstall solves the problem, but that’s not what we want he.

You’ll have to wait for someone that knows more than me. My title lies, Comodo HATES me, to be honest. :wink:

Sorry I couldn’t be help you better.

When you shutdown CPF, it does not block anything. i.e. it allows all the traffic. If uninstallation solves, I think this may mean CPF is conflicting with another packet filtering software installed on your PC. What other security software do you have?

Egemen

I’m only using Avast anti-virus, and shuting it down doesn’t help.
And windows firewall is disabled, so that’s not it either.

check your application monitor rules.Maybe the problem is there

My settings there for emule are:

Remote: Any
Port: Any
Protocol: TCP/UDP In/Out
Permission: allow

I also skip the parent check and connections is unlimited.

I’m gonna sleep on it for a night :slight_smile:

Then depending upon the position of this rule within your rule list, you may as well not have a firewall - as you have set them up - this rule allows all TCP/UDP traffic on all ports from all IPs. Emule has specific ports for RX and tX and these are the only ports that need to be opened. Skipping the parent check isn’t recommended as well, as ANYTHING could be firing up an application to do whatever it wants.

Hope this helps,
Ewen :slight_smile:

You are right Ewen, but he tried to prove there that no matter what he does, eMule gives him a LowID and I’m still in the dark here. (:SAD)

What’s even stranger is that when he sets CPF to “Allow ALL” he still gets a low ID. I suspect there’s something else happening other than CPF choking traffic.

ewen :slight_smile:

Exactly. :slight_smile:

Guys the rule Fnx described is the rule for emule and is correct.
But it is strange emule have low id (if the network rules are properly configured)

Bullhorn is right, no matter what I do, I get a low id on emule. ???

My network rules are:
0: allow IP out from IP Any to IP Any where IPPROTO is Any
1: allow TCP In or Out from IP Any to IP Any where source port is 10105 and remote port is Any
2: allow UDP In or Out from IP Any to IP Any where source port is 17534 and remote port is Any
3: block&log Ip In from IP Any to IP Any where IPPROTO is Any

10105 and 17534 are the ports I set in emule and my router, they allways worked before.
I tried it with the default ports from emule to, but no go :frowning:

In the log I see port 10105 acces denied, why?? when I set it to allow??

I even removed my Avast anti-virus and installed Comodo’s anti-virus, but no that wasn’t it.

Before I had Sygate, I did remove before installing Comodo, but could there be something left that keeps blocking things?

–edit–

Just set the last rule in the network monitor to Allow and all is well.
But this sounds to me like a mistake, right? :slight_smile:

Change the ports on the rules. As seen at the guide https://forums.comodo.com/index.php/topic,411.0.html
you must use
Source port = Any
Remote port = the ports your Emule uses for the TCP and UDP connections

Ok, I should have my eyesight checked (:SHY)
I’m really sorry guys/girls.

UDP is still blocked, but it’s not really necessary for emule to work.

Applause for pandlouk (:CLP)

Now let’s see how CPF is going to perform (J)

UDP shouldn’t be blocked (well some fragmented packets will be because of a bug). Wait Until thursday that the new beta will be released. According to Melih it is fixed on that version.