Empty paths in firewall Application rule settings

A. THE BUG/ISSUE (Varies from issue to issue)
Can you reproduce the problem & if so how reliably?:
If you can, exact steps to reproduce. If not, exactly what you did & what happened:
One or two sentences explaining what actually happened:
Somehow entries in “Application rule” under Firewall settings, has no application assigned to it. Also the path is empty.
i have attached a screenshot of it

One or two sentences explaining what you expected to happen:
If a software compatibility problem have you tried the advice to make programs work with CIS?:
Any software except CIS/OS involved? If so - name, & exact version:
Any other information, eg your guess at the cause, how you tried to fix it etc:
Some uninstaller or registry cleaner may be removing comodo firewall entries in registry.

Exact CIS version & configuration:
Modules enabled & level. D+/HIPS, Autosandbox/BBlocker, Firewall, & AV:
HIPS disabled, Autosandbox Enabled, firewall Enabled (Custom Ruleset), AV Enabled
Have you made any other changes to the default config? (egs here.):
Have you updated (without uninstall) from CIS 5, 6 or 7?:

Have you imported a config from a previous version of CIS:

OS version, SP, 32/64 bit, UAC setting, account type, V.Machine used:
Windows 8.1 pro , 64 bit, UAC ( do not notify), Account type : administrator, V.Machine not used
Other security/s’box software a) currently installed b) installed since OS, including initial trial security software included with system:
a=malwarebytes antimalware 2, hitman pro b= SecureAPlus 3.4.3, Qihoo 360 Total security 6.6

[attachment deleted by admin]

It’s not empty paths but file groups rules with empty name.
And you can find groups in Advanced Settings - File Rating Settings - File Groups

i have not added any group in firewall application rules. these empty entries belong to applications that got uninstalled.

The empty entries are caused because of “iobit uninstaller” which tries to remove the invalid entries of uninstalled software in Comodo firewall settings.

original entries


iobit uninstaller found comodo registry entries and flagged it for deletion


comodo firewall registry entries deleted by iobit uninstaller causes empty entries


If that is the case then it seems to me like this is an issue with Iobit uninstaller and should be reported to them.

I think that this issue is fixed with version <>.

I will move this one to "Resolved section.