Emergency Help! Comodo Time Machine - Boot Sector issues

!!! After updating Time Machine due to the issues below, Windows 7 would not boot, stating the \boot\bcd file is missing. Several attempt to repair using the Windows 7 Cd failed. I attempted to fix the mbr using Ultimate Boot CD, but it only covers Vista. I tried again with the Windows 7 CD and it finally let me in but my system was set at the first Time Machine snap shot I took! I’m not sure of the sequence of events but it seems as if my current system state never existed, never installed. I couldn’t even get the event logs from UBCD because it seems as if nothing happened between 1/29 and 3/12.

Windows is also reporting that the version I have is not genuine! I’m still new to Windows 7, haven’t had time to dig deep yet (guess what? I will now!).

  1. What could have caused Time Machine to corrupt so easily?

  2. I can’t run Time Machine due to a critical system not functioning error (which I have received before).

  3. What steps can I take to get the development team the data it needs to help fix the problem? I need an answer as soon as possible

When Comodo warns me about a potential malware threat, I will never doubt it again. I don’t remember the file, but it was a common program I use. I didn’t think it would be an issue, but evidently something is not right:

  1. On the last round of updates, the computer booted, Comodo Time Machine reindexed, and then a black screen with the statement that one of my disks need to be checked for consistency. At this point, everything seemed normal except for the statement: Windows XP and greater run chkdsk from a blue background. Maybe it has changed with Windows 7.

  2. Once the count down was to 1 second, it did nothing. The HDD light pulsed, so some activity was taking place. What was disturbing is my wireless light was pulsing. I’ve turned wireless off for now.

  3. I let it sit all night and nothing happened. Time Machine does run, but it is always reindexing, only once was I able to get the Time Machine screen, and subsequently boot into Windows.

  4. I tried the Ultimate Boot CD, but it was an older build, and the boot up process halted because a file was corrupt. I have a current Boot CD built, so I’m going to try to get into the system. My goal is to hit the HKLM/Software/Microsoft/Run and see if I can’t stop the chkdsk or other application.

  5. I don’t remember the file that is stated was malware, but I’m sure I can check the list of files that were trusted. It might be in Files to Submit. Let me know if there is anything else I need to check here.

  6. Does Time Machine reset my mail file? At this point, that’s the only thing I would concern myself with. I haven’t had time to really play with Time Machine, but if I can get into it, I’ll reset to an earlier time.

  7. I’ll try to get the files submitted tonight if I can get in. If I can’t is there something I can send from the Comodo directory under Program Files?

  8. It might not be a virus, it could be a system issue, but I would like to make sure. Any ideas would be helpful.



This is more likely a CTM problem then a virus problem…

So moving it over to CTM board…

Is there any update to this thread? Is there anything else needed? I don’t have much in terms of evidence; I couldn’t get Process Monitor behind CTM, but I will be recreating the scenario in a virtual machine.


Hi Dino,

get the newest UBCD4Win with the latest TestDisk version. Connect your HDD to another machine via USB (external). Rewrite MBR and partition table if found correctly. Reconnect your harddisc to your computer and reboot.

See my post at Bug Reports - CTM, How to recover your drive, if CTM made it not boot…

Good luck,


I believe I read your post after posting my version of what happened. I was asking if there is more information needed to help out the CTM team. I didn’t know about TestDisk; I ran MbrFix which set it back to when I first had CTM installed. It’s okay, I needed a refresh anyway.

I’ll make note of your procedure and test it in a VM. I’m interested in how it happened in the first place. Has to do with how Vista and 7 use the BCD system.

BTW I miss Jeff Jaeger. :wink:



I will start testing on a VM (with 7) asap as well; it will be interesting to find out what CTM exactly does… May I ask what kind of VM software you are using?

Did you already test bootrec? The link to the ms article was prev. posted in here.

btw, I am sorry, I do not know about Jeff. Do you mind, using email?


Hi Jaeger,

I use Virtual Box as my primary VM. I find it to be easy to use and has a robust feature set. Virtual PC is good, and could be used as well, but I like VB’s footprint in memory.

I didn’t test the bootrec as I had no choice but to reinstall the OS. It was time for a refresh anyway. I’m going to start my testing this week.

Jeff Jaeger was a kicker for the Oakland Raiders for a long time. I forgot when he left. He was a true team player; when the game was on the line, he would make that kick.

I’ll PM you with my email, but lets make a point to post our findings in this thread.

Note to Moderators: Please keep this thread open for a month; jaeger and I are working on testing CTM in a virtual environment to get an idea as to why it failed on boot. I have an idea that it was one of my hard drive tools (scan disk equivalent) that caused it to fail. We’ll test that theory and post our findings back here.


Hi Dino / Jaeger,

Same did happen to me on my pc.
File: /Boot/Bcd
Status: 0xc000000f
It happened 3 days after installation of CTM 2.5. I did use BOOTREC /REBUILDBCD and it did solve my boot problem. But then the error did pop up again after 3 days. So again i used bootrec to repair it and i updated CTM to 2.6. That was 4 days ago. Till now the error did not occur again.

My other pc was updated to 2.6 much 1 day after installing CTM 2.5. That pc did never had the /Boot/Bcd problem. Maybe it’s related to CTM 2.5, but i’m not sure. I asked it on this forum, but the CTM guru’s never confirmed it.

Anyway, i hope the above is an useful addition to your tests.


I had a very similar if not exactly the same issue on my system last night.

I decided to uninstall CTM because I was too impatient to let it “reindex the data” during reboot. When I uninstalled it, I thought it might remove any snapshots. It only gave me the option to create another snapshot before uninstall or .
Anyway, so I did that and rebooted and suddenly it gets stuck during boot throwing endless sector errors.
When I tried booting from my HDD, it would only get as far as “Verifying DMI Pool Data”.

What I had to do was use the Windows 7 DVD and do Startup Repair.
After that I had to Active Disk Image to restore to 2 days ago.

On a side note, I had told CTM to only protect my C drive and leave my D, E and F drives alone.
After restoring I noticed that files and folders I deleted were back and that all my drives were protected.

By the way, where are the snapshots stored? I looked for an Application Data folder and under Program Files, did a search. Can’t find them.
I even Googled the user guide and searched the PDF.

I kept getting told my drive was running out of space when this was not actually the case.

I like this program, especially because it is free.
I do not mind that my Boot loader was corrupted or that the files are back - it gives me a challenge.
I just wanted to clarify that I am not a n00b trying to rant. :wink:


CTM saves data to the unused part of the disk…
Windows may report 20 gb free… There is where CTM info resides…
These is to protect the info…
If CTM is uninstalled it will start being overwriten with normal use

A program that uses unused disk space to store snapshots resulting in Windows reporting low disk space when it will not appear this way to an average user - in my opinion - is not the best way to go.
I have 3 HDDs and 2 partitions.
I would rather the snapshots be stored in a CTM Snapshots folder on a drive/folder that I specify.
Guillermo391, you say it is done this way to “protect the info”. In my opinion, it is not Comodo’s responsibility to protect my info - it is mine. I am very independent and responsible for anything and everything that takes place on my PC. :slight_smile:

Yes, but if stored within windows, it is possible for data to be infected by virut or other virus.
Since CTM was done to undo virus damage, it has to be protected more than normal files.
If windows cannot see CTM data, it would make harder for a virus to infect it.

I too have had the same problem and was only able to restore from backup image. The version I was using is the latest 2.6.138262.166, I hope some tech from Comodo can fix this problem as it’s not reliable/safe to use at the moment.

Yes, I understand all that.
My point is that this is the first program I have ever used that stores data in unused disk space, making it used.
However, the average user will have no idea of this and when he or she starts getting low disk space notifications, they will look at their drive properties and be totally lost.

You can put all the indicators and warnings in the ReadMe and Help files you want, but realistically, very few users look there. I know I didn’t.

I would love to use this, but cannot because of the above.
If Comodo wants to ensure that data is not infected with a virus, why not encrypt it?
CTM could require the user to create an encrypted file in a folder or drive of their specification - just like TrueCrypt.

Sure the snapshot data could get infected with a virus.
The HDD could also die in a week and it wouldn’t matter whether the snapshots were stored normally or in unused, would it?

As I stated previously, it is great that Comodo wants to ensure the security of my data, but that is my responsibility, not Comodo’s.

The bottom line is that it would great if the programmers gave users more options for how to and where to store snapshots.


I have to agree with Jeremy. It would be better if the user can deside where the snapshots are stored. It’s hard to accept “disk full” messeges if only 50% of your disk is effectivily used and the rest consumed by CTM. It would also be handy if a snapshot (especialy the baseline) could be exported to an other device/medium. This way it would be possible to export it and burn it on a couple of DVDs. Then there always is a safe and hopefully undamaged snapshot available.

Hi Marlon,
thanks a lot for this information. - If that was really a CTM problem, I wonder how the /rebuildBCD option could repair your system…
Did you do anything else with CTM after installing it - I mean, taking or restoring to snapshots, resetting the baseline, etc. ???
Guess, you have win7. - What kind of harddisk (ide, sata), which sata/raid drivers, mainboard type, proc. type (amd/intel) do you use, how many disks and more than one partition on a disk???
Just answer, if it does not take too much time for you.

Hi Klaus,

My pc is actually a Packard Bell netbook with Windows 7 starters ( :'() installed. I have 2 of them (one for me and one for my fiancé) and they are both the same model and have the same configuration and same software installed. I added CTM 2.5 after all software was installed (both netbooks are new). Then on 1 i updated to CTM 2.6. Next i opened my second netbook to upgrade it too, but then it already did not boot. That was the 1st time that this happened on that netbook. I used the boot console to go back to the baseline, but still the error was there. To bad CTM does not include the BCD file in the snapshots. It’s just a file so it should be possible to include it. To recover from this i used an usb key which i had made bootable. Unfortunately do Packard Bell netbooks not come with a windows setup cd, so i downloaded a windows 7 trail iso from microsoft site. I put all files and folders from that iso image on my usb key and luckily i was able to boot from it and enter the windows recovery command line. The only command i entered there was BOOTREC /REBUILDBCD. Then i tried to reboot and the netbook did start again. That was all i did. But then again 3 days after the repair i got the same error. I again did use bootrec to repair my BCD and directly after that i upgraded CTM to 2.6 hoping that it was a 2.5 issue. But not, 4 days later the message did pop up again. So again i repaired it. That was 5 days ago. Till now it did not occur again. To be honest, i have no idea what’s inside the netbook. I never did open it because it still has warranty, but i will try to answer your questions as far as i can.

  • resetting the baseline: Nope, i never did. CTM got installed on both netbooks on March 9 meaning the baseline is still fresh. Also did i never try to uninstall or reinstall CTM.
  • win 7: Yup, but the starters edition
  • harddisk ide or sata: I really have no idea
  • sata/raid drivers: Have to leave this one blank too
  • mainboard: …
  • proc: intel N270
  • nr of disks: one of 260Gbytes
  • partitions: all together there are 3 partitions. 2 are hidden and CTM does not monitor them. It only monitors the main partition (C drive).
    No important data is stored on both netbooks. If i need to store important data, then i store it on my desktop (CTM is not used on that one).

Sorry i can’t tell you much about what’s inside the netbooks. But at least i hope i could help a little.


In response to jeremy of many:

[quote]My point is that this is the first program I have ever used that stores data in unused disk space, making it used.
However, the average user will have no idea of this and when he or she starts getting low disk space notifications, they will look at their drive properties and be totally lost."

First of all, the system requirements for an application would be the first place a user should look before using the software.

System Requirements:
[tr][td]Free disk space:[/td][td]4 GB (minimum) / 10 GB (recommended)[/td][/tr]
I don’t know of any machine that doesn’t have at least 10GB of free space. If you are getting to that point, might be time to invest in an external hard drive and move some data there.

Second, while a choice to put the snapshots would be liberating, it would allow uneducated users to decide to put them in the root of C. Even worse, they would put them in a My Documents folder which adds the complexity of path (C:\users\user\documents) or (C:\Documents and Settings\user\documents). I don’t see how letting a user choose where to put the snapshots would be of any real use. What purpose would knowing where they are at?

As for the issue of the MBR being ruined, that can happen with or with out CTM. In version 2.6, they fixed that issue, or so it seems. I’m going to test the CTM in a Virtual Box Win 7, Win Vista, and Win XP environment. I’ll post what I find in a new topic.

Keyword - should.
I’m stating the painfully obvious here but not everyone reads that. I do, but others surely do not.
I have a 500GB and 2x160GBs.
My point is that those numbers become meaningless if the application stores snapshots in unused disk space that is not reported by Windows. Windows told me I had 50GB free on my storage drive, yet when I went to copy 50MB from another drive, I received a low disk space warning.

Awareness. Control. The principle of the matter. It is the same as downloading torrents and not knowing where the downloaded files are once you’re finished downloading them.

I am fully aware that any/all of my drives can fail at any time. That is not the point. My point was that uninstalling CTM caused it to happen. Fortunately, I had another backup with another program prior to testing out CTM.

I may use this program someday. For now I’ll make due with other means of backup.

jeremyofmany, the user can’t choose where to put the snapshots as they are allocated into the free space of the drive. To free up space, delete files or remove old snapshots. Also defragment the snapshots. Am I understanding wrongly what you’re posting? ???

Also, CTM is NOT a backup tool, but a system restore one.