Email Scanner doesn't works

I’m using OL2003 configured with following ports:

POP3 995 SSL

and Comodo Antivirus Email scanner seems to be inactive. The cause is because I’m using encrypted protocols or there are any other reason ?

thanks in advance
regards Davide

Even though I use Thunderbird, I use the same ports and anti-virus seems to be inactive for me also.


There is a known problem with CAVS’ proxy server hooking in with Outlook (I use 2003 at work). They are analyzing logfiles for it. (MS says no email scanning is necessary, especially for Outlook, since it blocks all attachments anyway, as long as there is a resident on-access scanner; but that’s just MS…)


I use CAVS & Tbird at home, but not on those ports…
For the “obvious” question - do you have email scanning turned on in CAVS, under Settings?
Do you have it set to show icons/progress, and to certify emails?
When you say it seems to be inactive, what are you basing that on?
When you’re downloading email, can you open Task Manager and watch for cavemlsvr.exe?
What firewall are you using? Is CAVS allowed by the firewall (specifically, cavemlsvr.exe)?


I have set to show icons/progress and mass mailer ,but not to certify emails.
I’m using Comodo Personal Firewall.
I don’t see progress bar or icon or mass mailer popup windows.


Okay, thanks for the info.

Do this next:

Open Task Manager, then open TB and retrieve your mail. While TB is downloading, check TaskMgr for CavEmlSvr.exe. Let me know if it’s there, and what amount of the CPU it’s using.


the process CavEmlSvr.exe doesn’t run. See the attached file for details.

regards Davide

[attachment deleted by admin]

Okay, thanks, Davide ~

So you’re using one of the recent Betas ( The most current one,, has an upgraded version of CavEmlSvr.exe.

I see two options for you at this point:

  1. Submit a ticket to Support here: They may provide you with a new .exe to improve functionality and logging for further diagnosis/resolution.

  2. Since you’re already using a Beta, download the most recent from the Beta section here in the forums.

In your position, I would probably try Option 1 first, just to see what Support says. If that doesn’t resolve it, then try Option 2.

One thing you might do, just for diagnostic purposes prior to submitting a ticket to Support, is go to your Comodo folder (probably C:\Program Files\Comodo\ComodoAntiVirus), and manually run the CavEmlSvr.exe (little envelope icon) by double-clicking it. Then open TB and see if you get any results.

At any rate, keep us posted on your results…


I had Thunderbird 2 configured to download my googlemail. CAVS would not scan the emails as ports 995 and 587 are used for this mail.
Strangely though when I added a second email account that uses ports 110 and 25 CAVS now scans emails from both email accounts. CPF asked dozens of time if I wanted to allow CavEMSrv access at first: then I rebooted and everything is fine now, even down to my googlemail being scanned. Strange as I thought CAVS only scanned mail using ports 110 and 25???


How do you know it’s scanning the emails on the other ports? Are you using the “certify” feature and getting the verification that way?

I’m using TB and have three emails accounts coming here. One is standard ports, the other two are SSL. CAVS still scans the 25/110 but not the others; the icon appears and disappears accordingly. I did go through the thing about CFP asking to allow, etc, and have rebooted numerous times, but still no change in CAVS’ scanning. Only the 25/110 account being scanned…

If yours is working otherwise, I’d like to be able to duplicate that… :wink:


The only indication of it working is the scanning indicators and the certification that suddenly appeared on my google emails. I only installed TB2 last night and as I said, it initially would not scan my googlemail. Then I added a second account (btinternet) that uses ports 110 and 25 and after many questions about allowing CavEMSrv from CPF I decided to reboot. When I rebooted the next lot of emails I received on my googlemail had the certification on them. Odd!

I have now set up another googlemail account with TB2 on my second pc and CAVS will not scan emails on this one. Very odd - I will have to have a look at the first pc when I get home from work tonight.


Wow Anderow.
As Im also using gmail I would really appreciate if you share your secret about how can we make cavs work with it:)
AFAIK, curent version of CAVS does not support ports other than 110/25. Sad…

Just tried it again. I sent an email from my googlemail account using Thunderbird to my BT email account. The scan indicator appeared and the email arrived with both outbound and inbound certification. Very strange as I can’t get it to work on my other pc where there is only a googlemail account set up in Thunderbird.Weird!

The received message source says (i have put ‘removed’ where id details were):
From - Wed May 23 22:15:57 2007
X-Account-Key: account2
X-Mozilla-Status: 0001
X-Mozilla-Status2: 10000000
X-Apparently-To: [Removed} Wed, 23 May 2007 21:15:36 +0000
X-Originating-IP: [Removed]
Authentication-Results:; domainkeys=neutral (no sig)
Received: [Removed]
by with SMTP; Wed, 23 May 2007 21:15:36 +0000
Received: (qmail 31905 invoked from network); 23 May 2007 21:15:36 -0000
Received: from unknown (HELO ? (Removed )
by with SMTP; 23 May 2007 21:15:36 -0000
X-YMail-OSG: sXucwhgVM1kJYk8l9Q3yrEvdPgsRB3AbL5uoRo8INt9QcMhsMSjXFGA6IWv0lvHvRFOR2S_vFs1bQX_BI3Mx8V8-
Date: Wed, 23 May 2007 22:15:35 +0100
From: [Removed]>
User-Agent: Thunderbird (Windows/20070326)
MIME-Version: 1.0
To: Removed <[Removed>
Subject: Test
Content-Type: multipart/mixed;
Content-Transfer-Encoding: 7bit

This is a multi-part message in MIME format.
Content-Type: text/plain; charset=ISO-8859-1; format=flowed
Comodo AntiVirus : Outbound message clean.
Scan Date: Wed, 23 May 2007 22:15:36
Virus Definition Update: Wed, 23 May 2007
Copyright © 2006 COMODO ®. All rights reserved.
Content-Type: text/plain;
Content-Transfer-Encoding: 7bit

Comodo AntiVirus : Inbound message clean.
Scan Date: Wed, 23 May 2007 22:15:57
Virus Definition Update: Wed, 23 May 2007
Copyright © 2006 COMODO ®. All rights reserved.

I have sent an email from my googlemail account to my work email address (exchange server on outlook). It will be interesting to see tomorrow if the email arrives with Comodo outbound authentication.


Just got the email I sent from my googlemail account last night and it has the Comodo outbound certification attached. This is odd. It must be something to do with the other email account I have set up in Thunderbird. Could CAVS have certified the googlemail email without actually scanning it for malware?

Why would the Comodo certification be on an email sent from a googlemail account if CavEmSrv.exe can not scan email sent using ports other that 110/25?? I hope someone can shed some light on this as I can’t figure it out - my settings for Thunderbird are standard and the same for CAVS.


From the transcript it looks as though your “Googlemail” is actually being sent using your Yahoo SMTP server which uses the standard port 25

In Thunderbird, open account settings, click on the name of the account and at the bottom on the right is a drop-down list of SMTP servers… my guess is you’ll see that your Googlemail account has the Yahoo! SMTP server selected???

What do you see?

Just to update this thread… CAVS, at present, only works with standard ports 25, 100; all non-standard or SSL ports are not supported.

Sorry about that; it’s impacted me now as well, as my ISP has gone to SSL for their email service.


@Little Mac
Do you think, this problem will be fixed in the 2.0 final?

I don’t really have any input on that, unfortunately. I hope it will be addressed, but I have not heard anything from the dev team on it. All the buzz is about the FW at the moment.

I can tell you what I do know… There is a new scan engine for CAVS; Melih has indicated it’s a real piece of work, very innovative. I also know that Comodo is very good about listening to their users, reading the forums, and making changes as necessary. I have a high degree of confidence that they will be looking at this issue (along with the others).


Edit: Check this thread:;msg72654#msg72654

OpusDei notes he can’t use CAVS because of incompatibility w/gmail (in a discussion about the inability to use CSE w/gmail). Comodo staff notes that both products have the same problem, and it will be fixed in both very soon.