Hi, all.

I recently learned that Elsword, a game I would otherwise play standalone, is now on Steam. However, I am having all sorts of problems trying to launch it.

Initially, I set the launcher up to link my accounts (my Kill3rCombo (North American publisher) to my Steam accounts). That goes without incident.

Then I try to launch the game, but it quits out without any manner of messages, whether in Comodo’s (other than the other events when it notices that it’s something it doesn’t know about, then sandboxes it; I later whitelist it so I don’t get this message ever again, and to make sure it has total access to the entire system). I’ve gone so far as to whitelist the entire install tree as “safe” in Comodo’s “rate files” menu as well as allow unfettered access to the Internet to all executables in the install tree. This holds especially true for X2.exe, which is XTrap, this game’s anti-cheating and -cracking (I hate the term “hacking” being used to indicate a person with less-than-charitable purposes) technology.

Before I go into my troubleshooting methodology, this assumes the following:

  1. Windows 7 + SP1 64-bit (I don’t think the edition matters)
  2. Comodo Internet Security, set for “Internet Security” configuration
  3. Successfully-linked Kill3rCombo and Steam accounts
  4. Steam-installed (not standalone) Elsword game
  5. Everything whitelisted in the appropriate parts of Comodo at a most basic level.

I go to troubleshoot and find the following:

  1. Comodo + Steam-launched Elsword = No joy.
  2. Comodo + manual launch of elssteam.exe (launched by Steam, presumably) = No joy.
  3. Comodo + manual launch of elsword.exe (in same directory as essteam.exe) = Works, but requires a manual login using my Kill3rCombo account.
  4. No Comodo + Steam-launched Elsword = Works but doesn’t require a login like above due to the account link described further above.

I suspect Comodo is attacking the Steam link to start the game so as to not require a login prompt; I just don’t know what communication it’s seeing that it ends up stopping. Any ideas?



Hi IJ, welcome to the forums.

Might this be relevant to your issue?

[url=http://steamcommunity.com/app/237310/discussions/0/864974467472228916/]Launching Elsword - How I fixed it[/url] [steamcommunity.com]

Hi, though I actually hate web forums in general.

Might this be relevant to your issue?
[url=http://steamcommunity.com/app/237310/discussions/0/864974467472228916/]Launching Elsword - How I fixed it[/url] [steamcommunity.com]</blockquote>

I just tested this by uninstalling IE10 and attempting to launch the game via Steam while Comodo was installed. It is not relevant. I was able to make the account connection successfully with IE 10 installed and it launched just fine via Steam, as long as Comodo is not installed.

I have to outright uninstall Comodo to make the Steam link work. Whitelisting the install tree in File Rating and giving full access to the Internet to the executables do not help. Even if I disable all security features, it will not work. The only way to launch the game is to launch the elsword.exe binary directly, but that requires me to log in with my Kill3rCombo credentials, defeating the purpose of having it in Steam to begin with.

The finger needs to be pointed somewhere. Unlike someone I was talking with on the Elsword forums at the publisher’s site, I am unwilling to point fingers just yet, except to Comodo to say something else is afoot because it is still part of the problem, even if just an indicator that a problem actually exists. Likewise, I am also far more willing to do more comprehensive testing than this individual is because the issue may not be fixable via normal, user-handled means.




UPDATE: There’s a maintenance event underway right now, so we might know if anything’s changed a bit later.


[s]As of right now, the X-Trap program (x2.exe), the anti-cheat framework that the game uses to enforce fair play, now seems to think that Comodo Internet Security is a cheating facilitating program. The game outright refuses to start if Comodo is installed. Even when I activate the firewall-only configuration and disable HIPS, no dice.

In fact, I get this when I try to fire the game up:

A monitor program has been found running in your system. Please, unload it from memory and restart your program. (Process Monitor ETC.)

Basically, that would mean uninstalling Comodo completely.

I have opened a ticket with the game vendor to explain what I’m seeing, but at the same time, it would be nice to see what could be done on this side of the equation as well.[/s]


UPDATE: I had actually run System Internals’ Process Monitor earlier that session but didn’t realize there was any residual code still in memory. A reboot with Comodo installed and an attempt to launch did not yield this error. Comodo was NOT a problem this time; the software did its job correctly.

However, the problem still remains after an update that was released today. I cannot launch the game via Steam, likely due to IPC (interprocess communications) between ELSSTEAM.EXE and ELSWORD.EXE.

UPDATE 2: I have notified Kill3rCombo, the publisher here in North America, of my findings and they will investigate the issue.


UPDATE 3: I tried the AV and FW by themselves, and both install Defense+. The game fails to run via Steam.

Unfortunately, until the real problem is identified, the only solution to get this program running is to uninstall any Comodo security product and use something else.

UPDATE 4: The latest update that came down by way of Steam (likely for the Steam launcher; the game itself never had any trouble) allows the game to launch with a fully-default Comodo Internet Security install with factory-default settings for the Internet Security profile loaded.

Going back to Comodo to get my groove back!

Thanks for putting up with any of my (few) updates!


Turns out that the 11/06/2013 update DOES allow it to start under 32-bit Windows, I’m still having trouble under 64-bit Windows. I haven’t fully checked things out and I need sleep more than I need games. Will check things out more in the morning.


Tried with my 64-bit Windows 7 laptop with most of the core functionality of CIS completely disabled; the game wouldn’t run. Tried on my 32-bit Windows 7 netbook with only the four necessary files which do the probing and/or communicating with the Internet whitelisted; everything else was set to factory defaults. It works just fine, albeit v-e-r-y s-l-o-w-l-y because netbook; even went so far as to log into my account and pull stats down on my only character, a level 17 Aisha.

These “anti-cheat” programs do some pretty severe probing. It even thinks such programs as SysInternals’ ProcExplorer as “cheating-enabling” software. In the past, I could outright disable Defense+ and the program would work. This does not seem to be the case anymore; I can turn off a lot of monitoring, but not the software which implements that monitoring itself without outright uninstalling the Comodo software.