Duplicate entries in Trusted Files List [V6][M213]

Not sure where to post this…I may a found a bug in the Trusted Files List.

I found duplicate file names listed in Trusted Files. These files are the ones that Comodo already trust. Thiis has happened on several programs that I updated to new versions. I did verify that the file names were the same and in the same folder. Purge does not remove them since the names are valid. The only way to fix this was to remove all entries to the program and have Comodo put the entry back. This causes Comodo to only list the entry once. I assume this is caused by the different version numbers. It would be nice to have it remove older version entries.

I think it would be nice to have search feeture to be able to search for duplicate entries. Thanks.

This looks like a V5 bug back again.

I’d very much appreciate it if you would make a report in standard format (please see the stickies), so we can nail this one.

Particularly critical to work out which files (& versions) the duplicates referred to if you can.

Best wishes


Multiple entries for the same file names listed In Trusted Files.

A. The bug/issue: Multiple entries for the same file names listed in Trusted Files.

  1. What you did: I clicked on the program’s icon on the desktop ex. UltraDefrag and TBIview
  2. What actually happened or you actually saw: Program’s file name listed more than once in Trusted Files l
  3. What you expected to happen or see: File name only listed once
  4. How you tried to fix it & what happened: I deleted all entries of the file name and ran the program again. This time the program is only listed once.
  5. If its a software compatibility problem have you tried the compatibility fixes (link in format)?: NA
  6. Details & exact version of any software (execpt CIS) involved (with download link unless malware): UltraDefrag - prev 5.1.1/new 5.1.1 TBIview - prev 4.30/new 4.31
  7. Whether you can make the problem happen again, and if so exact steps to make it happen: Could not make it happen again since I deleted all entries and CIS only puts the entries back once.
  8. Any other information (eg your guess regarding the cause, with reasons):
    I am assuming that it still list the old version as well as the new version. Since the file name are the same, Purge reports the names as valid. I don’t believe this problem is limited to UltraDefra and TBIview. These were the ones I saw listed more than once.

B. Files appended. (Please zip unless screenshots).
0. A diagnostics report file (Click ‘?’ in top right of main GUI) Required for all issues):

  1. Screenshots of the 6.0 Killswitch Process Tab (see Advanced tasks ~ Watch Activity) or 5.x Active process list. If accessible, required for all issues: NONE
  2. Screenshots illustrating the bug: No screenshot captured
  3. Screenshots of related CIS event logs:
  4. A CIS config report or file.
  5. Crash or freeze dump file:
  6. Screenshot of More~About page. Can be used instead of typed product and AV database version.

C. Your set-up

  1. CIS version, AV database version & configuration used: 6.0, AV not installed, Proactive - FW custom/D+ safe
  2. a) Have you updated (without uninstall) from from a previous version of CIS: No - I uninstalled prev version first
    b) if so, have you tried a clean reinstall (without losing settings - if not please do)?: Did a clean install
  3. a) Have you imported a config from a previous version of CIS: No
    b) if so, have U tried a standard config (without losing settings - if not please do)?: I used the Proactive config, exported it and imported that back under a different name. I have the new name set as active. I did this so that I will always have a default Proactive that I can fall back on, if necessary.
  4. Have you made any other major changes to the default config? (eg ticked ‘block all unknown requests’, other egs here.): HIPS - safe/FW - Custom/AV - not installed; I enabled all 5 boxes in FW advanced section. I
  5. Defense+/HIPS, Autosandbox/BBlocker, Firewall & AV security levels: D+/HIPS= , ASB/BB= , Firewall = , AV =
  6. OS version, service pack, number of bits, UAC setting, & account type: Vista SP 2 32bit, UAC on default. Admin account
  7. Other security and utility software currently installed: Avast AV Free 7/TrueCrypt 7.1a/UltraDefrag 5.1.2 MBAM Pro 1.70; Not sure what other programs fall in this Category
  8. Other security software previously installed at any time since Windows was last installed: AVast AV Free 7 TrueCrypt 7.1a MBAM Pro 1.70
  9. Virtual machine used (Please do NOT use Virtual box): NONE

I hope I gave all the info needed. I was unable to provide any files or screenshots…Sorry.

I set the color to blue but it would not show up in blue

To get that you need to copy and paste the strange SMF code from the Blue version of the format :slight_smile:

But thanks very much for doing this much appreciated


Thank you very much for your report in standard format, with all information supplied. The care you have taken is much appreciated by Comodo, and will increase the likelihood that this bug can be fixed.

Developers may or may or may not communicate with you in the forum or by PM/IM, depending on time availability and need. Because you have supplied complete information they may be able to replicate and fix the bug without doing so.

Many thanks again


Please, pretty please, fix this one. It’s a big PITA for those of us who like to keep things (i.e. TFL) clean.

Can you please check and see if this is fixed with the newest version? Please let us know whether it is fixed or you are still experiencing the problem.

Thank you.

PM sent.

Can you please check and see if this is fixed with the newest version (6.2.282872.2847)? Please let us know whether it is fixed or you are still experiencing the problem.

Thank you.

PM sent.

Can you please check and see if this is fixed with the newest version (6.3.294583.2937)? Please let us know whether it is fixed or you are still experiencing the problem.

Thank you.

PM sent.

I believe the bug is foxed. I will need to wait until I update a program in the list. Maybe someone can check to see if the bug is present on their system. Thanks.

Once you have checked this please let me know if it is indeed fixed. If so I’ll move this to Resolved at that time.

Thank you.

The devs have informed me that they believe that this is fixed for CIS version 7.0.313494.4115. I will therefore move this to Resolved.

If this is still not fixed for you please both respond to this topic and send me a PM (including a link to this bug report).

Thank you.