Due to Defense+ Malwarebytes stuck at start-up/opening

I got a problem starting/opening Malwarebytes(freeware). I used it before installing comodo and it worked fine, and still does only if I disable defense+. All the updates and scans of malwarebytes work fine. Only when its opened with Defense+ enabled in any mode (training/safe…) except installation and disabled.

I have made the Malwarebytes under custom rules and policies to be allowed and trusted by comodo defence+, but it still get stuck. In the task manager it shows mbam stuck with 72kb process.

The comodo events show that Malwarebytes as terminate process by explorer.exe (no idea how) ???.

So once its stuck, when I disable defense+ and ended the task of Mbam.exe (at exactly 72kb), the UAC pops up and all works fine.

Any suggestions how to fix this please? cuz its irritating to keep disabling the defense+ (plus having to surf the web with defense+ disabled).
(I have tried uninstalling malwarebytes completely with the mbam-cleaner but the result is the same at the end)

Problem solved,
All I did was install the latest version. :slight_smile: