DSL Internet Connection Drops

Hello to the Comodo Team,

I have just switched to Comodo Internet Security Suite and am quite impressed with how much it does while not taking up a lot of space or hogging the system. I am having a little problem though with the Internet connection.
I am running Windows XP Home Edition with service pack 3 and my Internet connection is DSL through AT&T. The connection keeps dropping several times a day and I have not been able to find a solution. I have checked extensively throughout the Comodo forums and have not been able to find anything on this. There are quite a few entries on not being able to connect at all, but that is not my problem. When the connection fails, I have to reset the DSL modem (Turn off and back on again) and the connection becomes active again. I have been running Mcafee Internet Suite for several years and have never had any connection problems or with accessing the Internet.
I did a complete un-install of Mcafee and even downloaded their product cleanup program (MCPR.exe) to get rid of all traces of the Mcafee products prior to installing Comodo Internet Suite, so there should be nothing there to conflict with Comodo.
Is there settings that I should change somewhere in the firewall or D+? I have gone through all options within firewall and D+ and do not see any problems, but I’m not even good enough to be a novice to really know what I am looking at. I did make two changes, but those changes made no difference in trying to fix the problem.

Those changes were:

  1. Under Firewall Behavior Settings - Alert Settings
    I unchecked the box ‘This computer is an Internet connection gateway’, as this is the only computer I have and is not on any network.
  2. Under Image Execution Control Settings
    I moved the control level to ‘Normal’. It was set on ‘Disable’. The help text indicated that this should be the default anyway.
I have heard so many good things about Comodo and, as I say, am quite impressed by your work. If anyone can help with this little annoyance, I would be extremely grateful.  Hope it's not too technical.  I know as much about this as I do about Einstein's theory of Relativity.

To all the Comodo Team, great work. Keep on truckin’.

Thanks for any help anyone can provide.


Can you post a screenshot of the Firewall logs? They can be found under Firewall → Common Tasks → View Firewall alerts.

When the thing happens again let Windows repair the connection. Does that help?

Thanks for quick response EricJH,

View Firewall Alerts Show nothing (No Items to Show)

If I let windows try a Repair, it comes back with Cannot Repair.

So I have to Reboot the DSL Modem and then the connection comes back

Thanks, Chuck

I am no sure why CIS is not showing any logs. It could be either CIS being messed up or there are still some remnants of McAfee around.

Try running Diagnostics under Miscellaneous in CIS. Does that help?

To check for McAfee leftovers download and run Autoruns. Thsi tool find almost if not all autostarts in Windows After starting Autoruns go to Options and let it hide Microsoft and Windows entries and push F5 to refresh.

Now browse through the list and see if any McAfee entries are there poiting to existing files. When you find them disable them by unticking. When done reboot the system and see what happens

Okay EricJH,
just completed your suggestions.
Ran diagnostics and it showed up clean (no problems detected)
Downloaded Autoruns and found no Mcafee entries at all.

Not giving you too many clues am I ??

Thanks again for your help. If you need screenshots or the autoruns listing, let me know.
I think I can figure out how to include screenshots but not sure how to get the listing to you.


Try this, it automatically fixes many networks connection problems


Try running Diagnostics under Miscellaneous. What does it say?

Can you show a screenshot of the Global Rules? THey can be found under Firewall → Advanced → Network Security Policy.

Do you have other security programs running in the background? Try disabling them.

Diagnostics show no problems
screenshot of Global Rules should be attatched
I have no other security software running at all

Prior to installing CIS, I had Mcafee Internet Security Suite and PC Tools Spyware Doctor

have since removed Mcafee completely and disabled spyware doctor prior to installing CIS

No other security software is on the system

Hope you can read the screenshot

Thanks so much,


Here is a better image of the Global Rules

Hope this helps…
One thing I noticed which may help in determining a solution…
As long as I have the browser open (Firefox in this case), the network connection stays up.

Only when no browser is active, that’s when the connection seems to have a problem.

Thanks again.

AT&T DSL internet connection keeps dropping?

Maybe the likes of Connection Keep Alive (require .NET 2.0) or KeepAlive 1.4 could help.

Thanks Endymion,
I’ll check it out… Does it work on standard connections?.. I do not have a wireless connection
as stated in the writeup on Download.com


It depends on the reason behind the dropouts.

In case the connection is severed after a period of inactivity those apps generate some activity automatically and thus could disable this kind of ISP practices.
Many of these apps may rely on pings (ICMP packets) whereas it is possible that using http connection would be necessary to workaround the issue.

If the dropouts are due to some ADSL signal issue (eg “DSL signal blinks green every time my connection drops” in the yahoo answers page) it could also be some landline issues whereas the signal quality can worsen up to the point the connection is lost.

Since you confirmed that keeping your browser opened apparently workaround the dopouts maye a keepalive app could work (if the ping based do not maybe the one that use HTTP will).

Some router/modems have a connection timeout (Connection on demand) that could cause those issues or Keepalive options to prevent this as well though not all brands/models have this feature.

Connection Timers: If the Connect on Demand timer is used, set the value to at least 15 minutes, preferably 30 minutes or higher. If using the Keep Alive timer to maintain the connection 24/7, set the value to 180 seconds. If the Keep Alive timer is set low, for example 30, the router can cause a login failure or even a hung PPPoE session. At this point, remove power from the router and modem, wait five minutes, then restore power to the modem. Wait for sync then restore power to the router. If still unable to connect, call the Fastaccess helpdesk and ask them to reset your line.

Thanks again Endymion,

Thanks for all the info. I’ll read through the link you gave me on dslreports.com.

I looked into my DSL modem and there is a timeout option but it is set to ‘Never’.

Not sure why it would be dropping now with CIS. Maybe Mcafee’s Internet Security Suite that
I was using had a feature that would keep the line active even though I wasn’t using the connection.
Never had a reason to look into it as I never had this problem.

Thanks again for the information.

You’re welcome Chuk.

If your router has a e Keep Alive timer maybe the dslreport indication could be of help.

Indeed it looks Mcafee integrated such keepalive functions.

The StayOn Pro utility is now available in the update mechanism of McAfee Software products. This small utility resides in the software and keeps customers online by periodically retrieving information over their connection. Users can now download critical software updates with a continuous online connection. Since computers disconnect based on a flat rate of inactivity, StayOn Pro actively surfs the Internet to keep the connection "live".

Although some DSL reliability issues could also a possible cause whenever the timing was coincidentally overlapping to CIS installation.

Hi chuckm60090,

There are few things to check. My apology if some of that was mentioned here or may sound obvious.

1) Check whether Windows Firewall (WF) is not active.
Microsoft has a bad habit to set it back “On” and unfortunately Comodo doesn’t notify you about it except during the first Setup.
In addition to disabling WF you can disable Windows Firewall/Internet Connection Sharing (ICS) if you are not using it. That will keep WF dead for sure.

2) in the Device Manager set “Show hidden devices” and check whether there are any conflicts in network devices.
In Non-Plug & Play Drivers check if there are McAfee drivers / devices leftovers (probably you did that already). Sure uninstall if any were found.

3) Even if you are not using Internet Explorer, in Internet Options > Connection Tab > LAN Settings… check if you have proxy set. You may be surprised that even if you never set it and “Use proxy” is unchecked there could be some weird settings greyed out. If so – Check Use proxy; clean up those boxes and then uncheck “Use proxy” back.

4) What do you have in Comodo > Firewall > My Network Zones ?
(you may post that image as well)
Sometimes if you ever had any computer networked or you made some changes in your modem/router you may find out spare zone there and Comodo will never tell you about it. That can create some conflicts too. You should remove unneeded Zone.

Finally, in order to eliminate that Comodo is a culprit it never hurts testing whether your dropouts will be cured performing some tests like:
disable Comodo Firewall completely (startup/ driver). Reboot in Normal Mode (you may or may not enable WF temporarily);
Test the same in Safe Mode with Networking

The last two experiments may not give you the answer straight away but at least you will know whether it’s Comodo to blame or you have to look deeper into other system settings.

My regards

Thanks SiberLynx and Endymion for all the info and suggestions.

you’ve given me a lot to digest and tryout. Thanks so much


Thank you very much Comodo members.

SiberLinx: I went through all you suggestions and everything is clean and normal.

Endymion: I downloaded ‘Connection Keep Alive’ from NGcoder.com and it appears to be working great.
Thank you for the suggestion and the link.

EricJH and jay2007tech: Thanks so much for your input and help.

‘Connection Keep Alive’ so far is working great. I like keeping the connection up even though I am not on the Internet because any updates will be able to come in. Not only for Comodo, but all Microsoft and Windows security updates and any other updates for any other software I have on the system.

I do have one more question about CIS. Nothing is being posted to the firewall log. When I look in
‘View Firewall Events’, it is empty.

I was looking at the ‘Application Rules’ and the ‘Global Rules’ and I see that the box for ‘Log as Firewall Event if this rule is fired’, is unchecked for every rule in both sections. Should both Application and Global rules be checked to log an event, or just the Global Rules?

It seems to me that if you log the application rules you would get a lot of unneeded entries in the log. Am I correct in this assuming this or am I all wet (as usual)?

Thanks again to all of you. I appreciate all you help.


Don’t mention it. Finger crossed it will will the connection alive past the first 24h hours too.

Logging is usually used for troubleshooting purposes and thus is mostly enabled for blocking rules.

Though it looks like the global rules default you mentioned are an exception. I guess you can enable logging for all of them if you wish and later disable those who trigger too many log events.

Great Endymion. Thanks again for all the help and advice… Much appreciated


Hi Chuck,

I’m glad that connection is back to normal.
Reading again the advices about “Keeping Alive” I recalled that there is another thing to look at, which I forgot to mention in my list:

  • Disable power management for a network adapter

Basically that is the property on Power Management Tab of your adapter in Device Manager.
You have to think though what you actually want. That is your choice.
I mean if you want the connection to be switched off by power management when computer is unattended (for safety) that can be checked “on”.
Keep in mind that some programs will still keep the connection alive even when that option is set. The example would be - uTorrent.

Why I recall that option - because that is one of known cause of dropouts, when for some reason (say not updated buggy driver) connection may not be reestablished after computer waking up after Stand By…