Driver_Power_State_Failure after installing Comodo Firewall

Hello folks,

2 hours ago I’ve installed Comodo FW and after the restart the keyboard just stopped working. I was able to move the mouse, open apps and stuff, but I couldn’t type at all. I did another restart and same thing happened. Then, after a couple of minutes I got a BSOD with an error message, saying “DRIVER_POWER_STATE_FAILURE”. Did a few more restarts, loaded the BIOS defaults… but it didn’t make any difference. I just kept getting the BSOD.

So I’ve uninstalled Comodo FW and did another restart, hoping that it will fix it… Well, it didn’t. Luckily I had a Restore point from 3 days ago, so I did a rollback and now it’s all good.

Is this a known issue? If so, is there a fix for it?

System specs:
Laptop Lenovo Z510
CPU: Intel Core i5 @ 2.5GHz
OS: Windows 8.1 Pro 64bit

Thanks in advance!

The first thing I think about is that in the past we have seen problems with helper programs that come with touchpad. They would get upset because they could not access CIS processes in memory and blocked activity. We would need to have D+ logs to see if such a thing is happening. But since you uninstalled CIS they are no longer there.

Can you download BluescreenViewer from Nirsoft and post a screenshot of it with the BSOD alert. That assumes a minidump was made and not a full dump; BluescreenView only reads minidumps.

I’ve downloaded BluescreenView, but since I did a system restore, the blue screens are no longer available. I could get Comodo FW installed again and reproduce the BSOD, but I’ll do it tomorrow as it’s 3am here and I can barely keep my eyes open :smiley:

P.S.: I had only the FW installed (not the CIS)

Keep us posted anytime. I always check unread posts of topics I replied in.

Hello again,

I’ve installed Comodo FW again like an hour ago, and so far it works flawlessly… Don’t know what went wrong yesterday :-\

Ok, so the firewall itself seemed to be working properly… untill I decided to give CIS a try. As soon as I restarted the computer in order to complete the installation process, the keyboard froze and minutes after that BSOD appeared.

Minidump attached…

[attachment deleted by admin]

Thank you for the minidump information. Windows only sees one of its own system files as part of the crash. There is no indication a driver from Comodo is involved. In your topic the problem also occurs after you had uninstalled Comodo Firewall which also suggests Comodo Firewall is not involved.

To make sure that CIS or CFW are completely uninstalled run this clean up tool in Windows Safe Mode. Only use option 1 and 2 of the tool.

Also run clean up tools for security programs you had in the past just to be sure they are not of influence. A list of such tools can be found here: ESET Knowledgebase .

On a side note. How did you go from firewall to the suite? Did you use the Add/remove components option? Or did you follow a different strategy?

Fixed clean up tool link

The 1st time problem appeared right after instaling the Firewall and remained even after uninstalling it. Had to do a system restore. The 2nd time I installed the FW, it worked fine for like 2 days or so, untill I installed the whole suite (CIS). And just like the first time, even after uninstalling it, the problem remained untill performing a system restore. I’m pretty sure that there is something about Comodo, that breaks Win 8.1. Another thing that happened while the BSOD is that the laptop (BIOS is Win 8 optimized) wouldn’t restart. Every time I tried, the CPU fan just kept running at highest RPM, the screen stayed black and kept going like this until I plugged it off the power.

As for the CIS installation… Yes, I did the Ädd components" option.

BTW, we could go on TeamViewer, so you can see for yourself what is happening. Let me know if you’re up for it :slight_smile:

Happy New Year :slight_smile:

The timeframes you’re describing do not put Comodo Firewall or Internet Security suite in the spotlight. Only if the uninstallation would leave behind a component then the timeframes could make sense for a possible influence.

To be sure that after uninstalling all components are gone use this clean up tool from the Geekbuddies in Windows Safe Mode. Only use options 1 and 2.

If the problem persists after this we can say for certain there is no influence from Comodo.

We should keep the possibility in mind that this problem may be with Windows 8.1 and or BIOS.

Hi, got the same problem, any fix?

System specs:
Laptop Lenovo Z510
CPU: Intel Core i7 at 2.20GHz
OS: Windows 8.1 Pro 64bit (upgraded from Windows 8)