Drive letters above K: being displayed as C:0 etc

TOPIC TITLE
I have many hard drives. Comodo shows all drives above K: as C:0 instead of L:, C:1 instead of M:, C:2 instead of N: and so forth.

This results in inability to add executables in those drives to for example the trusted files list.


The bug/issue

  1. What you did: No actions required, except having alot of drives
  2. What actually happened or you actually saw: 100% reproducible
  3. What you expected to happen or see: Correct drive letters
  4. How you tried to fix it & what happened:
  5. If its an application compatibility problem have you tried the application fixes?:
  6. Details (exact version) of any application involved with download link:
  7. Whether you can make the problem happen again, and if so exact steps to make it happen: Have alot of drives.
  8. Any other information (eg your guess regarding the cause, with reasons):

Files appended. (Please zip unless screenshots).

  1. Screenshots illustrating the bug:
  2. Screenshots of related CIS event logs and the Defense+ Active Processes List:
  3. A CIS config report or file.
  4. Crash or freeze dump file:

Your set-up

  1. CIS version, AV database version & configuration used: 5.0.163652.1142
  2. a) Have you updated (without uninstall) from CIS 3 or 4: No
    b) if so, have you tried reinstalling (if not please do)?: Yes
  3. a) Have you imported a config from a previous version of CIS: No
    b) if so, have U tried a preset config (if not please do)?: Yes
  4. Other major changes to the default config (eg ticked ‘block all unknown requests’, other egs here. )
  5. Defense+ and Sandbox OR Firewall security level:
  6. OS version, service pack, no of bits, UAC setting, & account type: WinXP SP3 32bit
  7. Other security and utility software installed:
  8. Virtual machine used (Please do NOT use Virtual box): No

[attachment deleted by admin]

I have a “invisible home” from I to L (all four are extension card readers), i see the DVD reader at M, but not the CD burner at N.

Are those drives external drives?

External drives are not seen as safe by design as they are not necessarily continuously monitored.

I can confirm it is not possible to make an executable from a USB stick part of Trusted Files.

It may be by design for the same reason as in the above. May be one of Comodo’s staff members can comment on this?

Hi JuuJuuJuu

We would very much appreciate an answer to Eric’s question, as its difficult to know if this is an issue without one.

Many thanks

Mouse

PM reminder sent

Unfortunately we do need this issue to be reported with all the information we have asked for, if we are to forward it to verified issues.

For the moment I am going to move it to the Orphaned/Resolved child board. If you do manage to aanswer outstanding questions, and PM an active mod, we will of course consider moving it to verified reports.

The devs only look at the Orphaned/Resolved board if they have time, so please do edit the post and PM an active mod if you want it fixed.

Best wishes and many thanks in anticipation

Mouse