Dragon won't start after updating to Version 25

Updated Dragon to version 25 this morning and am no longer able to start the application. I’ve attached the error message. The error is a “Class not registered” when referencing the Dragon program file.

How can this be fixed?

This problem ONLY occurs when attempting to open Dragon from the Windows 8 task bar (desktop). If I start the program via start menu (Start8 in desktop mode), it works perfectly. I also tried starting Dragon from the Windows 8 start screen and it loads fine as well. Hope this helps.

Here’s a link to a discussion on the exact same topic involving Chrome. Thought this might be of some help. 123994 - chromium - An open-source project to help move the web forward. - Monorail

I’ve gotten 2 calls from family members that who are running Windows 8 and I installed Comodo Dragon, and both are complaining of the exact same problem.

Thanks. -SA Jack

[attachment deleted by admin]

I am getting the same error when trying to launch dragon 25.0 from task bar. I am able to run it from desktop icon.
Dell I15 3520 1.7 dual core 4gb ram, windows 8 64 bit

For workarounds you can check out my post here: https://forums.comodo.com/news-announcements-feedback-cd/comodo-dragon-ver-250-is-now-available-for-download-t92242.0.html;msg665128#msg665128 Do note that they are workarounds and not fixes.

I have the same problem!

see my post in german language

It’s worse…try your hyperlinks in outlook.
i don’t know about other email clients.
but dragon won’t work with office properly as the default browser anymore.
At least on my 2 win 8 x64 pc’s with office 2010 pro plus x86…


that’s the office bug, the task bar pinned icon won’t work, auto update win8 x64 won’t work with uac off.
it doesn’t elevate itself.


anyone having shockwave problems too on the above website?
Can’t get shockwave to work either with Dragon 25…

Great even Chrome 25.0.1364.97 m won’t run shockwave either…

It appears to be working correctly here.
Is shockwave present in dragon://plugins/?

[attachment deleted by admin]

Had the same “class” error when launching from taskbar in Win8. Deleted task bar icon, repinned taskbar icon from start menu, everything works fine.

Adobe Shockwave Player - Version: 12.0r112
Adobe Shockwave for Director Netscape plug-in, version 12.0
Do you see the animation on the web page or the screenshot attached to my post??

[attachment deleted by admin]

Thanks Imamba.

Your solution appeared to work initially.

However, another side effect of this problem is that while using my email client (Thunderbird); if I click a link in an email to be opened in my default browser (Dragon), Dragon would not open. When I change the default browser to Firefox, the link opens fine.

So after I followed your solution, I made Dragon my default browser again, went into Thunderbird and tried to open a link in the default browser. It did not work again. Plus, the original “class” error returned.

So I guess that as long as you don’t try to link to your default browser via a program like Thunderbird, your fix hopefully will hold up

Thanks again. -SA Jack

Hi DrHaze,
It is static, however as far as I know this is the way it works now.
There is some slight animation or at least motion when you hover over the yellow/black text.
See reply 10 in the link below.
Adobe Forum

I have sites that it is working on.
Test page below, please note this is a 3rd party test site.
chemgapedia shockwave test page

No luck here keeps giving the same error on chrome or dragon.
can’t load shockwave on that 3rd party website you gave me…

[attachment deleted by admin]

I found a full installer of shockwave…
Once you run the Full installer by it self it fixes the shockwave issue
the third party site works…but the http://www.adobe.com/shockwave/welcome/
still doesn’t work…

Hi DrHaze,
It sounds to be now working correctly IMO, as long as you are seeing the image you posted in reply7.