Dragon tries to start delegate_execute.exe which doesn't exist.

Hello,

Specific symptoms of the bug and steps you can take to reproduce it (step by step).
Go to dragon://flags then change an option (you can change it back if you want) you should now get a button in the lower left to restart Dragon, if you click it then it will try to launch ?:[dragon installation path]\delegate_execute.exe (in my case C:\Program Files (x86)\Comodo\Dragon\delegate_execute.exe) The problem is that the file doesn’t exist.
Added screenshots.

Specific steps you have taken to try to resolve it.
None :embarassed:

Comodo Dragon Version (Stable/Beta) e.g. Dragon 4.1.1.11 (Beta); e.g. Dragon 4.1.1.12 (Stable)
Comodo Dragon Version 30.0 Stable (Full install)
Comodo Dragon Version 31.0 Stable (Portable)
(Haven’t tried older)

Plugins/Themes installed in Comodo Dragon
Adobe Flash Player - Version: 11,9,900,170

Windows version (w/ 32 or 64-bit) e.g: Windows 7 Ultimate (64-bit); Windows XP SP 3 (32-bit)
Windows 8 64-bit
Edit: Potentially a windows 8 specific issue.

UAC status (diabled/enabled) if it applies to you [ for Vista/Windows 7 only! ]
Disabled

System Drive where Windows is installed (e.g. C:, “C” Drive )
C:\

Place (installation path) where Comodo Dragon is installed
C:\Program Files (x86)\Comodo\Dragon

User privileges (administrator, limited user, guest, etc.)
Administrator

If you have Google Chrome installed then please mention it’s version and whether the same issue reproduces with it.
No, but delegate_execute.exe exists for Google Chrome.

Regards,
Sanya IV Litvyak.

[attachment deleted by admin]

Hi Sanya IV Litvyak,
I wonder if this could be Windows 8 specific or maybe 64-bit specific.
I just tried with Windows 7 32-bit and it does not replicate, it relaunches correctly with no request for the mentioned file.

Do you have the delegate_execute.exe file in your dragon installation folder? I think it used to be provided with Comodo Dragon but in 30.0 and 31.0 (perhaps older) it’s not installed (at least for me) so if you’ve updated from a version that did have delegate_execution.exe then it might have been carried over?

Either way, could you try downloading CD 31.0 and get the portable version set up and try that?

Edit: I installed a few versions of Comodo Dragon, down to version 23.1 but none of them had delegate_execute.exe … so the above seems to be wrong, either way could you check if you have the file and could you try the portable version?

Edit 2: I searched for it again and found Comodo dragon about:flags error windows 8 (wonder why I didn’t find that first time I searched? ???) So this isn’t a new issue, the user who made the other thread did use Windows 8 though…

I have tried with both installed and portable versions of CD V31.
Both versions work correctly and neither have the delegate_execute.exe file, the file does not appear on my system anywhere (I do not have Chrome installed).

Edit: I just noticed your “Edit 2”, this does appear to be a Win 8 issue.
If Staff haven’t responded in a day or so, I will point out this issue to them via PM.

Hmm… perhaps Chromium work differently in Windows 7 and Windows 8, perhaps in Windows 7 it launches chromium.exe (dragon.exe) and in Windows 8 it launches delegate_execute.exe?

Thanks :-TU

I have no such file.
CD is updated in the manual.
No problems described are present above.
Win7 32 CD portable.
Edit: The truth of CD is in other section of a disk.

Edit: I too never used Chrome.

Then indeed it looks like a Windows 8 specific issue. (Anyone with Windows 8 who doesn’t see this behavior?)

Hi Sanya and Jenny,
Sorry about about any confusion caused by the edits above, I have also edited my reply 3.

Thanks.

Lots of edits here. ;D

I tried it on my old ■■■■■■ laptop with Windows 7 32bit and it restarts normally without any issues, so yup… probably Windows 8 issue.

Edit: Fun fact, 6 posts in a row (including original post) was edited XD

I have 8.1 and I have the same issue. Perhaps you can address this issue in the next browser release for us Windows 8.1 users. :slight_smile:

While this issue is not of the highest priority, I can assure you that it is being looked into by Comodo Staff. :slight_smile:

Thanks.

i had this problem in 8

change your Compatibility settings to 7 for Dragon 'til it gets fixed