Dragon Portable will not install

I downloaded the latest version and ran install as portable. Regardless of where I try to install it to, a flash drive, external hard drive, or internal hard drive, I first get a location screen, then DNS choice and import screens, and then it starts to install. It creates the directory and then fails with just the message that it did not successfully install. I am running the installer using ‘run as administrator’ and have tried it on two different computer systems using several different flash and external drives. I thought the download may be faulty so I downloaded it twice on each system. Still will not install. From what I read in old posts, the portable installer is not supposed to offer the DNS screen, but it does. I downloaded Ice Dragon and it successfully installed as a portable on a flash drive. Any suggestions?

Hmm try to remove dragon related registry entries, and if it is listed under programs & features try to uninstall it. I was able to successfully install dragon using portable option.

I didn’t want to remove my installed versions, so I used a laptop that it was not installed on. It would not install it to any flash or external drive but I was able to install it to the C drive as a portable version. Then I saw there was a newer version out. I tried to install the new version as a portable after deleting the previous portable install. It failed. I searched the registry and found that even though it is supposed to be portable it left numerous pieces throughout the registry. I ran a find and removed all of them. It will not install as a portable anywhere now. People may wonder why I am trying so hard to get it to install as a portable. On my new computers I am not running any installed software, only portables from a flash drive. I just find it hard to believe that IceDragon installed as a portable with no problem and Dragon won’t.


If using the file browser to get the folder path when trying to install into a custom path and you select a drive with the browser (e.g. c:/) the url returned into the installer is incorrect and will cause the installation to fail. You can fix that by either installing in an existing folder in your desired location or fixing the path returned in the url field (e.g. put c:/Comodo/Dragon instead of the c://Comodo/Dragon).

This issue will be fixed in a release in a few days.

Hope this is the issue that prevented you from installing portable Dragon on your flash drive.

The Comodo Browsers Team.