Dragon lo longer works (not possible to reinstall or uninstall)

Hi and Thanks in advance,

I am new here and I am hoping this is the right section (I do not know what CD or CDI stand for).

I have been used dragon + virtual dragon for a few months (win 8 machine). Then suddenly it has stopped working. I have tried to reinstall and it won’t install. I have tried to uninstall and that doesn’t work either.

Installation problem:
[i]Error message:

error opening file for writing


click retry or cancel


Uninstallation problem:

I cannot find the application from the control panel so I cannot uninstall.

With the installer I am given the option of uninstalling but when I choose it nothing happens…

What to do?


Hi and welcome hekola,
Do you get a repair option when you run the installer?

Try renaming 'C:\Program Files (x86)\Comodo\Dragon’ folder if present to, ‘C:\Program Files (x86)\Comodo\Dragonold’ and run the installer again.

CD = Comodo Dragon
CID = Comodo IceDragon

Please note: Dragons homepage is having issues and not currently downloading the latest version.
Please download the latest version from the release topic.
Comodo Dragon ver 33.0 is now available for download


Worked thanks. I managed to install however it did not install the desktop icons (they were there before) so I have created a shortcut but the biggest problem is that comodo dragon “in virtual mode” too has disappeared.

Is it a different install, should it not come with this installation?

Thanks !

Hi hekola,
Just to clarify do you mean the ‘Virtual Shortcut’ has disappeared or the ‘Switch to virtual mode’ in Dragons drop-down menu’?

If it is the shortcut missing,

  1. Select ‘Run virtual’ from the sandbox tasks screen.
  2. Check the ‘Create a virtual desktop shortcut’ option.
  3. Select ‘Choose and run’, then navigate to the dragon.exe file and open.
    File located in the ‘C:\Program Files (x86)\Comodo\Dragon’ folder.
    This should open Dragon in virtual mode and also create a Virtual Dragon shortcut.
    Run an Application in the Sandbox

Note: If Dragon fails to open in virtual mode, try resetting the sandbox.
Note 2: Resetting the sandbox will remove all data that is stored in the sandbox only.
Reset the Sandbox

Hope that helps.


Thanks for taking the time to send those instructions but I cannot do what I need.

OK let’s re-phrase it. How do I run Comodo Dragon Virtual? I used to have a desktop shortcut which has disappeared.

In your instructions: Run An Application In A Sandbox, Sandbox Computer Security | Internet Security v7.0

I do not have that interface. I have a similar one but it only has “tasks” and not:

General tasks
Firewall tasks
Sandbox tasks

There is a link to : auto-sandbox but I am not sure what it is and it is disabled…

Sorry … :frowning:

Hi hekola,
What version of Comodo Internet Security do you have?
Check this by clicking on the question mark (Title bar controls) at the top right hand corner of the GUI and opening the ‘About’ screen.

If you have version 6 or later, just under the question mark you will see a curved arrow toggle.
Click this toggle to flip to the tasks interface, then click on the sandbox tasks to expand .
The Main Interface-Comodo Help
The Tasks Interface-Comodo Help

You can manually run Dragon in virtual mode, by right clicking the shortcut and selecting ‘Run in Comodo Sandbox’.

In regards to “what is auto-sandbox” which is an entirely different function to running virtual programs, it is probably best explained in the link below.
Auto-sandbox unknown applications as-Comodo Help

Kind regards.
Edit: Corrected error.

I have version 7.0.31…etc

Worked thanks !!!

Not the easiest interface to work with :stuck_out_tongue:

Good to hear that it worked. :-TU

The interface does get easier to use once you become familiar with it IMO.
Adding commonly used tasks to the programs task bar can save time.
Adding tasks to the Task Bar

Kind regards.