Dragon extensions lose settings on startup

Good morning, I’ve been using CD for months now as my main browser, but in the last few days I’ve experienced an odd problem: I’ve installed 3 extensions from chrome’s gallery (adblock+, ghostery, better popup blocker) and each of them loses its settings at browser’s startup. That’s kinda annoying. Any suggestions? Thanks, keep up the good work.

Hi Ektor Badomen,
Do you clear browsing data before or on exit?
This could now be clearing data from hosted apps.

[attachment deleted by admin]

Hi, I don’t do it manually but I’ve got both “clear cookies and plugin data” and “clear history” on exit checked in browser’s settings, which probably ends up clearing data from hosted apps as well. I unchecked “clear cookies etc.” and it looks like the problem is gone, thing is these settings have been the same for months: why would I clear extensions’ settings when deleting cookies?

Hi Ektor Badomen,
Have you tried unticking clear data from hosted apps only, as this is a recent addition.

[attachment deleted by admin]

Yep, unchecked it in the ctrl+shift+del panel and re-checked the “clear cookies and plugin data etc.” setting, lost everything again. Maybe the two of them are not related (I’m trying to guess), or my CD install is now corrupted, or it’s a bug.

I never had this option ticked and it was happening regardless. My only solution right now is to go back to 21.2. I’m not going to update until Comodo gives an all clear. I don’t have time to constantly reconfigure all my extensions (mainly AdBlock, ScriptNo, IE-Tab and a couple of others). Very frustrating if all the configured data is gone to say the least.

Happens to me also!
Clear data from hosted apps unchecked.
If it keeps doing it, I will consider switching to Opera or Avant Ultimate.
EDIT: Already done it, it is rediculuous having to wait to load all extensions and then configure almost each and every one of them. :-TD :frowning:


The issue is related to the “Clear cookies and other site and plug-in data when I close my browser” option.

Please find this option at dragon://chrome/settings/content in Comodo Dragon and disable it. A fix will be available in the next release.

Thank you for your support.

I can confirm it solves the problem, thank you very much! :-TU

George-Silviu Blendea, thanks for this information. :slight_smile:

Fine, I’ll wait for a fix. Thanks, see ya.

You guys seem to be accepting this very well. This is UNACCEPTABLY bad. And how long do we have to wait for the fix?

PS And thanks for losing my scriptno whitelist for me.

You don’t

Thanks George-Silviu Blendea. It was indeed the culprit and disabling the option you mentioned did the trick. :-TU