dr.web cure it

without cpf v3 installed i can download or update the program but with it installed i cant is there a certain setting im missing
anyone else have this problem???
link to dr.web http://www.freedrweb.com/cureit/

[Topic Closed: If issue returns PM an online mod to open]

anyone have this problem,still happening for me,i have to shut down cpf3 to download dr.web cure it


Have you tried disabling Defense+ and if it still doesn’t work, disabled the firewall (so that we know which component that causes the problem)?


its the firewall,i right click on cpf3 icon in system tray and click disable and i can download it,with it on train with safe mode i cant

Hyatt, it appears that I could download it if I wanted. CFP gives me a Warning Block asking if I want to permit the website to change a file. Since I’m not familiar with DrWeb Cureit I didn’t let it download.

The only thing I’ve done with CFP as far as changing anything is to purge the files in My Pending Files and then submit those that are left to CFP. Both the Firewall and Defense+ work perfectly shielding my computer as it passes all the leak tests with flying colors.

ill just have to disable the firewall part for a few seconds when i open dr.web cure it and update it and then ill turn it back on,i have no idea ???ill keep tinkering with it

hey, i think i’ve had the same problem before, right after i install CFP 3.0.13.***, i no longer can download cureit, but i just ignored it, and now i’m using the latest CFP, no problem related to cureit.

What application are you using to do the download?



If you use internet browser to download DrWeb CureIT, try this:

Add one more rule to your internet browser rule set:
Allow TCP Out From IP Any To IP Any Where Source Port Is Any And Destination Port Is In [64000-65535]:

Make sure this rule is above Block All Unmatching Requests rule.

Try to download CureIT without disabling CFP.

Hi Guys,

I found this thread and decided to check it out with CureIt.
I did use the program through several versions/updates without any problems.
That was with Comodo v2.
I downloaded the latest Dr.Web CureIt 4.44. The download went without any issues… compare to initial request.
but then…Oh boy!.. Runing with Defense+ “Clean PC”.
1) first run of CureIt needs unRARing into temporary folder.
I immediately got an error from CureIt that it cannot be done and the list of files that should be unarchived… I closed that and tried again.
2) This time ??? the Defense+ kicked in with those many “oranges”. (this is something to discuss
in different thread…but it makes any installations practically impossible… try Adobe CS3 Suite… Yeah!)
After several identical answers to treat and remember(!) Setup.exe as installer/ updater and 69 times of “program accessing the keyboard…” The installation got unresponsive.
3) and then Comodo’s subsequent request could not be answered (green Ok button cannot be pushed in)
4) I fired up Sysinternals Process Explorer to Stop/Kill not responding CureIt Setup… and got a Black Screen.
The only way after that was Reset button.

After Restart the Defence+ was switched Off and - “Bob’s your uncle” - all fine with CureIt installation and run, and scan

So, ??? it is really something fishy in CureIt-Comodo 3 relationship.

My regards

I use Cure It and have it on my PC along with CFP 3.0, i’ve never had any problems running it or checking for new updates via the program and downloading them.

Defense+ does pop up a fair bit of alerts when i load the program to do a scan, saying cure it is trying to create temporary files or directories and i just click allow for it all. and then it runs and scans my PC without any further alerts from CFP 3.0

i have the firewall set to firewall training safe mode. defense+ clean PC mode and connection type P2P

If you want it to be completely silent, change the process access rights for the cureit.exe to Allow for Protected Files/Folders.


ah cool :slight_smile: I didn’t know that, only thing though is Cure IT is a standalone product, to update it one just downloads the newer cureit.exe, so everytime CFP 3.0 recognises it as a new program on each new download and has to be trusted again, its a bit like a file that keeps changing and i don’t run cureit everday, maybe once or twice in a week now, and everytime there is a new cureit.exe version

thanks for that though, cause i didn’t know that, i’ll try that with avg roolkit it doesn’t have an update that often but creates the same amount and same kind of popups as CureIt does.

cheers :■■■■

i thought i’d just look into that ^ for avg roolkit all its access rights was on allow, that inludes Protected Files/folders. i noticed the one thing on ask for which there is only a choice of ask or block is executable file. now if there was an allow for that then eachtime i load that program might nto trigger any alerts. but it does, it actually produces more alerts than cureit when its launched. couldn’t find cureit in my computer security policy list of apps, will run cureit later been a bit of a while since i have bothered to and there is probably a new cureit.exe download for it anyway.

thanks for the mention of Protected Files/Folders in access rights though. i noticed them stuff before but i never figured out what i could use them for lol. until you made it clear what it can be used for by giving cureit as an example :slight_smile: nice one dude

am running CureIt now, there was a new cureit.exe for it, so i downloaded it. yeah cureit does create several or more pop up alerts when loaded its simplier to just click allow and never tick remember me, after all eachtime you run cureit it will be a new cureit.exe file you will be running. there is no point in creating any settings for cureit in the firewall when its all temporary.

anyway it downloads and runs fine for me like usual. no idea whats probs these guys are having or what is triggering it, only 1 thing i can comment on and it might be of help for some. that is when you first click the shortcut to launch cureit, that is if you have created a shortcut for it, then the first time it says it can’t unpack whatever files and run cureit, ignore that! just close that window and click the shortcut again! the 2nd time you do it will unpack all the files and load cureit.

Hi Ron_75,

Thanks for that and that is what (unpacking) I noticed too and described in the scenario, I think… but it would be interesting to find out why the shortcut is treated like that?

I just checked - running from the base location (no shortcut) is fine.
And then there is more : there were only 2 Defense+ popups.

  • the first one didnot have an option Trusted so I responded - Updater/Installer
  • the second popup did have Trusted option, which I set with “remember”
    Now I can run it fine without popups: either exe from base dir or using shortcut as well!

Here is another trick :wink: run-once it first time from base directory.

My regards

Hi SiberLynx,

I think in the command line paremeter in the shortcut properties box a syntax command/key could be added to stop it doing that not loading right first time. sorry for the termonology but thats what they used to call it, now i guess its just called nothing in windows dialog boxes for shortcuts lol. i am sure i can figure out how to get round that shortcut, cos i used to do so back on win95 or win88 for shortcuts to exe programs that unpack before running.

if i figure this one out especially when i can’t remember how to on such stuff right now lol. then i will post and let you know the fix for it.

in the meantime though its just a nusisance thing so defintely not something one should regard as a anything more than a slight irritation or nuisance

I have cureit.exe defined in my D+ Application rules and I do not receive any prompts when downloading and running the new cureit.exe. The file does show up as a modified file in my pending files though. This may be another CFP bug because I think CFP should still prompt if the cryptographic signature changes and not rely on me to analyze it in the pending files. In my case, with a rule in place, it does not ask about the new cureit.exe


[attachment deleted by admin]

Hi adric,

I will try that and see, I think during installation of CFP 3 sometimes programs or files that changes get trusted and never asked or get put in pending file list ever again, and sometimes the scenario is reverse where they do.

for instance i have CFP installed for weeks, and a upnp.dll and a *.sys file for a program that keeps getting recreated would always end up in pending file list as a new or modified file upon reboot.
I uninstalled and reinstalled CFP 3 a day or two ago because of a nuisance well that and i wanted to clean all redundant entries for previous installs and reg legacy[old] entries and silly folders in application data folder in my documents/user settings. so i chose to uninstall CFP 3 and do a thorough cleanup and then install it back. now them two files which are a Ms upnp.dll file and a *.sys file of a program that always changes never end up in my pending list this time. which for me is a good thing, since i trust those files and having to keep adding them to my safelist is irritating.

so your CFP 3 is trusting cureit.exe and never treating a new download of it as a new file, just a changed file. thats convenient it wouldn’t be something i’d worry about since you know the new exe file is clean, btw i always scan anything i download with my AV before i do anything with it, be it an exe, divx, avi, mp3 whatever everything i download i scan its out of habit been doing that for years lol.