Downloads hang up

I have got a problem with CIS. Some 2 weeks ago, I noticed, my internet connection was somehow messed up.
I couldn’t download anything bigger than a few kBytes - the download stopped at some random point and hung up. I could pause it and unpause again and then it worked for next few kilobytes. I also couldn’t get any reasonable response from remote servers I administered. FTP transfers seem ok.
After uninstallation of CIS, everything was working well. But disabling only or shutting it down didn’t help (I didn’t try to kill all services of CIS, since I don’t know which belonged to it). I tried older version of CIS, didn’t help either.
I don’t remember installing any new software which may have caused that bahavior.

I attach summary of packets from Wireshark - where I see this:

[TCP ZeroWindow] univ-appserver > http [ACK] Seq=573 Ack=1973756 Win=0 Len=0

→ when the download is stuck.

univ-appserver > http [FIN, ACK] Seq=573 Ack=1973756 Win=0 Len=0

After unpausing:

mosaicsyssvc1 > http [SYN] Seq=0 Win=65535 Len=0 MSS=1460


Operating system Win XP SP3 32 bit.

Thank you for your help.

[attachment deleted by admin]

No one knows?

What version of CIS are you using? Can you show screenshots of your Firewall logs (Firewall → Common Tasks → View Firewall events) and Global Rules (Firewall → Advanced → Computer Security Policy)?

Do you have other security program running in the background? Try temporarily disabling them and see if that works.

We are gonna take a look to see if there are some old drivers of your previously uninstalled security programs are still around. Go to Device Manager → View → show hidden devices → now look under Non Plug and Play drivers → when you see a driver that belongs to your previous security programs click right → uninstall —> reboot your computer.

When the problem persists make sure there are no auto starts from your previous security programs. Download Autoruns and run it.

This program finds about all auto starts in Windows. This tool can therefore seriously damage Windows when not handled properly. After starting go to Options and choose to hide Windows and Microsoft entries, to include empty locations and then push F5 to refresh.

Now check all entries to see if there are references to your previous security program. When you find them untick them. After unticking reboot your computer and see what happens.