Download accelerator Plus

yes my firefox is brown but that launches just fine.

I have tried defining it as a installer/updater and that did not work

First let’s look at what happens when you start DAP a) from firefox b) from the command line. What files start in process explorer? Are any brown? Look under services.exe as well as explorer.exe. Also tell me about any files [Edit: from the same vendor] whether newly started up or not.

Then (and the sequence is important) I think from your logs that you have quite a few files being sandboxed, including firefox, so lets sort that out.

Go to ‘My Pending Files’ and move any file you trust to ‘My Safe Files’. These should include Firefox. If not add Firefox manually to My Safe Files.

Go to ‘My Safe Files’ and add a) the whole DAP directory. b) the whole Program Files ~ Common Files directory. (Presuming you know there is no malware in these directories. You can do an AV scan to check).

Finally look in the Computer Security Policy - is there an entry for explorer.exe, maybe as part of windows system files? If not add an entry and apply the Windows System predefined policy to it. If there is an entry but it is not defined as windows system please tell me.

You MUST then reboot. Then look at process explorer again and see if anything in brown. If not then we have established a baseline where most things should function normally.

Now try DAP again from Firefox and Explorer.

Hopefully that will have fixed things. If not your observations using process explorer should indicate the problem - also please post D+ logs again, taken after trying to relaunch DAP.

Best wishes

Mouse

firefox is still brown but DAP is now pruple and it is still not showing the GUI

Hi

I’ve now installed DAP myself, but unfortunately I cannot replicate your result.

I realise it is frustrating to have to carry out the tests I have described, and post the infomation I ask for. However given that I cannot replicate it on my machine, this really is the only way.

Could you just check to make sure that you have done everything I suggested, in the order I suggested it. For example have you disabled all highlighting except jobs in process explorer? I think perhaps not otherwise nothing would be purple. Please make sure you have rebooted afterwards. Could you also then post all the information I requested. In addition a screen shot of process explorer would be helpful.

With best wishes

Mouse

Hi, I am also having the same problem with DAP. When i first installed comodo, it was running fine. But after a program update, it couldnt work anymore. The process is still running but no GUI. I have tried rolling back to my old version… now it cannot work. I have to uninstall comodo for it to work… HELP plz

Just waiting for feedback from the user above. Hopefully he will come back with the further information we requested.

If not maybe you would be willing to provide the information?

Mouse

Oh meanwhile. Could you maybe try:
0) FIRST define DAP.exe as an installer/updater in the computer security policy

  1. THEN renaming guard32.dll in the main CIS directory, and in the repair directory AND rebooting. THen re run DAP.
  2. THEN Try disabling D+ a) using the slider b) using the tick box to disable permanently and rebooting. Then re-run DAP. Does either solve the problem?

If you can come back with this info, we will have at least eliminated some possibilities

Best wishes

Mouse

i am currently using 4.0.1.135239.742 Do you need me to update to the latest version? I do not have guard32.dll in my main CIS, only in repair folder

I have videos of everything I have done where can I send them

That worked. I renamed those files rebooted still did not work then I went to D+ advanced
D+ settings checked deactivate d+ permanently and rebooted now when I click the the .exe the GUI shows up

yea at least now we know the cause, is there any solutions to enable d+ with dap?

WOW, videos eh? If not to big then append them zipped. Else you can email me - just PM me if you need my address.

OK, did you update CIS by the way? Best to try with D+enabled and updated CIS (& reboot) before anything else if not.

Then try with D+ disabled using the slider. IF this works then we can narrow things down by trying training mode, then reverting to safe mode, seeing if it works and looking at the logs & computer security policy.

Best wishes

Mouse

Apologies, I had forgotten that it is in C:\Windows\System32. You could try renaming it there, see if it will run with D+ enabled and guard32 disabled, but probably not!

Best wishes

Mouse

the files were rather large it was a recording of everything you said to do and it not working. If I enable d+ like you said it will not work. I have tried training mode and everything you listed above but to no avail

OK the final things to try are disabling image execution control, and shellcode injection protection, then rebooting. Go to Defense+ ~ image execution control and use the slider.

If this doesn’t work disabling D+ permanently is the best you can do, I think unless anyone else has any ideas.

Let’s see what happens before shifting this to bug reports.

I will look to see how you can get me the files, in case they suggest anything. Think there is an upload service that Comodo uses.

Best wishes

Mouse

I’m going to move tis to bug reports to see if we can get it fixed. Would you please add the information about your system requested in the stickies at the head of the bug reports section here.

Meanwhile if you have the results of the other tests I suggested please do post them.

Your big video files can be uploaded to: http://ifile.it/ If you do this please post a download link in the topic.

Best wishes

Mike