DON'T UPDATE - if you use Sandboxie

It seems there are some risks if the Sandboxie driver is set to Automatic and starts too early…

So I’ve put together an utility for me and anyone else who experiences this incompatibility between CIS 4.1 and Sandboxie, that will automatically start Sandboxie and its driver at boot, after a 20 second delay.

Just run the installer and follow the instructions…

Notes:

  • this app is safe and doesn’t make any unwanted changes to the system
  • it doesn’t use any additional resources, it will exit after starting Sandboxie

I did this for personal use, but I thought I’d share it here too… If you have any questions, feel free to ask.

[EDIT] See the post below for downloading…

Hi Phaser.That seems to be a great idea,however the fixed 20 second delay might cause issues on some systems,ie. slower systems or those with a lot of programs running at startup.Perhaps if you could vary the delay time?

andyman35, not really… Applications from startup folder load after user login, after other programs and services.

Use the installer below, and you can edit the properties of the shortcut from startup folder:

"C:\Program Files\Sandboxie\delayexec.exe" start_sboxie.exe [b]20[/b]

You can replace 20 with the number of seconds that you want.

I’ve made a “final” version with an installer and instructions (it automatically adds a startup entry)…

Before, there was a problem with Comodo Sandbox (because the files were executed each time from random temp folder) but everything should be fine now.

DOWNLOAD from attachment or from here:

  • Version 3 with installer
  • Version 2 (you have to copy manually to startup folder, and may not work with Comodo Sandbox)

[attachment deleted by admin]

v3 don’t work for me… how can i completely remove registry entries etc? Can’t find any uninstaller
(my fault, didn’t take a registry backup before >:( )

too strange, installed inside sandboxie (not in forced folder) ???, try again

v3 don’t work for my Vista, but i use succesfully the v2 as a shortcut to desktop :■■■■

Make sure the files are not sandboxed… You should disable Comodo sandbox while installing and add the files delayexec.exe and start_sboxie.exe to “My Own Safe files”.

You can stick with v2, if that works for you.

There’s no need for an uninstaller…
If you want to remove it, delete the shortcut from startup folder and remove the files delayexec.exe and start_sboxie.exe from the install folder (no registry entries are added).

Thank you so much for your time & help :-TU
When is possible, please provide some tech info about how it works and bypass CIS blocking

It’s not very complicated… Basically, the CIS blocking of Sandboxie cand be “bypassed” if you start the driver from the command prompt or using a BAT script.

I’ve used DelayExec (an utility that delays the execution of a program) to run a compiled script (using ExeScript) with administrative privileges. And the installer is just a WinRAR self-extracting archive (SFX) that copies the files and adds a startup entry.

This is what the script contains:

net start "sbiesvc" [b]net start "sbiedrv"[/b] cd %ProgramFiles%\sandboxie\ start /I SbieCtrl.exe cls

Hello phaser

Thanks for version 2. Will be upgrading from 3.14 to version 4.1 soon

I have version 2 working on my XP Pro Sp3. Any way possible to have a non install version that is comaptible with Software Restriction Policy. I have the executable in it’s own folder in Programs Directory. SRP stops it dead cold.

Ralph

oldCoCo3user, from what I understand now, there is no need for it on Windows XP…
The bug manifests only on Vista/7. So you should be fine upgrading…

Excellent work Phaser,SBIE junkies everywhere will be grateful. :-TU

Actually I figured out my own alternative method for making Sandboxie to work.

Disable Sandboxie from starting up with Windows as somewhy CIS, when not fully started, CIS always denying everything related to making Sandboxie to work, despite the fact I added all possible Sandboxie files to trusted list. Anyway, after CIS has fully started and working, only then start Sandboxie Control and it will work!

New version 4.1 of CIS is rather “racist” than “more secure”.

The most recent update seems to have fixed this problem for me. Sandboxie started properly this morning even though Defense+/Advanced/Defense+ Settings/Monitoring Settings/Device Driver Installations was checked.

Yeap, the update fixed the problem for me too.

:-TU :-TU THANKS COMODO!! :-TU :-TU

Thanks for not making us choose between you and Sandboxie. :slight_smile:

Same problem with latest Beta of CIS 5.0.157302.1066

Sandboxie driver does not start.

Report here by Matty_R

Posted here aswell so you do not try the beta if you run Sandboxie.

Will run in Windows7 in VM

Dennis

Had the same problem and found this thread. This is an ugly bug as i would prefer the protection of CIS and Sandboxie just as a backup for worst possible situations so to say. Im going to give the problem a shot that was posted earlier in the thread. Will report back if it works for me. Comodo please fix this bug and make Sandboxie compatible out of the box,this is a big one for me :cry:

Just to report back,the previous application posted by Phaser works fine for me on Windows 7 x86 with the new CIS 5 beta. So its a fine workaround until Comodo squashes this bug out.

On another note,man i like the detection of this cloud so far,and i imagine with more time it will only improve! Also seems to run light on my system

For some reason Phasers little program isnt working now. Im going to try something,and will report back

i have windows7 home premium on a 64-bit machine and comodo and sandboxie seem to co-exist just fine. :slight_smile:

I remember the bad old days when Comodo v4.1 would not let Sandboxie 3.45 run on my Vista laptop, but I have had the very positive experience of Comodo v4.1 getting along perfectly with Sandboxie v3.46 on my Win 7 x64 desktop.

~Maxx~

It may in x64 but does not in x32 systems.

It is the same in V5 as V4 (first releases until they fixed it) it will not let the sandbox driver run, the only way for it to run is to untick Device Driver Installations in Defense+

Still not fixed in latest release.

Dennis