Don't start Comodo at boot

Now I have no idea if this is possible or not, I’ve spent a day trawling the forums and trying things out without success.

First off the reason for my question: I have a server which I only have remote access to and I managed to lock myself out of it by incorrectly setting up Comodo. I had to get and engineer to remove Comodo. As I want to try a few things out and so may cock things up I’d like a get out of jail card - i.e. to be able to power cycle the server to get back in.

So I have a test machine which I have been playing with. I can enable remote desktop by enabling port 3389 and then placing that rule above the ‘block everything’ rule. But I can lock myself out by accidentally on purpose moving the remote desktop rule so it comes after the block everything rule.

I have tried…

  1. Setting cpf.exe to not automatically start (using msconfig)
  2. Setting cmdagent.exe not to automatically start (using the management panel)

But I can still lock myself out by (accidentally on purpose) putting the allow remote desktop rule after the block everything rule. The only ways (I found) to correct this were to physically log in and then chenge the rule order back or uninstall comodo (a bit drastic).

I can’t do a boot into safe mode or safe mode with networking to sort this out.

Then the only solution is call the engineer.

Any ideas? Or am I just after the moon on a stick?

Cheers,

G