Doesn't loading links in secure sites.

When accessing secure sites i.e. Internet Banking, I cannot access the next page unless I change the security level to ‘allow all’ then back to ‘custom’ when page is loaded. I am a new user to this firewall and do not understand all the ‘fine tuning’, so I may be missing something.!!! Can some one help in plain english please???

Hi Tony,
Secure sites use port 443, non-secure use port 80. In your custom setting make sure you’ve allowed communication on port 80.